pm-utils: typo in set_sata_alpm()

Bug #900930 reported by Colin Ian King on 2011-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pm-utils
Won't Fix
Low
pm-utils (Ubuntu)
Low
Martin Pitt

Bug Description

function set_sata_alpm prints "Setting SATA APLM on %s to %s...", in fact this should be "Setting SATA ALPM on %s to %s...".
(APLM --> ALPM).

set_sata_alpm() {
    # see kernel commit 6013efd8860bf15c1f86f365332642cfe557152f
    kv="$(uname -r)"
    [ "$kv" ] || exit $NA #for paranoia's sake
    [ "${kv%-*}" \< "2.6.33" ] && exit $NA # avoid fs corruption
    for f in /sys/class/scsi_host/host*; do
        [ -w "$f/link_power_management_policy" ] || continue
        printf "Setting SATA APLM on %s to %s..." "${f##*/}" "$1"
        echo "$1" > "$f/link_power_management_policy" && echo Done. || \
            echo Failed.
    done
}

Be nice if this was fixed.

Related branches

Changed in pm-utils (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → precise-alpha-2
Steve Langasek (vorlon) on 2011-12-08
Changed in pm-utils (Ubuntu):
status: New → Triaged
importance: Undecided → Low
milestone: precise-alpha-2 → none
Changed in pm-utils (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Martin Pitt (pitti)

function set_sata_alpm prints "Setting SATA APLM on %s to %s...", in fact this should be "Setting SATA ALPM on %s to %s...".
(APLM --> ALPM).

Created attachment 55434
Fix typo

Martin Pitt (pitti) wrote :

Forwarded upstream with a git formatted patch.

Martin Pitt (pitti) wrote :

Committed to Debian packaging git.

Changed in pm-utils (Ubuntu):
status: Triaged → Fix Committed
Changed in pm-utils:
importance: Unknown → Low
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pm-utils - 1.4.1-9

---------------
pm-utils (1.4.1-9) unstable; urgency=low

  * Add 26-inhibit-on-right-status.patch: Do not use the exit status of log
    rather the exit status of the hook thereby allowing inhibit to work.
    Thanks to Ariel Cornejo for the patch! (LP: #665651, Closes: #633147)
  * Add 01_xfs_buffer_arguments.patch: pm/power.d/xfs_buffer: Fix wrong
    argument ordering. Thanks to Andre Draszik for the patch!
    (LP: #645974)
  * debian/rules: Remove the journal-commit and readahead scripts. Recent
    measurements have shown that they do not save any power in different
    workloads on rotary disks, and in fact increase power usage on SSD.
    (fd.o #44627, LP: #900923) This also avoids bugs caused by the
    journal-commit script. (Closes: #625606, LP: #891688)
  * Add debian/power.d/{pci_devices,usb_bluetooth}: Set USB bluetooth to
    autosuspend and a safe subclass of PCI devices to low-power mode during
    powersafe mode. (fd.o #44672, LP: #911325)
  * Add debian/patches/03-fix-alpm-typo.patch: Fix typo in sata_alpm hook.
    (fd.o #44676, LP: #900930)
  * debian/rules: Stop install hal-cd-polling. hal has been obsolete for
    years, so don't waste cycles for checking for hal. (LP: #898564)
  * debian/rules: Stop installing sleep.d/49bluetooth, it is not necessary any
    more with current Linux kernels. (Closes: #623750)
 -- Martin Pitt <email address hidden> Mon, 16 Jan 2012 15:55:45 +0100

Changed in pm-utils (Ubuntu):
status: Fix Committed → Fix Released

pm-utils hasn't been touched in eight years, none of this is likely to get addressed. Closing bugs and disabling the bz product.

Changed in pm-utils:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.