pm-utils: power.d/hal-cd-polling probably should be removed

Bug #898564 reported by Colin Ian King on 2011-12-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pm-utils (Ubuntu)
Low
Martin Pitt

Bug Description

/usr/lib/pm-utils/power.d/hal-cd-polling seems to be redundant now that we aren't using HAL, and hence should probably be removed, or at least marked non-executable.

It serves no purpose and consumes a bunch of CPU cycles to execute for a no-op every time pm-powersave is called.

Related branches

Changed in pm-utils (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → precise-alpha-2
Steve Langasek (vorlon) wrote :

Is this actually worth diverging from Debian on? Since hal is no longer part of the installed system, the "command_exists hal-disable-polling || exit $NA" check exits early. Yes it consumes some CPU cycles and should go away, but I would expect the actual impact is trivial.

Colin Ian King (colin-king) wrote :

Steve, agreed, it's a minor overhead - I just wanted to ensure that the HAL left over cruft was being flagged up as redundant and causing some extra overhead. Just wanted to save a bunch more fork/exec calls (e.g. on boot and AC/battery actions) and a few more bytes of space on the disk. I just like to see old cruft being removed if possible.

Colin

Steve Langasek (vorlon) wrote :

agreed that it's cruft that should be removed, but we ought to do this upstream in Debian and I don't see any reason this should be tied to alpha-2.

Changed in pm-utils (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
milestone: precise-alpha-2 → none
importance: Undecided → Low
status: New → Triaged
tags: added: battery-power-consumption
Martin Pitt (pitti) wrote :

Will do this in the Debian git.

Changed in pm-utils (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
Martin Pitt (pitti) on 2012-01-16
Changed in pm-utils (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pm-utils - 1.4.1-9

---------------
pm-utils (1.4.1-9) unstable; urgency=low

  * Add 26-inhibit-on-right-status.patch: Do not use the exit status of log
    rather the exit status of the hook thereby allowing inhibit to work.
    Thanks to Ariel Cornejo for the patch! (LP: #665651, Closes: #633147)
  * Add 01_xfs_buffer_arguments.patch: pm/power.d/xfs_buffer: Fix wrong
    argument ordering. Thanks to Andre Draszik for the patch!
    (LP: #645974)
  * debian/rules: Remove the journal-commit and readahead scripts. Recent
    measurements have shown that they do not save any power in different
    workloads on rotary disks, and in fact increase power usage on SSD.
    (fd.o #44627, LP: #900923) This also avoids bugs caused by the
    journal-commit script. (Closes: #625606, LP: #891688)
  * Add debian/power.d/{pci_devices,usb_bluetooth}: Set USB bluetooth to
    autosuspend and a safe subclass of PCI devices to low-power mode during
    powersafe mode. (fd.o #44672, LP: #911325)
  * Add debian/patches/03-fix-alpm-typo.patch: Fix typo in sata_alpm hook.
    (fd.o #44676, LP: #900930)
  * debian/rules: Stop install hal-cd-polling. hal has been obsolete for
    years, so don't waste cycles for checking for hal. (LP: #898564)
  * debian/rules: Stop installing sleep.d/49bluetooth, it is not necessary any
    more with current Linux kernels. (Closes: #623750)
 -- Martin Pitt <email address hidden> Mon, 16 Jan 2012 15:55:45 +0100

Changed in pm-utils (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers