sched-powersave is outdated

Bug #774643 reported by Adam Porter on 2011-05-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pm-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pm-utils

/usr/lib/pm-utils/power.d/sched-powersave

This file is outdated, because these controls do not exist anymore:

sched_powersave() {
    for pool in mc smp smt; do
        dev="/sys/devices/system/cpu/sched_${pool}_power_savings"
        [ -w "$dev" ] || continue
        echo $1 > "$dev"
    done
}

$ ls /sys/devices/system/cpu/
cpu0 cpu1 cpufreq cpuidle kernel_max offline online perf_events possible present probe release

This is on Maverick.

Serge Hallyn (serge-hallyn) wrote :

Please reply if this is still an issue on a supported release.

Changed in pm-utils (Ubuntu):
status: New → Invalid
Adam Porter (alphapapa) on 2014-04-24
Changed in pm-utils (Ubuntu):
status: Invalid → Confirmed
Adam Porter (alphapapa) wrote :

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.10
DISTRIB_CODENAME=saucy
DISTRIB_DESCRIPTION="Ubuntu 13.10"

$ cat /usr/lib/pm-utils/power.d/sched-powersave
sched_powersave() {
    for pool in mc smp smt; do
        dev="/sys/devices/system/cpu/sched_${pool}_power_savings"
        [ -w "$dev" ] || continue
        echo $1 > "$dev"
    done
}

$ ls /sys/devices/system/cpu/
cpu0 cpu1 cpu2 cpu3 cpufreq cpuidle kernel_max microcode modalias offline online possible power present probe release uevent

Please do not mark bugs invalid without using the given shell commands to see for yourself that it's still an issue on a supported release.

This happens over and over on Ubuntu bug reports: they languish for years, then someone comes along and marks them invalid for the sake of tidying up the bug tracker. But said someone doesn't even put forth minimal effort to check the bug's status; instead they whack everything over a certain age with their "invalid stick." This is insulting to the reporter who spent his valuable time contributing a detailed bug report to the project.

As a result, people like myself, who have reported hundreds of bugs, decide to no longer do so, because it is ultimately a waste of their time. As a result, Ubuntu and its community suffer.

"First, do no harm."

Jérôme (jerome-bouat) wrote :

Same bug on 14.04 LTS release.

--------------
a@B:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty
a@B:~$ ls /sys/devices/system/cpu
cpu0 cpuidle kernel_max microcode modalias offline online possible power present uevent
a@B:~$
---------

/usr/lib/pm-utils/power.d/sched-powersave :
------------------
(...)
sched_powersave() {
    for pool in mc smp smt; do
        dev="/sys/devices/system/cpu/sched_${pool}_power_savings"
        [ -w "$dev" ] || continue
        echo $1 > "$dev"
    done
}
(...)
----------------

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers