i8042 unbind required for keyboard/mouse to be useable following suspend/resume & hibernate/resume cycle

Bug #23497 reported by mike powers jr. on 2005-10-08
92
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Declined for Feisty by Sebastien Bacher
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
Declined for Feisty by Sebastien Bacher
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
Declined for Feisty by Sebastien Bacher
pm-utils (Ubuntu)
Medium
Unassigned
Declined for Feisty by Sebastien Bacher

Bug Description

After installing Breeze RC1 two days ago, I have tried the hibernation feature.
The system suspends to disk just fine. Upon powering the laptop up from
hibernation, I am prompted for a password or the ability to switch users.
Unfortunatley the touchpad and keyboard both seem to be completely unresponsive
at this window. I have tried ctrl+alt+F1 to get to terminal...that did not work
either. The odd thing about it is after sitting idle for a few minutes, the
screensaver started, and touching the toucpad would stop the screensaver and
show the same login/switch user prompt. at this point the cursor is visible, but
it still does not move. The keyboard is also still unresponsive. This is on a HP
Pavillion ze4805us laptop.

Herman Bos (hbos) wrote :

I Can confirm this bug on my Acer 1511LCi.

Is extra information needed?

I could log in with ssh and kill xscreensaver and after that shutdown gnome by
usb mouse.
During shutdown i noticed a whole list of keyboard related errors and it failed
to set some scancode to 0.

If requested I can write down the complete error.

If any use my dmidecode is here:
http://users.lichtsnel.nl/~spacey/dump/dmidecode

Simon Law (sfllaw) on 2006-05-05
Changed in acpi-support:
status: Unconfirmed → Confirmed

I have a similar problem on Feisty... 30% of the time I resume from Suspend (to RAM), the keyboard and touchpad on my Inspiron 6400 are dead. Plugging in a USB keyboard and mouse lets me shut down.

Interestingly, sometimes I can suspend again (with the USB mouse), and the laptop's keyboard/touchpad work after resuming again. Not always, though. Sometimes it just locks up after the second resume.

So... this is still an issue?

Does the workaround in Bug #22931 help anybody?

Scott Robinson (scott-ubuntu) wrote :

If you are having this issue under feisty, please try the attached package.

This solved the issue on an nx7300. It should cause no ill-effect to other machines. (also tested against a Presario 2200)

Scott Robinson (scott-ubuntu) wrote :

Attached is the patch to generate the above acpi-support package.

I am nominating this patch for inclusion into feisty.

Scott Robinson (scott-ubuntu) wrote :

There is an issue with my i8042 rebinding patch. The resume script priority should be changed to 40-ish.

Basically, it should be after 35-modules-load and before 65-console. The reason is the rebinding takes a moment, so in X sometimes a user won't be able to type for a few seconds. Furthermore, if the rebinding occurs after X switches in, on synaptic touchpads the scrollwheel won't be active. (unless the user switches to a text console and back.)

Andrew McMillan (karora) wrote :

Hi,

With my HP Compaq nx6320 I was having issues with the keyboard usually not working after a restore.

Adding the i8042 unbind before suspend and re-binding it on resume appeasrs to have solved the problem for me. Well I have just suspended to ram four times in a row, and I'm still able to type this comment!

Thanks,
Andrew McMillan.

This can be fixed in userspace by unbinding and then re-binding the i8042 driver. This issue is also apparently fixed in 2.6.21 upstream, so it'd probably be cleaner to pull the commit from there if it can be found.

If it can't be fixed in the kernel, I'll do it in 'acpi-support'.

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in acpi-support:
assignee: mjg59 → nobody
Paul Sladen (sladen) wrote :

Andrew McMillan: if you get a catch, could you try to locate this change to fix the i8042 rebind upstream (git/patch).

Jeff Abbott (fdivbug) wrote :

I installed the Feisty beta and was experiencing the same issue -- almost every time I resumed from sleep, my keyboard and mouse wouldn't work. I created the suspend and resume scripts myself and it completely fixed the problem. This is with my HP Compaq nw8440 laptop, so I suspect it's something endemic to HPs. Just adding another report of success with this fix.

Scott Robinson (scott-ubuntu) wrote :

I have thus confirmed it on nx7600, nx700, nx6320. You bring that to nw8440.

However, I do know it isn't endemic to HPs as I have tested against several HP laptops where this isn't an issue. Likely it's nx and nw business series machines.

Scott Robinson (scott-ubuntu) wrote :

Sorry, that should have been nx7300.

Juho Vuohelainen (yuho) wrote :

Bug also present in HP nc8430. Suspend and resume scripts fixed it.

So, if removing and reloading psmouse doesn't help (I have a Dell Inspiron 6400), is this not the bug for me? Should I file a new one?

Jeff Abbott (fdivbug) wrote :

Jon,

That used to fix the problem for me in Edgy with my HP Compaq nw8440, so it's possible that you're seeing the same issue now. Try running the following two commands after waking back up:

  sudo sh -c 'echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind'
  sudo sh -c 'echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind'

Obviously if you've got no keyboard you'll need to this via ssh or plug in an external USB keyboard.

If that helps, then the fix listed above would work to resolve the problem you're seeing with your Dell, too, so I'd snag the suspend and resume scripts from the patch until they make it into acpi-support proper.

Scott Robinson (scott-ubuntu) wrote :

Paul, it's getting close to freeze... Is the patch from upstream going in the kernel?

Or, will you include the scripts in acpi-support? I have tested them on several laptops, and as far as I can tell they have no ill-effect. (Which is the expected behavior...)

Stéphane Graber (stgraber) wrote :

Same issue and working patch (thank you very much) on HP Compaq nx7400

Sebastien Bacher (seb128) wrote :

The target option is to use to target other version than the current unstable one

Up until about a week ago, I also had this problem, but it seems to have disappeared with a recent update.

I've now run about 10 consecutive suspend-to-ram cycles and the keyboard has worked every time. Either I've been very lucky, or a fix has been committed to the kernel or to acpi-support.

I'm using kernel 2.6.20-14-generic (amd64) and acpi-support 0.95.

Swistak (swistakers) wrote :

I confirm the patch working on my HP nx6310 with Feisty Beta. I would be glad to see it in Feisty Final.

JT (spikyjt) wrote :

Works a treat on my nx7400 too.
I am also using kernel 2.6.20.14 and acpi-support 0.95, but it did not work by itself (only very occasionally as reported by others).
As the patched package kindly supplied by Scott Robinson was for an older version of acpi-support, I manually added the scripts from the patch, and changed the numbering of the resume script as he suggested later.
Its a shame this will not make it to Feisty final, according to the bug status. This type of thing failing is exactly what makes new users say "Linux is rubbish - nothing ever works" because they don't understand yet. Therefore, IMHO this type of bug should be top priority :-)

maslokm (maslokm) wrote :

I have HP nx7400 ey508es and Feisty with unbind patch and suspend to ram work, but after resume scroll on touchpad doesn't work, I need to go to console using alt+F1 and back to X using F7, after that scroll work. It would be nice if someone could tell me how can I get touchpad working without going to console and back to X.

I had my first keyboard lockup with 2.6.20-14 kernel (no extra patches), so the bug isn't solved for me either. It's definitely much more unlikely to appear with this kernel, though.

Scott Robinson (scott-ubuntu) wrote :

The final release kernel has entered Feisty, so it seems the bug won't be fixed there. acpi-support hasn't been updated, so that's a no-go too.

After feisty releases, I'll attach an updated version of acpi-support that will be easily installed rather than the slightly wrong patch that currently exists.

(See: https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/23497/comments/6)

Paul Sladen (sladen) wrote :

Scott, if you can do an updated patch, we can still review it, though I have a feeling we'll have to hold it until the next release (when hopefully it might get down in-kernel).

I'm using a Clevo M121W laptop which is displaying these symptoms. The keyboard and mouse can be reclaimed using ssh from another host with the commands in https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/23497/comments/17 , but the patched version of acpi-support from Scott doesn't work for me and causes an uncontrolled switch-off crash on resume. Because of the version numbers, it is also a downgrade from the feisty final acpi-support version of 0.95, which causes installation problems.

Feeling intrepid, I grabbed the suspend.d and resume.d scripts from the .deb and installed them manually. Still the same violent crash.

Is there any reason why applying the commands manually works, but doesn't on resume?

Many thanks,
J.

JT (spikyjt) wrote :

Check out my little suggestion here:

http://ubuntuforums.org/showthread.php?t=361285&page=2

(second post down)

This works for suspend to ram - and resume - but not suspend to disk.
I haven't cracked suspend to disk yet as I cannot get it to hibernate at all let alone resume!

On a Dell Inspiron e1705 running Feisty, suspend/resume worked fine until this one time. The touchpad and keyboard were unresponsive after resuming. I plugged in a USB keyboard to diagnose the problem.

Doing the i8042 unbind before suspend and bind after resume did not fix the problem. I got the touchpad back (scrolling works fine), but every time I press a key on the laptop keyboard, I get the following messages in my kernel log:

atkbd.c: Unknown key pressed (raw set 2, code 0x101 on isa0060/serio0).
atkbd.c: Use 'setkeycodes 01 <keycode>' to make it known.

So the keyboard is still on the fritz after doing the unbind/rebind.

Re: previous comment:

The problem has not repeated itself (yet). I'm using JT's scripts.

Martin Wimmer (martin-wimmer) wrote :

I have this problem too. after suspend/resume the keyboard didn't work. I used my usb mouse to hibernate the pc, which worked correctly.

HP nx7300 (ru458et)
feisty amd64

unfortunately the supplied patch is only for the 32 bit version of feisty. can anybody please supply a 64 bit version?

The acpi-support package consists of scripts, so you can just use the i386 package. Do "cd /tmp; wget http://launchpadlibrarian.net/6787623/acpi-support_0.91build2_i386.deb", followed by "ar xf acpi-support_0.91build2_i386.deb" and "sudo tar xzf data.tar.gz". Finally do "sudo cp etc/acpi/resume.d/80-i8042-input.sh /etc/acpi/resume.d" and "sudo cp etc/acpi/suspend.d/20-i8042-input.sh /etc/acpi/suspend.d" and you're all done.

Fedor Isakov (fisakov) wrote :

Identical problem with nw9440 running Feisty with all latest updates. The patch from https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/23497/comments/5 didn't work for me, though I did manage to fix the issue by adding a script to /etc/acpi/resume.d with commands from https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/23497/comments/17.

Daniel Holbach (dholbach) wrote :

Unsubscribing Ubuntu Sponsors for main as there seems to be no working patch available to review and upload.

LEVIS Cyril (atlas95) wrote :

This fix my problem with HP Nx9420! Thanks!! But now i have still problem with suspend resume and wifi rrhhh

fekw (fekw-engel) wrote :

I followed the steps "Johan Brannlund wrote on 2007-06-08". Hibernate now works fine. But after resuming from standby modus the display illumintaion not at 100% as it was before standby. Also trying to increase the illumination doesn't work with shortcut "fn + f9".

Sytem: HP nx7400

Does anybody have an idea?

fekw (fekw-engel) wrote :

ok my mistake, now everything works fine on my nx7400. !!!! Thanks. Great work. ;-)

a.sweets (a-sweets) wrote :

I've got a Dell 1420n that came preloaded with Feisty. I had the problem in the last distro and am still noting it in Gutsy.

I'd like to play around with some of the above suggested patches, but as they're for older distros and one has caused major crashes for James...I guess I'll try them and report on where they leave me.

I've got my laptop set to suspend when the lid is closed so all I've done so far when the problem has occurred is to close the laptop and let it suspend and then wake it up again. The keyboard and mouse usually work again after that.

tonfa (bboissin) wrote :

I've seen this bug on a Dell Inspiron 6400 (preloaded with feisty, and upgraded to gutsy), no keyboard + touchpad on resume. Plugging a usb device works.
It's not my laptop so I don't know if I'll be able to test patches.

jpiesing (jon33040) wrote :

I've seen the same symptoms on a Dell D420 - on both dapper and gutsy.
dmesg | grep 8042 reports the following
serio: i8042 KBD port at 0x60,x064 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12

On dapper it happened perhaps 1 suspend in 20. On gutsy, it's just happened for the first time. There's no obvious error messages mentioning this in Xorg.0.log.

Tobias Heinemann (theine) wrote :

This bug is still present in Hardy. My laptop is a Dell Latitude D830. I tried the fix suggested in https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/23497/comments/33, but it still locks up on a regular basis upon resume.

There's a bit of a problem with the patch: after unbind/rebind, my touchpad's scroll area doesn't work any more.

Hi everyone,

Thanks for testing the Hardy Alpha release. However, please note that the symptom of this particular bug is specific to the hardware used. So while many of you may have the same symptom they really should be different bugs. It would be helpful if everyone who still is experiencing issues could test with the latest Hardy Alpha build, http://www.ubuntu.com/testing/ . You should be able to test using the LiveCD, but please note you can only test Suspend from the LiveCD, not Hibernate. If the issue still exists, please open a separate bug report for your hardware using "linux" as the package name. The bug report should contain the information requested at http://wiki.ubuntu.com/KernelTeamBugPolicies . Additionally, it would be great if you made the titles of a new bug report contain information about your system. I apologize for any inconvenience this might cause but appreciate your cooperation.

Also please note that we will keep this report open against the actively developed kernel bug will close this against 2.6.20 and 2.6.22. Thanks.

Thanks!

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.22:
status: New → Won't Fix
Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Mathieu Pellerin (nirvn-asia) wrote :

confirming also being victim of this resume after suspend bug on a dell latitude d830 laptop on hardy beta release (kernel 2.6.24.12)

tonfa (bboissin) wrote :

Same problem with Dell D430 on Hardy, it happens much much more frequently than in Hardy (where it was seldom for me)

$ dmesg |grep i8
[ 11.406688] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 11.406696] serio: i8042 AUX port at 0x60,0x64 irq 12

nanog (sorenimpey) wrote :

This bug is still active in Hardy and is now a regression from Gutsy (e.g. it happens reproducibly whereas in Gutsy it was very infrequent).

I can regain keyboard and trackpad function by activating the power button and going through a suspend-unsuspend cycle. A short suspend interval never triggers the bug while a long suspend interval always triggers the bug.

~$ uname -a
Linux 2.6.24-17-generic #1 SMP Thu May 1 14:31:33 UTC 2008 i686 GNU/Linux

$ dmesg | grep i8042
[ 8.836731] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 8.836736] serio: i8042 AUX port at 0x60,0x64 irq 12

LEVIS Cyril (atlas95) wrote :

I have this bug too on my xps m1330, I suspend and unsuspend for repair this :/ on last hardy with last update.

xurxo13 (xurxo13) wrote :

Could it be possible to add the binding/unbinding scripts to the /etc/apm/suspend.d and resume.d instead of /etc/acpi/suspend.d and resume.d ? I seems they are using /etc/apm folders in Hardy. I downgraded to Gutsy so I cannot test it now.

sudo nano /etc/apm/suspend.d/20-i8042-input.sh
#!/bin/sh
# Unbind the AT keyboard interface.
if [ -f /sys/bus/platform/drivers/i8042/unbind ]; then
echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind
fi
(save ctrl-x)

sudo nano /etc/apm/resume.d/39-i8042-input.sh
#!/bin/sh
# Rebind the AT keyboard interface.
if [ -f /sys/bus/platform/drivers/i8042/bind ]; then
echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind
fi
(save ctrl-x)
sudo chmod +x /etc/apm/suspend.d/20-i8042-input.sh
sudo chmod +x /etc/apm/resume.d/39-i8042-input.sh

LEVIS Cyril (atlas95) wrote :

This seems to be better with this fix.

I must remove something in /etc/acpi now?

Swistak (swistakers) wrote :

@nanog: How long should the interval be to trigger this bug? I suspended my HP nx6310 for ~15 minutes and after resume I had no problems with keyboard.
I could reproduce this bug on Feisty and Gutsy, but I haven't reproduced it on Hardy yet.

[swistak 17:21 ~]$ uname -a
Linux swistak-laptop 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

[swistak 17:21 ~]$ dmesg | grep i8042
[ 12.897421] i8042.c: Detected active multiplexing controller, rev 1.1.
[ 12.898173] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 12.898179] serio: i8042 AUX0 port at 0x60,0x64 irq 12
[ 12.898182] serio: i8042 AUX1 port at 0x60,0x64 irq 12
[ 12.898185] serio: i8042 AUX2 port at 0x60,0x64 irq 12
[ 12.898188] serio: i8042 AUX3 port at 0x60,0x64 irq 12
[ 12.958372] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input1
[ 29.255145] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio4/input/input8

I have this when I suspend/resume in few times, ~1min for example and
sometimes later.
This bug doesn't appear all the time.

Le mardi 06 mai 2008 à 15:43 +0000, Swistak a écrit :

> @nanog: How long should the interval be to trigger this bug? I suspended my HP nx6310 for ~15 minutes and after resume I had no problems with keyboard.
> I could reproduce this bug on Feisty and Gutsy, but I haven't reproduced it on Hardy yet.
>
> [swistak 17:21 ~]$ uname -a
> Linux swistak-laptop 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux
>
> [swistak 17:21 ~]$ dmesg | grep i8042
> [ 12.897421] i8042.c: Detected active multiplexing controller, rev 1.1.
> [ 12.898173] serio: i8042 KBD port at 0x60,0x64 irq 1
> [ 12.898179] serio: i8042 AUX0 port at 0x60,0x64 irq 12
> [ 12.898182] serio: i8042 AUX1 port at 0x60,0x64 irq 12
> [ 12.898185] serio: i8042 AUX2 port at 0x60,0x64 irq 12
> [ 12.898188] serio: i8042 AUX3 port at 0x60,0x64 irq 12
> [ 12.958372] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input1
> [ 29.255145] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio4/input/input8
>

--
LEVIS Cyril, http://www.atlas95.com .

A mort Windows! Vive Ubuntu! http://www.ubuntu-fr.org .

Uptime: 17:54:05 up 2:57, 1 user, load average: 0.52, 0.44, 0.53

- Combien serai-je payé pour ce travail ?
- Vous recevrez 1115 unités de la monnaie coréenne : « aurez mcxv wons. »
  -- Esposito-Farese, Gilles

Swistak (swistakers) wrote :

I tried hard (suspended 10 times with short and long intervals), but I still can't reproduce it. Maybe it happens under certain circumstances.

I've got a question to HP nx**** users. Can you reproduce:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/110581

jpiesing (jon33040) wrote :

I had this bug on Gutsy (Dell Latitude D420) and worked around it by Fn+Esc (=standby) and then resume again.
It was relatively infrequent.

It's more common in Hardy so I tried the binding / unbinding scripts described above.
These didn't fix the problem and completely broke the standby / resume work-around. On a resume, the latptop would immediately suspend again. On a second resume, it would resume as far as a black screen with a cursor and then stop.
Pulling out the battery is easier than testing with another computer to see if the network was running.

I have now removed the bind/unbind scripts.

Jan Newmarch (jan-newmarch) wrote :

Still occurs in Hardy release 8.04 on a Dell Latitude D830. The bind/unbind fix doesn't work for me: no such device when I try to write to the bind file. Symptoms as everyone describes: on resume after suspend to disk the laptop keyboard doesn't work but an external USB keyboard does. xev reports no keyboard events. Requires a reboot to regain keyboard.

Kernel is Linux 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GNU/Linux.

dmidecode reports
Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: Dell Inc.
        Version: A11
        Release Date: 04/03/2008
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 2048 kB
        Characteristics:
                ISA is supported
                PCI is supported
                PC Card (PCMCIA) is supported
                PNP is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                3.5"/720 KB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                CGA/mono video services are supported (int 10h)
                ACPI is supported
                USB legacy is supported
                AGP is supported
                Smart battery is supported
                BIOS boot specification is supported
                Function key-initiated network boot is supported
                Targeted content distribution is supported
        BIOS Revision: 1.1
        Firmware Revision: 1.1

From lsmod the i8042 module is not loaded - statically compiled in?

Jan Newmarch (jan-newmarch) wrote :

More info for the last post: if I call pm-suspend directly and close and open the lid, then it all works fine. Keyboard is activated on resume. So it appears that gnome-power-manager is doing something to break the keyboard. When I had Fedora Core 9 running, Gnome had the same problem, but KDE was okay.

jpiesing (jon33040) wrote :

I run kubuntu (Hardy) and I see this problem so there must be something not specific to Gnome. I'm using the default KDE 3.5.x.

mkaram-99 (mkaram-99) wrote :

Also have this problem on the thinkpad t43: mouse and keyboard do not work after sleep/resume cycle.

mkaram-99 (mkaram-99) wrote :

Also have this problem on the thinkpad t43: mouse and keyboard do not work after sleep/resume cycle (Hardy).

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Pietro Battiston (toobaz) wrote :

I have almost the same problem with an HP tx2510: after suspend, keyboard and touchpad don't work; if I plug in USB keyboard and mouse, the system is absolutely usable.

If I give unbind and then bind i8042 as written by Jeff Abbott, the embedded keyboard comes again to life, but the touchpad still stays unresponsive. My touchpad has a small button which should enable/disable it, and usually when using it it changes color, but in this case it is stuck too.

I'm using an up-do-date 64 bit Intrepid, so kernel is 2.6.27-4.

I don't have this problem with hibernation (which often doesn't work, but it's a separated issue).

Pietro Battiston (toobaz) wrote :

Also notice that:
- the bug always happens when resuming from suspend
- someone reported that suspending and resuming again would fix the problem: this is not my case. It even happened to me at least one time that after suspending and resuming again Jeff Abbott's fix didn't work no more, but after suspending and resuming again it did.

Jan Newmarch (jan-newmarch) wrote :

Bug has almost completely disappeared for me with Ubuntu 8.10 alpha5 out of the box. Currently running kernel 2.6.27-4 and bug has hardly ever happened for me with the 2.6.27 kernels, but always happened with 2.6.24 kernels and Ubuntu 8.04. Machine is Dell Latitude D830, reported in previous post.

Pietro Battiston (toobaz) wrote :

On my HP tx2510, bug was solved (both keyboard and touchpad) only by following instructions of post http://ubuntuforums.org/showpost.php?p=5220536&postcount=19.

This fix should be integrated in acpi. I could try to provide a patch to acpi package, but I don't know if there are some techniques to execute it only on machines needing it.

JoSch (j-schauer) wrote :

This bug appeared for me in Ubuntu Hardy and in Debian Lenny.
The proposed bind/unbind fixes it in both so this should be reported upstream asap.

Pietro Battiston (toobaz) wrote :

Bug confirmed in released Ubuntu Intrepid.

Lethe (nick-ukfsn) wrote :

Guys, just to let you know, these i8042 echo scripts actually does the opposite for me - they render my keyboard useless after a resume with BIOS system password set.

Please refer (read from bottom up):

http://marc.info/?t=122666606100002&r=1&w=2

Nick

Swistak (swistakers) wrote :

Nick: Does it happen every time or randomly? (when you use these scripts)

Pietro Battiston (toobaz) wrote :

Lethe: am I wrong or your experience (and Matthew's answer) seems to suggest that this is not a bug in acpi-support, but maybe in gnome-powermanager?

In other words: if binding/unbinding is a hack, do you have any idea of where the real work should be done?

My usb keyboad doesn't works after suspend too.
I contrained to unplug keyboard and plug in it back again.

Mildred (mildred) wrote :

Lethe, thanks a milion, your solution works here on a HP Pavilion dv5 running ubuntu 8.10.

https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/23497/comments/67
http://ubuntuforums.org/showpost.php?p=5220536&postcount=19

But ... you need to stay away from the keyboard while the computer resumes itself, or it stops working :/

Karl Ostmo (kostmo) wrote :

I have a 6-year-old Compaq Evo laptop and the keyboard and mouse would be frozen after resuming from suspend (the cursor in the password dialog box would blink, however). I am running Ubuntu 8.10 with kernel 2.6.24-21-generic.

Thankfully, this script worked like a charm!
http://ubuntuforums.org/showpost.php?p=5220536&postcount=19

Now, if I could just get my wireless card to reconnect...

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

James M. Ward (jmw86069) wrote :

Not too sure what resolutions people have come to, but I have an HP dv1245dx laptop with an ATI Radeon 3200 HD integrated. I could hibernate/resume fine, but suspend/resume resulted in non-functioning keyboard and touchpad. The fixes above didn't work for me -- however manually typing in the unbind/bind commands did work if I did it twice. (Inconsistently.)

However, I stumbled upon wisdom from this thread which did solve the problem for me, without creating a script in /etc/acpi/resume.d/*.sh:
http://ubuntuforums.org/archive/index.php/t-1038898.html

Basically you add "i8042.reset" to the /boot/grub/menu.lst line which loads the kernel. I described what I did specifically in my post here:
http://ubuntuforums.org/showpost.php?p=6653249&postcount=15

I wondered if this fix may seem more "global" and may resolve the issue for those people here, including the ones about the opposite effect happening?

For further info, I'm using fglrx (8.12 ATI drivers) and have disabled composite and AIGLX in my xorg.conf file.

boothby (boothby-math) wrote :

This bug has been plaguing me since August when I bought my HP Pavilion dv5. The i8042.reset flag in menu.lst fixed it for me. Thanks, jmw86069! BTW, I'm in the Jaunty development branch. I recall seeing that Jaunty was supposed to fix suspend issues -- hope this gets cleared up before Jaunty is released.

Steve Langasek (vorlon) wrote :

Boothby,

Please note Leann's request for separate bug reports in
<https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/23497/comments/44>.

Pietro Battiston (toobaz) wrote :

@Lethe: could you please try if the "fix" suggested by jmv86069 (add "i8042.reset" to the /boot/grub/menu.lst, or just at the end of the kernel line at startup) causes you the problem you mentioned with scripts?

After resume the keyboard and touchpad on my laptop, HP Pavilion dv5, running Ubuntu Jaunty were not working. Even though if I connect the USB mouse and keyboard they were working.
Adding "i8042.reset" flag to the menu.lst helped me to fix the problem.
thnx.

Jim Lieb (lieb) wrote :

Suspend/resume development and testing was a key delivery goal of Jaunty. If you have an issue that is similar to that reported here, please test with current Jaunty and then file a new bug with the hardware details appropriate to your system. Include in your report the details as outlined in https://wiki.ubuntu.com/KernelTeam/SuspendResumeTesting. In particular, run the tests and report the results.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix

Thank you for posting this bug.

Does this occur in Lucid?

Changed in pm-utils (Ubuntu):
status: Confirmed → Incomplete
James M. Ward (jmw86069) wrote :

I have Lucid on a HP Pavilion DV7-1245dx, and although I needed to add the flag "i8042.reset" to the kernel options in Jaunty, I no longer need this flag in Lucid. Suspend/Resume works fine for me under most circumstances related to this bug.

I sometimes have problems during resume but I think it's only happened when I forgot to run "fusermount" on an sshfs drive mount to un-mount it before suspend. I just haven't gotten around to writing the suspend/resume scripts which check for and unmount automatically.

Many thanks to whoever resolved this issue!

Bryce Harrington (bryce) wrote :

Alright, assuming this issue is no longer relevant for pm-utils; reopen (and explain further) if there's remaining work needed.

Changed in pm-utils (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.