[Hardy] ipw2200: No Wireless Network after suspend resume

Bug #213158 reported by Liken Otsoa on 2008-04-07
14
Affects Status Importance Assigned to Milestone
pm-utils (Ubuntu)
Medium
Unassigned

Bug Description

After suspend to ram / resume, wireless network cannot establish connection. Although Interface eth1 is up.
This has only shown up after updates to Hardy in the last few weeks.
It requires a long time suspend/resume.

Trying to connect:

/etc/init.d/network restart
ifdown and ifup eth1
rmmod and modprobe ipw2200
Physically off and on laptop wireless.

All Fails. I need to reboot system.

System:
IBM Thinkpad X41 Tablet.
ipw2200 wireless module
Hardy Uptodate

Liken Otsoa (liken) wrote :
Mary Gardiner (puzzlement) wrote :

Please attach the output of the dmesg command. Ideally attach one from immediately after a complete boot, and then a second from after you have suspended and resumed and wireless is no longer working.

description: updated
Emil Sit (emilsit) on 2008-04-07
Changed in pm-utils:
status: New → Incomplete
Liken Otsoa (liken) wrote :

Well... This was finally related to same bug of _rename stuff.
Then I did the workaround rm /etc/udev/rules.d/70-persistent-net.rules,
but problem is not totally solved. After resume wireless network cannot connect.
I need to do a ifdown eth1 ifup eth1.
I attatch a fresh dmesg and dmesg inmediatelly after resume.

Liken Otsoa (liken) wrote :
Changed in pm-utils:
status: Incomplete → New
Greg Michalec (greg-primate) wrote :

This may be a duplicate of Bug #183968, which was just marked as 'Fix Released'. Try upgrading to udev (117-6) and see if the problem persists.

Liken Otsoa (liken) wrote :

Problem persists.

After resume iwconfig shows this extrange result:
_____________________________________________

lo no wireless extensions.

eth0_rename IEEE 802.11g ESSID:"FON_Wolf"
          Mode:Managed Frequency:2.417 GHz Access Point: 00:18:84:12:11:29
          Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
          Retry limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=99/100 Signal level=-22 dBm Noise level=-87 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth1 no wireless extensions.
___________________________________

Normally eth0 is wired and eth1 is wireless. After resume eth1 is missing as wireless and there is a new interface eth0_rename.

it is done workaround: rm 70-persistent-net.rules

Liken Otsoa (liken) wrote :

This problem persists.

Liken Otsoa (liken) wrote :
Liken Otsoa (liken) wrote :

These three above files are when system is OK. Before Suspend/Resume.

Ok, could you attach the same three files from _after_ the resume?

Thanks

Liken Otsoa (liken) wrote :

After Resume, When network is down:

Liken Otsoa (liken) wrote :
Liken Otsoa (liken) wrote :

Could you run "sudo udevmonitor -e > udev.log" and then suspend and resume your machine, leaving 30s between suspending and ressuming.

Attach the resulting log file to this bug

Liken Otsoa (liken) wrote :

First time:

udevmonitor -e > udev0.log

30 seconds. Network is OK at resume.

Liken Otsoa (liken) wrote :

Second time:

udevmonitor -e > udev.log

30 seconds. The problem appears. Network is Down at resume. iwconfig shows _rename stuff.

Liken Otsoa (liken) wrote :

Sorry. The first file would be this:

ethanay (ethan-y-us) wrote :

Liken: I'm curious, does Network Manager dispaly the eth0_rename as a wired connection?

I've always been able to get a connection without restarting through some combination of disabling networking via Network Manager and enabling, modprobe -r iwl3945 (and reload), and/or iwlist wlan0 scan.

Sometimes, if/when it finally reconnects, Network Manager displays it as a wired connection, which it most certainly is not. Disabling and re-enabling networking seems to correct the issue temporarily, and network manager displays the network as wireless.

Liken Otsoa (liken) wrote :

I use Wicd, not Network Manager, but this is not a high level bug, it is low level, udev or something.
I have tryed: modprobe -r ipw2200, network restart, ifup and ifdown all interfaces, and nothing.

Liken Otsoa (liken) wrote :

This bug persists. Frecuently after resume there is not network. And iwconfig shows eth0_rename as wireless, normally is eth1.

Changed in pm-utils:
status: New → Confirmed
Macavity (ean25) wrote :

Also affects my Thinkpad T40, using a Cardbus wireless device (Broadcom) via ndiswrapper.

Liken Otsoa (liken) wrote :

For weeks I didn't get this bug, but after last updates (Kernel v18 included) to Hardy this days it is here again.

Liken Otsoa (liken) wrote :

This bug persists. After resume, frecuently an interface is eth_resume and no wireless without reboot.

eqskcr (skullmug) wrote :

This happens to me also

The problem happens 1 out of 2 suspends when my network is in "roaming" mode

If i set it to a manual connection I see the problem 1 out of 5-8 suspends

Once the connection goes i have to reboot

I have a Dell Inspiron 6000

Daniel Hahler (blueyed) on 2008-10-14
Changed in pm-utils:
importance: Undecided → Medium
status: Confirmed → Triaged
Paul (treepata) wrote :

Hey there,

I am no sure if the bug I am experiencing is this one, as it could also be <A href="https://launchpad.net/ubuntu/+source/network-manager/+bug/69892">bug 69892</A> or <A href="https://bugs.launchpad.net/ubuntu/+bug/69426">bug 68426</A>.

But in essence, I cannot reconnect to the internet through Network Manager after the system resumes from suspend or hibernation. It shows all the networks and I can try to connect to them, but even with both the lights green it won't eventually establish a connection.

I am running Xubuntu 8.10 on my IBM x41 and the problem first showed up when I upgraded from 8.04. I had issues with the Network Manager not being able to make a connection in the past, but I solved this by adding the following line to acpi-support:

# Add services to this list to stop them before suspend and restart them in
# the resume process.
STOP_SERVICES="networking"

However, this solution doesn't work in the current situation. And what is different, is that it still tries to establish a connection and almost succeeds in this, but it hangs after both lights turn green.

This could be bug #1052227, but I'm not sure.

Changed in pm-utils (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for pm-utils (Ubuntu) because there has been no activity for 60 days.]

Changed in pm-utils (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers