Suspend does not work when lid is closed on lenovo W530

Bug #1736216 reported by Gerd Grundke on 2017-12-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pm-utils (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to Ubuntu 17.10 closing the lid of my Lenovo W530 does no longer suspend my machine.

I checked the power settings using tweak
-> Suspend, when lid is closed is ON

I ran the following commands

sudo apt install gksu
xhost si:localuser:root
gksudo gedit /etc/systemd/logind.conf

I changed the setting of HandleSuspendKey = hybernate to suspend
(Why was this still set to hybernate, when tweak power settings says suspend?)

[Login]
#HandleSuspendKey=suspend

after saving I ran
sudo systemctl restart systemd-logind

But still no action is performed, when I close the lid.

Checking System Settings for power
-> suspend when on battery after 15 minutes

This works perfect after the 15 min idle time.

Somehow no action is performed when I close my lid.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: pm-utils 1.4.1-17
ProcVersionSignature: Ubuntu 4.13.0-17.20-generic 4.13.8
Uname: Linux 4.13.0-17-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Dec 4 19:23:44 2017
InstallationDate: Installed on 2017-10-25 (40 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: pm-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Gerd Grundke (gerdgrundke) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers