pm-utils suspend fails every 2nd time with gyro-sensors enabled

Bug #1593981 reported by Ray-Ven on 2016-06-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pm-utils (Ubuntu)
Undecided
Unassigned

Bug Description

If I turn on sensors (connected to usb) in the BIOS of my Lenovo Thinkpad S1 Yoga suspend fails (immediately wakes up) every 2nd time. Disabling async doesn't help.

Ray-Ven (ray-ven) wrote :

sudo pm-suspend from commandline works, closing the lid or using KDEs suspend button won't

Ray-Ven (ray-ven) wrote :
Ray-Ven (ray-ven) wrote :
Ray-Ven (ray-ven) wrote :
Ray-Ven (ray-ven) wrote :

Disabling sensors in Bios makes Suspend work again

STM Micro HID Sensor HUB, working through IIO HID

    accelerometer sensor
    rotation sensor
    magnetometer sensor
    angular velocity sensor (aka gyroscope)
    inclination sensor
    ambient light sensor

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pm-utils (Ubuntu):
status: New → Confirmed
kaeru (kaeru) wrote :

Confirmed here Thinkpad S1 Yoga that disabling the Sensors in BIOS fixes this problem. It would seem that USB HID signals fromt he gyroscope triggers resume from suspend similar to that of moving mouse / or keyboard.

Pointers to configuration on resume from suspend events would help possible solve this problem, by disabling resume from STM sensor device.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments