strange Xorg screen blanking control after resume from suspend to disk

Bug #127173 reported by Radim Luža
6
Affects Status Importance Assigned to Milestone
pm-utils (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

After resuming from suspend to disk (used s2disk) Xorg turns backlight of laptop panel off and blanks the screen after selected time period, but after some time screen turn on again and it stays on. I tried to play with configuration i KDE and with xset utility, but it doesn't seem to have any effect. Only restarting Xorg after resuming solves this problem. I tried to change the kernel to 2.6.21.5, but problem did not disappear - it probably doesn't depend on kernel.

Software: Kubuntu 7.04
Hardware: HP Omnibook vt6200 - P4 platform, Radeon R100 based graphic card

Reproduction: set the screen blanking timeout in configuration dialog, suspend to disk (s2disk),resume and wait some time

Revision history for this message
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in recently. We were wondering if this is still an issue for you? Thanks in advance.

Revision history for this message
Radim Luža (radimluza) wrote :

Yes, it's still an issue for me. I recognized that this problem appears not only after resumming from disk - it appears also after nornal boot. Sometimes it takes a long time before problem appers (about 1 hour), sometimes problem appears after short while. I also recognized, that if I enable DRI for my graphic card (01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY) system becomes unstable and if it gets under load for a while it hangs. Thanks that I had to disable DRI in Xorg configuration. But problem with blanking screen appers always - if DRI is enabled or disabled - so I think, that DRI problem doesn't influence blanking problem. Now I use Kubuntu 7.10 and problem still lasts. Can I help you somehow to solve this issue?

Revision history for this message
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add your '/etc/X11/xorg.conf' file and your '/var/log/Xorg.0.log' file as attachments to your bug report? Thanks in advance.

Revision history for this message
Radim Luža (radimluza) wrote :

OK, this is my Xorg configuration - Xorg configuration is full of mess - I copied and modified it from another computer - but this problem appeared also with default automaticly generated configuration.

Revision history for this message
Radim Luža (radimluza) wrote :

Xorg.log

Changed in xorg:
assignee: brian-murray → nobody
importance: Undecided → Medium
status: Incomplete → Confirmed
Revision history for this message
Dennis Murczak (dmurczak) wrote :

Confirmed on my both desktops AND my laptop, all running Kubuntu Gutsy. After hibernation/suspend-to-disk, the screen regularly goes blank after about ~5 minutes without user input. The screen just blanks, without the monitor going on standby. A mouse move unblanks the screen. Disabling/tweaking any powersaving related options in system-settings doesn't change the situation.

The three machines run completely different hardware, including the graphics cards, so I don't think it is a driver related problem.

Revision history for this message
randallw (rwayth) wrote :

I am also having this problem after suspend-to-ram (I haven't tried suspend-to-disk) with gutsy, although this problem has been around for several ubuntu releases I think. My laptop is this one: https://wiki.ubuntu.com/LaptopTestingTeam/CompaqPresarioV2600CTO
I can supply X config files and/or logs if requested.

Revision history for this message
Dan Am (da-lonx) wrote :

I seem to have a similar problem on compaq 6710b. After resume screen just stays blank. If I go to console and back to graphics or kill X the backlight comes back on.

Revision history for this message
Dan Am (da-lonx) wrote :

There seems to be a problem with /sys/class/backlight, which gets referred by /usr/lib/pm-utils/sleep.d/99video:

reset_brightness() {
        for bl in /sys/class/backlight/* ; do
                [ -d $bl ] || continue
                [ -f $bl/brightness ] || continue
                BR=$(cat $bl/brightness)
                echo 0 > $bl/brightness
                echo $BR > $bl/brightness
        done
}

However /sys/class/backligzht is empty and thuis the function just has no function. Loading of modules "lcd" and "cr_bllcd" does not change this.
Still working on it...

Revision history for this message
Radim Luža (radimluza) wrote :

Problem seems to be solved in Kubuntu 8.04. I left my laptop after resume for one entire day idle - screen blanked and stayed blank after I returned. I was lucky to see that - big thanks to everyone who was working on fixing this problem.

Revision history for this message
Radim Luža (radimluza) wrote :

In Kubuntu 8.04 this problem doesn't appear. Solution that works for me is upgrading to 8.04.

Changed in pm-utils:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers