plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Bug #950511 reported by aaron-bru on 2012-03-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

just after logging in, apport popped up with this

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: plymouth 0.8.2-2ubuntu28
ProcVersionSignature: Ubuntu 3.0.0-16.29-generic 3.0.20
Uname: Linux 3.0.0-16-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Mar 8 22:07:55 2012
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Dell Inc. Latitude D630
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=85f66f41-f857-4e0e-8dee-1dfbcbe65a00 ro quiet splash vt.handoff=7
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron: PATH=(custom, no user)
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=85f66f41-f857-4e0e-8dee-1dfbcbe65a00 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f06fae51504 <ply_event_loop_process_pending_events+468>: test %r12d,0x8(%r13)
 PC (0x7f06fae51504) ok
 source "%r12d" ok
 destination "0x8(%r13)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_event_loop_process_pending_events () from /lib/libply.so.2
 ply_event_loop_run () from /lib/libply.so.2
 ?? ()
 __libc_start_main (main=0x403830, argc=3, ubp_av=0x7fffb7318218, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffb7318208) at libc-start.c:226
 ?? ()
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()
UpgradeStatus: Upgraded to oneiric on 2011-10-17 (143 days ago)
UserGroups:

dmi.bios.date: 01/04/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A17
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA17:bd01/04/2010:svnDellInc.:pnLatitudeD630:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D630
dmi.sys.vendor: Dell Inc.

aaron-bru (aaron-bru) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #849414, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers