plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Bug #944243 reported by Luca Chiodini on 2012-03-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Only booted, doing nothing.
Using Nvidia driver

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: plymouth 0.8.2-2ubuntu28
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.93-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Wed Feb 29 15:27:48 2012
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120220)
MachineType: Hewlett-Packard HP G61 Notebook PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic-pae root=UUID=026db4c4-ef84-4836-a50b-bc69d4ca9e93 ro quiet splash vt.handoff=7
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic-pae root=UUID=026db4c4-ef84-4836-a50b-bc69d4ca9e93 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0xb77915b7 <ply_event_loop_process_pending_events+455>: test %ecx,0x4(%esi)
 PC (0xb77915b7) ok
 source "%ecx" ok
 destination "0x4(%esi)" (0x00000004) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_event_loop_process_pending_events () from /lib/libply.so.2
 ply_event_loop_run () from /lib/libply.so.2
 ?? ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
 ?? ()
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 12/21/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.23
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 306A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 21.14
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.23:bd12/21/2010:svnHewlett-Packard:pnHPG61NotebookPC:pvrRev1:rvnHewlett-Packard:rn306A:rvr21.14:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP G61 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Luca Chiodini (l-chiodini) wrote :
visibility: private → public

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #849414, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-i386-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers