Please backport commit to enable building without irrelevant drm libs on some arches

Bug #927424 reported by Robert Hooker on 2012-02-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Medium
Unassigned
Precise
High
Maarten Lankhorst

Bug Description

Starting in libdrm 2.4.31 which will hopefully be pulled into precise, libdrm-intel1 will only build on x86/x64 arches. We are needless building/shipping irrelevant libdrm-intel1 on arches such an armel/armhf/powerpc that can never use it in libdrm to work around this bug but the fix has been commited upstream a year ago to plymouth

http://cgit.freedesktop.org/plymouth/commit/?id=22a1273bb2c9dc0d3188b8ed11b0c97bfca6d3ef

Backporting this plus passing --disable-libdrm-intel at configure time on !i386/!amd64 would be really appreciated as well as save on the image size.

Changed in plymouth (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.4-0ubuntu1

---------------
plymouth (0.8.4-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - drop patches originating from or merged upstream: debug-fixes.patch,
      gcc45-arith-workaround.patch,
      main-Don-t-watch-for-keyboard-input-if-no-keyboard.patch,
      upstart-bridge.patch, upstream-*.patch
    - debian/rules: pass --with-log-viewer to explicitly request its
      inclusion.
    - update libplymouth2.symbols.
  * debian/patches/initramfsless-boot.patch: clean up our failure path when
    /dev/pts isn't available yet:
    - don't free a buffer that we might use again later
    - once we've created the session object, keep it around, instead of
      freeing it again and leaving a dangling reference to it in the loop
      exit handler list.
    it's not clear if this was working before, but it definitely hits an
    assert now. LP: #981314.
  * Build with --disable-libdrm_intel on !x86, to avoid an unnecessary
    dependency. LP: #927424.
 -- Steve Langasek <email address hidden> Sat, 05 May 2012 01:19:02 +0000

Changed in plymouth (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

We'll need to backport this to precise to support bug 1086345.

Changed in plymouth (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-12.04.2

Hello Robert, or anyone else affected,

Accepted plymouth into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/plymouth/0.8.2-2ubuntu31 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in plymouth (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in plymouth (Ubuntu Precise):
assignee: nobody → Maarten Lankhorst (mlankhorst)
Adam Conrad (adconrad) wrote :

Looks like the linkage and dependencies on the packages in proposed are correct.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.2-2ubuntu31

---------------
plymouth (0.8.2-2ubuntu31) precise-proposed; urgency=low

  * debian/patches/plymouth-optional-drm.patch: backport patch to disable
    intel dependency on !x86 (LP: #927424)
  * drop dependency drm-intel1 on !x86
  * debian/patches/plymouth-old-nouveau.patch: updated to use libdrm_nouveau1,
    needed for building on the updated libdrm.
  * debian/patches/autoreconf.patch: refreshed for above patches
 -- Maarten Lankhorst <email address hidden> Fri, 18 Jan 2013 17:59:35 +0100

Changed in plymouth (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers