plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Bug #898886 reported by cameron goldsworth on 2011-12-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: plymouth 0.8.2-2ubuntu28
ProcVersionSignature: Ubuntu 3.2.0-2.5-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic x86_64
NonfreeKernelModules: wl fglrx
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Thu Dec 1 20:15:20 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
MachineType: Dell Inc. Inspiron M5010
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-2-generic root=UUID=c0884f7f-25ad-4f2d-a208-c9eb062494ab ro acpi=off radeon.modeset=0
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron: PATH=(custom, no user)
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-2-generic root=UUID=c0884f7f-25ad-4f2d-a208-c9eb062494ab ro acpi=off radeon.modeset=0
SegvAnalysis:
 Segfault happened at: 0x7f0997cdf504 <ply_event_loop_process_pending_events+468>: test %r12d,0x8(%r13)
 PC (0x7f0997cdf504) ok
 source "%r12d" ok
 destination "0x8(%r13)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_event_loop_process_pending_events () from /lib/libply.so.2
 ply_event_loop_run () from /lib/libply.so.2
 ?? ()
 __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
 ?? ()
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 12/30/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0WTVYR
dmi.board.vendor: Dell Inc.
dmi.board.version: A09
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A09
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd12/30/2010:svnDellInc.:pnInspironM5010:pvrA09:rvnDellInc.:rn0WTVYR:rvrA09:cvnDellInc.:ct8:cvrA09:
dmi.product.name: Inspiron M5010
dmi.product.version: A09
dmi.sys.vendor: Dell Inc.

cameron goldsworth (red40y) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #849414, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers