plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Bug #868231 reported by alex.marcev@gmail.com on 2011-10-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: plymouth 0.8.2-2ubuntu28
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CurrentDmesg: [ 137.128761] init: plymouth-stop pre-start process (2203) terminated with status 1
Date: Wed Oct 5 12:13:58 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
MachineType: Hewlett-Packard HP 2140
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=9fc5edb5-e012-4a43-901d-2f39a51252d6 ro quiet splash vt.handoff=7
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron: PATH=(custom, no user)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=9fc5edb5-e012-4a43-901d-2f39a51252d6 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x6b75b7 <ply_event_loop_process_pending_events+455>: test %ecx,0x4(%esi)
 PC (0x006b75b7) ok
 source "%ecx" ok
 destination "0x4(%esi)" (0x00000004) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_event_loop_process_pending_events () from /lib/libply.so.2
 ply_event_loop_run () from /lib/libply.so.2
 ?? ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
 ?? ()
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 02/18/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68DGU Ver. F.01
dmi.board.name: 3056
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 20.0D
dmi.chassis.asset.tag: CNU9140ZPS
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68DGUVer.F.01:bd02/18/2009:svnHewlett-Packard:pnHP2140:pvrF.01:rvnHewlett-Packard:rn3056:rvrKBCVersion20.0D:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP 2140
dmi.product.version: F.01
dmi.sys.vendor: Hewlett-Packard

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #849414, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
visibility: private → public
tags: removed: need-i386-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers