plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Bug #862071 reported by Szymon Wojtowicz on 2011-09-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

after start OS

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: plymouth 0.8.2-2ubuntu26
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Thu Sep 29 00:27:56 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110911)
MachineType: ASUSTeK Computer Inc. K52Dr
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=dcd68d55-513c-4984-905a-b1bcbc6aba43 ro quiet splash vt.handoff=7
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron: PATH=(custom, no user)
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=dcd68d55-513c-4984-905a-b1bcbc6aba43 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f9da72c9504 <ply_event_loop_process_pending_events+468>: test %r12d,0x8(%r13)
 PC (0x7f9da72c9504) ok
 source "%r12d" ok
 destination "0x8(%r13)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_event_loop_process_pending_events () from /lib/libply.so.2
 ply_event_loop_run () from /lib/libply.so.2
 ?? ()
 __libc_start_main (main=0x403830, argc=3, ubp_av=0x7fff23e348f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff23e348e8) at libc-start.c:226
 ?? ()
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()
UpgradeStatus: Upgraded to oneiric on 2011-09-24 (4 days ago)
UserGroups:

dmi.bios.date: 01/27/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K52Dr.213
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K52Dr
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK52Dr.213:bd01/27/2011:svnASUSTeKComputerInc.:pnK52Dr:pvr1.0:rvnASUSTeKComputerInc.:rnK52Dr:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: K52Dr
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Szymon Wojtowicz (ghb321-gmail) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #849414, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers