plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Bug #854499 reported by Andy Whitcroft on 2011-09-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Appeared on login,.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: plymouth 0.8.2-2ubuntu25
ProcVersionSignature: Ubuntu 3.0.0-11.19~flickerfreeboot201109151609-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Mon Sep 19 19:05:10 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: Hewlett-Packard HP Mini 5102
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=5fb238d3-d8f2-428b-9984-1c68e2a65b34 ro quiet splash vt.handoff=7
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron: PATH=(custom, no user)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=5fb238d3-d8f2-428b-9984-1c68e2a65b34 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f6839ac3504 <ply_event_loop_process_pending_events+468>: test %r12d,0x8(%r13)
 PC (0x7f6839ac3504) ok
 source "%r12d" ok
 destination "0x8(%r13)" (0x4030a9116691a6dc) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_event_loop_process_pending_events () from /lib/libply.so.2
 ply_event_loop_run () from /lib/libply.so.2
 ?? ()
 __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
 ?? ()
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()
UpgradeStatus: Upgraded to oneiric on 2011-06-09 (102 days ago)
UserGroups:

dmi.bios.date: 03/11/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68PGU Ver. F.05
dmi.board.name: 3653
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 43.1D
dmi.chassis.asset.tag: CNU0150M0R
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68PGUVer.F.05:bd03/11/2010:svnHewlett-Packard:pnHPMini5102:pvr:rvnHewlett-Packard:rn3653:rvrKBCVersion43.1D:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP Mini 5102
dmi.sys.vendor: Hewlett-Packard
mtime.conffile..etc.init.plymouth.stop.conf: 2011-09-15T08:10:39.703123

Andy Whitcroft (apw) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #849414, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers