FFe: enable flicker-free boot with lightdm

Bug #849954 reported by Steve Langasek on 2011-09-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Ubuntu Flicker-Free Boot Project
Undecided
Unassigned
plymouth (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

I have recently vetted the lightdm plymouth handling code to confirm that it is capable of a flicker-free hand-off from plymouth in the same way that gdm was. We should have updated plymouth pre-beta to turn on flicker-free handling; since this didn't get done, this is now a freeze exception request.

This is an important part of the Ubuntu desktop boot experience, and not having it enabled constitutes a regression from natty, so I think a freeze exception is warranted. However, since lightdm has been the default DM for much of the oneiric cycle, we've not been getting any testing of the flicker-free code path in plymouth or the DRM drivers so there's definitely some risk of regression from turning it on as well. As such, I don't believe we should enable this in the archive until the plymouth change has been tested with at least one system each of the intel, nouveau, and radeon drivers, both with and without cryptsetup installed (due to cryptsetup's effect of pulling plymouth into the initramfs, resulting in an earlier start).

I have personally tested this with the intel+cryptsetup case only.

Steve Langasek (vorlon) wrote :

The linked branch implements the necessary one-liner change to the plymouth upstart jobs; hardware testing needed.

Changed in plymouth (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Didier Roche (didrocks) wrote :

on nvidia, closed-source driver : as expected, anything better or worse, still have a lot of text printed (at random places and overwriting themselves) above the plymouth low-resolution splash.

Martin Pitt (pitti) wrote :

I tested this on my X201 with Intel Arrandale, and on my Dell Mini 10 with an Intel 945, both without cryptsetup. This successfully got rid of the intermediate text screen, i. e. less boot flicker.

Michael Vogt (mvo) wrote :

I tested this with the radeon driver (no cryptsetup):
 [ 1.524529] [drm] Initialized radeon 2.10.0 20080528 for 0000:01:00.0 on minor 0
and it works fine, no flickering.

Steve Langasek (vorlon) wrote :

And just to confirm, everyone here has lightdm configured, not gdm, right?

Michael Vogt (mvo) wrote :

Yes, lightdm is used here on a Radeon HD 5500.

Michael Vogt (mvo) wrote :

I tested this now with and without cryptsetup installed and noticed no difference. Flickerfree boot in both cases on my radeon system.

John Johansen (jjohansen) wrote :

On my lenovo x61t (intel grapics), with out cryptsetup adding "lightdm" to the special case in /etc/init/plymouth-stop.conf fixes the plymouth to lightdm transition. Specifically there is a flixer free transition where the cursor appears over the plymouth background, however there is a significant flicker immediately afterwards when lightdm redraws the screen.

Sebastien Bacher (seb128) wrote :

shouldn't that land for beta2 if it targets oneiric?

Chris Coulson (chrisccoulson) wrote :

Hmmm, I tested this with the change to /etc/init/plymouth-stop.conf, but it makes no difference to me. I get a purple screen briefly, then several flickers with the cursor appearing a couple of times, and then I see lightdm (without ever seeing plymouth appear). But this was the case before as well...

Chris Coulson (chrisccoulson) wrote :

Ok, I opened bug 853927 for that issue

On Mon, Sep 19, 2011 at 10:34:34AM -0000, Sebastien Bacher wrote:
> shouldn't that land for beta2 if it targets oneiric?

Yes, we should certainly try to land this before beta2, but I still need
testing from someone using nouveau.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Marc Deslauriers (mdeslaur) wrote :

Just tested this on a Thinkpad T61 with nouveau.

Before the update, I get:
- Purple grub screen
- Corrupted plymouth screen
- Text mode with text
- Lightdm

After the update I get:
- Purple grub screen
- Corrupted plymouth screen
- Black screen
- Lightdm

So, looks like this is a slight improvement.

Steve Langasek (vorlon) wrote :

Thanks, sounds like we've got good results with all major video drivers. Handing off to the release team to consider the freeze exception.

Changed in plymouth (Ubuntu Oneiric):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.2-2ubuntu26

---------------
plymouth (0.8.2-2ubuntu26) oneiric; urgency=low

  * Add direct dependency on ttf-dejavu-core since that's the font used in
    the initramfs-tools hook, instead of trusting that fontconfig-config
    pulls in the right alternative. LP: #828027.
  * debian/initramfs-tools/scripts/init-bottom/plymouth: /run doesn't get
    moved to ${rootmnt}/run until *after* our script has run, so don't try
    to check for it before calling plymouth update-root-fs - it's not like
    we would ever want to not pivot root, anyway. Fixes the fact that we
    haven't been getting /var/log/boot.log for months now.
  * debian/plymouth.plymouth-stop.upstart: if stopped by lightdm, let
    lightdm handle the VT transition as it's able, so we get flicker-free
    boot. LP: #849954.
 -- Steve Langasek <email address hidden> Mon, 19 Sep 2011 10:56:55 -0700

Changed in plymouth (Ubuntu Oneiric):
status: New → Fix Released
Martin Pitt (pitti) wrote :

For the record, I reviewed this, belatedly +1 from me.

Changed in ubuntu-flicker-free-boot:
status: New → Fix Released
manny (estelar57) wrote :

still have some flickers.. (radeon)

fix released should read "improvement released", but launchpad doesn't have that option yet.

manny (estelar57) wrote :

made some more test reboots and sometimes it gets even worse (plymouth changes resolution for no apparent reason and trows a bunch of console text in different colors..)

God i hate buggy plymouth... probably the most unpolished and buggy part of ubuntu.

Steve Langasek (vorlon) wrote :

manny, this bug report is about having a flicker-free transition between plymouth and lightdm. There may be other sources of flickering on some systems, but these are separate issues. Please file bug reports with 'ubuntu-bug' for the issues you're encountering.

The kinds of regressions we would see as a result of a botched flicker-free transition to lightdm would be boot-time hangs or video corruption when lightdm starts. If you're not seeing either of these kinds of problems after applying this change, I think we can still consider this change good.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers