plymouth regression: text missing in initramfs (again)

Bug #812022 reported by Steve Langasek on 2011-07-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Steve Langasek
Oneiric
High
Steve Langasek

Bug Description

Text display in the initramfs within plymouth has regressed again in oneiric as of my latest upgrade. I believe the regression happened some time between July 14 (my last boot of 3.0.0-4-generic) and today.

There was a plymouth update in that window, so that seems a likely culprit; possibly triggered by the act of rebuilding, since the changelog for the plymouth update doesn't indicate any changes that should have broken this.

I can't otherwise bisect the initramfses to see what might have changed, because a separate issue in bootchart caused all the initramfses on my system to be regenerated. (Bug report pending.)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: plymouth 0.8.2-2ubuntu24
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
Architecture: amd64
Date: Sun Jul 17 14:09:31 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 003: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
MachineType: LENOVO 3249CTO
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-5-generic root=/dev/mapper/hostname-root ro quiet splash vt.handoff=7
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
UpgradeStatus: Upgraded to oneiric on 2011-06-27 (20 days ago)
dmi.bios.date: 08/23/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET52WW (1.22 )
dmi.board.name: 3249CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET52WW(1.22):bd08/23/2010:svnLENOVO:pn3249CTO:pvrThinkPadX201:rvnLENOVO:rn3249CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3249CTO
dmi.product.version: ThinkPad X201
dmi.sys.vendor: LENOVO

Steve Langasek (vorlon) wrote :
Changed in plymouth (Ubuntu Oneiric):
importance: Undecided → High
assignee: nobody → Ubuntu Foundations Team (ubuntu-foundations-team)
status: New → Triaged
Christoph (christoph-thomas) wrote :

Hi,
I have downgraded all plymouth packages from 0.8.2-2ubuntu24 to 0.8.2-2ubuntu23. The problem is still pending, so actually I think the issue might have something to do with the initramfs package which was updated at 2011-07-15 to 0.99ubuntu2. I'm still looking into it.
Cheers, Christoph

dj_palindrome (dj.palindrome) wrote :

Thank you gentlemen for looking into this. I do not have your skills, so while I suspect something is still wrong somewhere, it's difficult to isolate in a way that would be useful to you. On one virtualized system, Plymouth boots to a black screen, which I'm willing to overlook since the login screen eventually appears. On another virtualization platform, otherwise the same, Plymouth splash works, but hangs if I put the last nail in its coffin (by updating initscripts and base-files). As soon as I'm convinced I'm good again, the logo stops spinning and croaks. Obviously this would be useless as a bug report so I don't file one. But I'm very glad individuals of your talent are looking into this.

Christoph (christoph-thomas) wrote :

Hi Steve,
for me downgrade initramfs defenitly works.
I have tested the actual *plymouth*ubuntu24*.deb packages together with initramfs*0.98.8ubuntu3*.deb (due to dependencies you might have also to downgrade ntfs-3g and libntfs-3g) with Kernels 3.0.0-4-generic and 3.0.0-5-generic. Maybe you can verify it for your system?
Christoph

On Mon, Jul 18, 2011 at 08:21:59PM -0000, dj_palindrome wrote:
> Obviously this would be useless as a bug report so I don't file one. But
> I'm very glad individuals of your talent are looking into this.

The issue I've reported here is not about a blank screen or a system failing
to boot, it's only about the *text* messages not being rendered on the
splash screen. If you are seeing boot failures in oneiric with all packages
up to date, I do recommend that you file a separate bug report.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Steve Langasek (vorlon) wrote :

Christoph,

Thanks, initramfs-tools seems a likely culprit given the delta between 0.98.8ubuntu3 and 0.99ubuntu2. I'll have a look at this.

Changed in plymouth (Ubuntu Oneiric):
assignee: Ubuntu Foundations Team (ubuntu-foundations-team) → Steve Langasek (vorlon)
Christoph (christoph-thomas) wrote :

Hi Steve,
it looks like the change from 0.99ubuntu1 to 0.99ubuntu2 might be the culprit (most likely libcairo is not found anymore - see bug 717516). Unfortunatly I can't get hold of the package 0.99ubuntu1. But I have a working initrd.img which was generated 2011-07-12 (this is the timestamp of 0.99ubuntu1) and works fine. Maybe you can reassign this bug to the initramfs-tools package?
Below you find the critical point in the changelog:

Version: 0.99ubuntu2 2011-07-15 11:02:11 UTC

initramfs-tools (0.99ubuntu2) oneiric; urgency=low

  * hook-functions: Revert changes from 0.98.8ubuntu3. With the current
    implementation of copying, and /etc/ld.so.conf now existing in initramfs,
    we can leave libraries at their original location. Thanks to maks for
    pointing out!

tags: added: iso-testing
Luke (lukekuhn) wrote :

On my systems, this is fixed as of August 13-but only if the updates that caused a black screen/no video output boot on August 10 were never installed. Found this out updating the less frequently attended/updated remote system. Now, as of August 13, the text is back, after 6 weeks of waiting for it.

Steve Langasek (vorlon) wrote :

This is fixed here for me as well in the latest oneiric updates. I'm not sure what changed, but I don't see any further reason to keep the bug report open.

Changed in plymouth (Ubuntu Oneiric):
status: Triaged → Fix Released
Christoph (christoph-thomas) wrote :

Same here. According to the date I have noticed that xserver-xorg-video-intel has changed. But since everything works fine I agree with Steve - there is no reason to keep the bug report open.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers