init: plymouth-stop pre-start process terminated with status 1(plymouth-stop called multiple times due to race?)

Bug #800701 reported by Sworddragon on 2011-06-22
172
This bug affects 35 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Medium
Unassigned

Bug Description

I'm using Ubuntu 11.10 dev with plymouth 0.8.2-2ubuntu23. My desktop environment is LXDE with LXDM as login manager. Since a few months I get on every system boot the message "init: plymouth-stop pre-start process (PID) terminated with status 1". The system is working fine with this message but it's annoying to see it every time.
---
Architecture: amd64
DistroRelease: Ubuntu 13.04
MarkForUpload: True
Package: plymouth 0.8.4-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Uname: Linux 3.5.0-17-generic x86_64
UserGroups: adm cdrom dialout lpadmin plugdev sambashare sudo

Steve Langasek (vorlon) wrote :

Thanks for the report.

The code in plymouth-stop hasn't changed since December 2010, and the plymouth package itself is unchanged since natty. So this seems to be due to a change elsewhere in the system (possibly grub?).

Do you see the Ubuntu splash screen on boot? One simple reason for this job to exit with status 1 is if plymouth is not running.

Changed in plymouth (Ubuntu):
status: New → Incomplete
Sworddragon (sworddragon) wrote :

In grub I have changed some settings all the time:

GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_GFXPAYLOAD_LINUX=1680x1050-24

Because I wanted to see all the messages during booting. But I have the problem that the most time the monitor is black. Only at the end of the booting process I can see some text.

I have now restored the default configurtaion of grub and rebooted the system. I saw the message "mountall: plymouth command failed" and there was no splash screen.

Changed in plymouth (Ubuntu):
status: Incomplete → New
Steve Langasek (vorlon) wrote :

ok. please boot with the option 'plymouth:debug=file:/var/log/plymouth-debug.log' and attach the resulting file after boot.

Changed in plymouth (Ubuntu):
status: New → Incomplete
Sworddragon (sworddragon) wrote :

Here is the plymouth log.

Sworddragon (sworddragon) wrote :

It seems I can't upload any files. I can select the path to the file but after clicking "Post Comment" I get the error "Either a comment or attachment must be provided.". If I write some additional text the attachment isn't uploaded. There is even no other button to upload the attachement.

Sworddragon (sworddragon) wrote :
Sworddragon (sworddragon) wrote :

plymouth-debug.log had only read access to root. This was the reason why I couldn't upload it.

Changed in plymouth (Ubuntu):
status: Incomplete → New
Changed in plymouth (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Do you still see this issue with current oneiric? If so, a couple more things to try:

 - unset the 'GRUB_GFXPAYLOAD_LINUX=1680x1050-24' option in /etc/default/grub and re-run update-grub to see if the error displays
 - run 'apport-collect 800701' so we get full information about your plymouth config. I get hints of it from the plymouth debug log, but I'm not sure which parts are deliberate and which parts might indicate a bug.

In any event, the plymouth debug log indicates a normal exit of plymouth. So *something* is succeeding in calling 'plymouth quit', but then it looks like the plymouth-stop job is being triggered after plymouth has already exited. One possible explanation is that plymouth-stop is being triggered *twice* by two different events: probably 'starting lxdm' + 'stopped rc RUNLEVEL=[2345]', and because the events are far enough apart, plymouth has already exited before the second event happens, preventing upstart from eating the event.

One way to test for this would be for you to add as the first line after 'pre-start script' in /etc/init/plymouth-stop.conf the following:

   echo "$UPSTART_EVENTS" >> /run/what-killed-plymouth.log

then, after booting the system and confirming that you see the error message, attach /run/what-killed-plymouth.log to this bug.

Changed in plymouth (Ubuntu):
status: Confirmed → Incomplete
summary: - init: plymouth-stop pre-start process terminated with status 1
+ init: plymouth-stop pre-start process terminated with status 1(plymouth-
+ stop called multiple times due to race?)
Changed in plymouth (Ubuntu):
importance: Undecided → Medium
Sworddragon (sworddragon) wrote :

I don't see this message anymore but I get a new error for which I will create a new ticket.

Changed in plymouth (Ubuntu):
status: Incomplete → Fix Released
Sworddragon (sworddragon) wrote :

I'm using now Ubuntu 13.04 dev with plymouth 0.8.4-0ubuntu3 and have made a look into /var/log/kern.log. It contains the line: Oct 25 22:37:09 ubuntu kernel: <12>[ 28.842041] init: plymouth-stop pre-start process (1218) terminated with status 1

Changed in plymouth (Ubuntu):
status: Fix Released → New
Sworddragon (sworddragon) wrote :

I have now commented the line GRUB_GFXPAYLOAD_LINUX=1680x1050-24 in /etc/default/grub but the error still appears in /var/log/kern.log. I will attach what-killed-plymouth.log as you suggested.

tags: added: apport-collected
description: updated

apport information

Christopher (soft-kristal) wrote :

It adds several seconds to a boot time already slowed by vboxdrv. This is the end of the boot from dmesg:

[ 46.262355] atl1c 0000:03:00.0: irq 43 for MSI/MSI-X
[ 46.262463] atl1c 0000:03:00.0: atl1c: eth0 NIC Link is Up<100 Mbps Full Duplex>
[ 51.043928] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 51.299484] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[ 121.898333] vboxdrv: Found 2 processor cores.
[ 121.898453] vboxdrv: fAsync=0 offMin=0x473 offMax=0x9ce
[ 121.898515] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
[ 121.898517] vboxdrv: Successfully loaded version 4.1.18_Ubuntu (interface 0x00190000).
[ 122.785489] vboxpci: IOMMU not found (not registered)
[ 140.915652] init: plymouth-stop pre-start process (4519) terminated with status 1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
elhoir (jfarroyo82) wrote :

i all,

i have the same problem in 13.04, using plymouth 0.8.8

maddy malone (maddymalone) wrote :

Greetings,

I am getting the same message. It started on my installation of 12.04, and I first noticed iti after I installed ClamAV and havp.
When I did a fresh install of 12.10 with ClamAV and havp, itcontinued to appear, and still does after the kernel update.
To see if it would help, today I uninstalled havp and restarted. The error box reappeared with the message "init: plymouth-stop pre-start process (1906) terminated with status 1". While I had the terminal open to read dmesg, the error box popped up again. So I refreshed dmesg, and the latest complaint is "eth0: no IPv6 routers present". I have IPv6 set for "ignore", in case that matters. Also, in case it matters, several lines previous to the "init: plymouth-stop..." error message is always the line "init: failsafe main process (739) killed by TERM signal".

On two occasions--weeks apart--the boot process has stalled with a black screen showing some lines that look like content of dmesg, forcing me to restart. Sorry I cannot remember what the last lines were.

The error box has been popping open frequently, at various times, whether I am online or not, and I cannot associate it with any specific program. I read in a Ubuntu forum that the cure for the error box appearing had to do with apparmor notifications not being disabled in this version and the instruction was to clear the # in front of the line that controls this. When I checked, the line in my system was already cleared.
One of the things that bothers me most about this error is the box that requests the password to send the notice to Ubuntu about the error. It is not in the graphical style of this version--its looks like it came from a much older version when boxes had sharply square corners. Even the warning box itself is nearly a perfect square, and not rectangular. Most of the time I do not click it at all (fearing it is a hacker attempt to obtain my password) but hit [ESC] instead. It is not possible to get a screenshot, but I did take a photo of box with my camera, if anyone is interested in seeing it.

I have only been using Ubuntu for about 8 months, and I apologize for not being able to be more specific in my description of the error.

dd-b (dd-b-dd-b) wrote :

Also seeing this problem in a new 13.04 install. I'm running mine in VirtualBox, and I notice that the poster in #13 is also (or at least dmesg shows vboxsf is running); no idea if that's relevant.

Can't copy the dmesg tail from the VirtualBox console window, will retype the last few lines, omitting nasty timestamps and hard-to-type things:

Initialized drm 1.1.0 20060810
No driver support for vblank timestamp query.
Initialized vboxvideo 1.0.0...
init: plymouth-stop pre-start process (1564) terminated with status 1

I'm seeing the same error message on Lubuntu 13.10 x64.

Any new suggestions to solve this issue?

studiogrynn (john-grynn) wrote :
Download full text (3.2 KiB)

Ubuntu 13.04
Seeing same in dmesg:
//Snippet:

  39.664739] wlan0: authenticated
[ 39.668057] wlan0: associate with 20:4e:7f:20:c8:3a (try 1/3)
[ 39.671917] wlan0: RX AssocResp from 20:4e:7f:20:c8:3a (capab=0x411 status=0 aid=4)
[ 39.671985] wlan0: associated
[ 39.671999] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 44.824943] audit_printk_skb: 177 callbacks suppressed
[ 44.824951] type=1400 audit(1382968729.989:71): apparmor="ALLOWED" operation="open" parent=1350 profile="/usr/sbin/dnsmasq" name="/etc/NetworkManager/dnsmasq.d/" pid=1713 comm="dnsmasq" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[ 44.877924] type=1400 audit(1382968730.045:72): apparmor="ALLOWED" operation="open" parent=1350 profile="/usr/sbin/dnsmasq" name="/run/NetworkManager/dnsmasq.conf" pid=1713 comm="dnsmasq" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[ 44.881567] type=1400 audit(1382968730.045:73): apparmor="ALLOWED" operation="mknod" parent=1350 profile="/usr/sbin/dnsmasq" name="/run/NetworkManager/dnsmasq.pid" pid=1713 comm="dnsmasq" requested_mask="c" denied_mask="c" fsuid=0 ouid=0
[ 44.881590] type=1400 audit(1382968730.045:74): apparmor="ALLOWED" operation="open" parent=1350 profile="/usr/sbin/dnsmasq" name="/run/NetworkManager/dnsmasq.pid" pid=1713 comm="dnsmasq" requested_mask="wc" denied_mask="wc" fsuid=0 ouid=0
[ 53.044029] init: plymouth-stop pre-start process (2325) terminated with status 1
[ 89.310243] type=1400 audit(1382968774.473:75): apparmor="ALLOWED" operation="exec" parent=2838 profile="/usr/lib/chromium-browser/chromium-browser" name="/usr/bin/lsb_release" pid=2864 comm="Chrome_FileThre" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0 target="/usr/lib/chromium-browser/chromium-browser//null-40"
[ 89.311912] type=1400 audit(1382968774.473:76): apparmor="ALLOWED" operation="getattr" parent=2838 profile="/usr/lib/chromium-browser/chromium-browser//null-40" name="/usr/lib/chromium-browser/" pid=2864 comm="lsb_release" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[ 89.311953] type=1400 audit(1382968774.473:77): apparmor="ALLOWED" operation="open" parent=2838 profile="/usr/lib/chromium-browser/chromium-browser//null-40" name="/etc/ld.so.cache" pid=2864 comm="lsb_release" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[ 89.311965] type=1400 audit(1382968774.473:78): apparmor="ALLOWED" operation="getattr" parent=2838 profile="/usr/lib/chromium-browser/chromium-browser//null-40" name="/etc/ld.so.cache" pid=2864 comm="lsb_release" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[ 89.312067] type=1400 audit(1382968774.477:79): apparmor="ALLOWED" operation="open" parent=2838 profile="/usr/lib/chromium-browser/chromium-browser//null-40" name="/lib/x86_64-linux-gnu/libpthread-2.17.so" pid=2864 comm="lsb_release" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[ 89.312082] type=1400 audit(1382968774.477:80): apparmor="ALLOWED" operation="getattr" parent=2838 profile="/usr/lib/chromium-browser/chromium-browser//null-40" name="/lib/x86_64-linux-gnu/libpthread-2.17.so" pid=2864 comm="lsb_release" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

//EndSnippet

what-killed-plymou...

Read more...

studiogrynn (john-grynn) wrote :

Okay, here is the complete content of the what-killed-plymouth.log.

starting
stopped

Yup. that's it.

Daniel Jones (drjones18) wrote :

I'm also having this issue on 13.10.
init: plymouth-stop pre-start process (1902) terminated with status 1

I also made the change to plymouth-start.conf and my what-killed-plymouth.log was also only:
starting
stopped

Thanks for any help!

paul fox (pgf-launchpad) wrote :

as further background information on possible causes for this:

the message in question will occur in the log any time upstart is told to (re)enter runlevel 2. i.e, if you type "telinit 2", you'll see the result both in the output of "last -x head" (because wtmp records the (null) level transition) and in the output of "dmesg", where the plymouth-stop pre-start scriptlet records its demise.

(also note that the script /etc/init/plymouth-stop.conf is *not* consulted when the addition to dmesg occurs -- "ls -lu" will show you that. the pre-start segment of that script seems to be cached elsewhere. this may not be relevant, but is simply a factoid i discovered while attempting to isolate the source of the "terminated with status 1" message.)

I still have the message appearing in Lubuntu 14.04

arthur@AOD270:~$ dmesg | grep plymouth -i
[ 17.431099] init: plymouth-stop pre-start process (1146) terminated with status 1

arthur@AOD270:~$ uname -a
Linux AOD270 3.13.0-12-generic #32-Ubuntu SMP Fri Feb 21 17:45:10 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Daniel Jones (drjones18) wrote :

I'm also having this issue - running 32-bit Ubuntu 13.10.

[57.986502] init: plymouth-stop pre-start process (1713) terminated with status 1

I also changed plymouth-start.conf and what-killed-plymouth.log only contained:
starting
stopped

Thanks!
Dan

Toni (topinet) wrote :

Also having same issue in 13.10 64-bits:

[ 58.651672] init: plymouth-stop pre-start process (2806) terminated with status 1

what-killed-plymouth.log only contained:
starting
stopped

$ sudo tail -1 /var/log/plymouth-debug.log
[main.c] main:exiting with code 0

plymouth seems to exit cleanly, so same error as above.

NoOp (glgxg) wrote :

Like the poster in comment #16, I only started experiencing this problem after installing (and later purging) ClamAV. I wonder if this is pure coincidence, or if something that gets installed with ClamAV triggers the issue. Note: ClamAV was installed when claws-mail-clamd-plugin was installed (which I've also since purged).

 I've reinstalled plymouth, but the error remains.

3.11.0-19-generic #33~precise1-Ubuntu SMP Wed Mar 12 21:16:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
 (linux-generic-lts-saucy)

$ apt-cache policy plymouth
plymouth:
  Installed: 0.8.2-2ubuntu31.1
  Candidate: 0.8.2-2ubuntu31.1
  Version table:
 *** 0.8.2-2ubuntu31.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     0.8.2-2ubuntu30 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

dmesg:
[ 70.411380] init: plymouth-stop pre-start process (3290) terminated with status 1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers