apt should prevent reporting of bugs where packages are missing in /var/cache/apt/

Bug #790040 reported by Chad C on 2011-05-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Brian Murray
Oneiric
Medium
Brian Murray
plymouth (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

failed during system update

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: libplymouth2 0.8.2-2ubuntu22
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Sat May 28 23:36:40 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ErrorMessage: cannot access archive: No such file or directory
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=UUID=f49b634c-f62c-429c-915d-bd51151fba68 ro quiet splash vt.handoff=7
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: package libplymouth2 0.8.2-2ubuntu22 failed to install/upgrade: cannot access archive: No such file or directory
UpgradeStatus: Upgraded to natty on 2011-04-30 (29 days ago)
dmi.bios.date: 10/20/2002
dmi.bios.vendor: Intel Corp.
dmi.bios.version: SV84510A.86A.0008.P04.0210201732
dmi.board.name: D845PESV
dmi.board.vendor: Intel Corporation
dmi.board.version: AAA97671-106
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrSV84510A.86A.0008.P04.0210201732:bd10/20/2002:svn:pn:pvr:rvnIntelCorporation:rnD845PESV:rvrAAA97671-106:cvn:ct2:cvr:

Related branches

Chad C (bjmeany) wrote :
Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this issue and help to improve Ubuntu. The errors in the logfile are:

Unpacking replacement ubuntu-sso-client ...
dpkg: error processing /var/cache/apt/archives/plymouth-label_0.8.2-2ubuntu23_i386.deb (--unpack):
 cannot access archive: No such file or directory
dpkg: error processing /var/cache/apt/archives/plymouth_0.8.2-2ubuntu23_i386.deb (--unpack):
 cannot access archive: No such file or directory
dpkg: error processing /var/cache/apt/archives/libplymouth2_0.8.2-2ubuntu23_i386.deb (--unpack):
 cannot access archive: No such file or directory
Preparing to replace language-selector-gnome 0.33 (using .../language-selector-gnome_0.34.1_all.deb) ...

Missing files in /var/cache/apt are not bugs in the named packages. There may be a bug in apt somewhere causing unexpected clean-up of files, or a network error may have prevented the packages from being downloaded as expected; but it's not a bug in plymouth.

Changed in plymouth (Ubuntu):
status: New → Invalid
Brian Murray (brian-murray) wrote :

apt has some routines for preventing the reporting of bugs regarding specific dpkg failures of this nature. Another one should be added to apt for inaccessible archives.

Changed in apt (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - package libplymouth2 0.8.2-2ubuntu22 failed to install/upgrade: cannot
- access archive: No such file or directory
+ apt should prevent reporting of bugs where packages are missing in
+ /var/cache/apt/
Changed in apt (Ubuntu Oneiric):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.14.1ubuntu6

---------------
apt (0.8.14.1ubuntu6) oneiric; urgency=low

  [ Brian Murray ]
  * apt-pkg/deb/dpkgpm.cc:
    - prevent reporting of package installation failures due to inaccessible
      local files (LP: #791102, #790040)
    - include /var/log/apt/history.log in apport-package reports so we know
      the context for the package management request

  [ Michael Vogt ]
  * methods/mirror.cc:
    - ignore lines starting with "#" in the mirror file
    - ignore non http urls in the mirrors
    - append the dist (e.g. sid, wheezy) as a query string when
      asking for a suitable mirror
 -- Michael Vogt <email address hidden> Tue, 07 Jun 2011 15:55:07 +0200

Changed in apt (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers