ugly plymouth animation during booting with nvidia driver

Bug #728781 reported by Le Gluon Du Net on 2011-03-03
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

Hello,

the plymouth ubuntu animation during booting is very ugly with nvidia driver, could you make it better please?

Thanks for your help.

LGDN

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: plymouth 0.8.2-2ubuntu17
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Mar 4 00:46:03 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
MachineType: HP-Pavilion GX598AA-ABF a6221.fr
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=32fde935-d672-446f-8502-7cf931fc0385 ro quiet splash vt.handoff=7
SourcePackage: plymouth
TextPlymouth: Error: command ['readlink', '/etc/alternatives/text.plymouth'] failed with exit code 1:
UpgradeStatus: Upgraded to natty on 2011-01-24 (38 days ago)
dmi.bios.date: 07/27/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 5.21
dmi.board.name: Leonite2
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 6.00
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: 1111
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr5.21:bd07/27/2007:svnHP-Pavilion:pnGX598AA-ABFa6221.fr:pvr:rvnASUSTekComputerINC.:rnLeonite2:rvr6.00:cvnHewlett-Packard:ct3:cvr1111:
dmi.product.name: GX598AA-ABF a6221.fr
dmi.sys.vendor: HP-Pavilion

Le Gluon Du Net (legluondunet) wrote :
Le Gluon Du Net (legluondunet) wrote :

I reinstalled a fresh natty and I have plymouth ubuntu logo during booting, but it's ugly, the resolution af the plymouth theme should be 640x480.

Changed in plymouth (Ubuntu):
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
Changed in plymouth (Ubuntu):
status: Invalid → New
summary: - no plymouth animation during booting
+ ugly plymouth animation during booting with nvidia driver
description: updated
Steve Langasek (vorlon) wrote :

For Ubuntu 11.10, plymouth will use the preferred native video resolution as reported by 'vbeinfo' in grub. If this resolution doesn't look good on your display, you can override it by configuring GRUB_GFXMODE in /etc/default/grub.

Changed in plymouth (Ubuntu):
status: New → Fix Released
Le Gluon Du Net (legluondunet) wrote :

I set GRUB_GFXMODE to the maximum resolution of my nvidia card, 1680x1050 in /etc/default/grub, then update-grub and it finally works. Plymouth animation is no more Ugly, thanks.

LGDN

Le Gluon Du Net (legluondunet) wrote :

This bug is still present in Ubuntu 14.04. It appears when you install NVIDIA proprietary drivers, even if they are installed from the official Ubuntu repositories. Ubuntu is used by a large population, today this bug is easy to resolve, why you just don't add this line to grub by default:

GRUB_GFXPAYLOAD_LINUX=auto

or at less add it to the NVIDIA drivers installatio nscript from the official Ubuntu repositories.

Changed in plymouth (Ubuntu):
status: Fix Released → Confirmed
tags: added: trusty
removed: i386 natty
tags: added: amd64
Dennis Fehr (cy-raid) wrote :

It's funny how after so long this bug still isn't fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers