plymouth-x11 should use Xlib instead of GTK+

Bug #573977 reported by skybon on 2010-05-02
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Low
Unassigned
plymouth (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: plymouth

Plymouth depends on GTK+ which means pulling the latter into the Qt-based Kubuntu. And that's definitely not good at all.

Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this issue and help to improve Ubuntu.

The plymouth package does not depend on GTK+. The plymouth-x11 package does, but this is an optional component and it's not a bug that this uses GTK+ as its toolkit. It happens to be installed by default on Kubuntu, but doesn't have to be; this is a choice for the Kubuntu developers to make, so reassigning to kubuntu-meta.

affects: plymouth (Ubuntu) → kubuntu-meta (Ubuntu)
summary: - Plymouth depends on GTK+
+ plymouth-x11 should use Xlib instead of GTK+
affects: kubuntu-meta (Ubuntu) → plymouth (Ubuntu)

Well, this bug concerns plymouth-x11's usage of GTK+ itself but not kubuntu-meta. Renamed the bug for further clarification.

Changed in kubuntu-meta (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Jonathan Thomas (echidnaman) wrote :

Fwiw, we've dropped the dependency on plymouth-x11 from kubuntu-desktop in maverick.

Changed in kubuntu-meta (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) on 2011-09-30
Changed in plymouth (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers