Boot Splash Hindering Boot on Macbook / Mac Pro

Bug #563578 reported by Dawning on 2010-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub

I've had extreme difficulty in getting the 10.04 Beta 2 x64 disk image to boot my Macbook (4,1) past the initial grub menu.

I've found if I remove the last few grub entries and replace them with "nosplash" that it seems to start up okay. I've also had similar challenges with my Mac Pro (x64 too).

I've also found that if I boot from the disk and not press a key, the boot process freezes with the grub menu up. IF, I however, press some keys shortly after the menu appears, I can interact with it as expected until I select a boot option. I've tried options like disabling acpi with no change in symptoms.
---
Architecture: amd64
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
MachineType: Apple Inc. MacBook3,1
NonfreeKernelModules: wl
Package: plymouth 0.8.1-4ubuntu1
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Tags: lucid
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Uname: Linux 2.6.32-19-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/05/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB31.88Z.008E.B02.0803051832
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F22788C8
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 2
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22788C8
dmi.modalias: dmi:bvnAppleInc.:bvrMB31.88Z.008E.B02.0803051832:bd03/05/08:svnAppleInc.:pnMacBook3,1:pvr1.0:rvnAppleInc.:rnMac-F22788C8:rvrPVT:cvnAppleInc.:ct2:cvrMac-F22788C8:
dmi.product.name: MacBook3,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this bug and help to improve Ubuntu.

What entries, exactly, do you replace with 'nosplash' when booting? ("nosplash" is actually treated the same as "splash" by plymouth, so I don't know why you would see any difference using this option.)

After a successful boot, please run 'apport-collect 563578'.

affects: grub (Ubuntu) → grub2 (Ubuntu)
affects: grub2 (Ubuntu) → plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

Dawning (dawning) wrote : Lspci.txt

apport information

Dawning (dawning) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

Dawning (dawning) wrote : UdevDb.txt

apport information

apport information

Dawning (dawning) wrote :

The removed grub entries are "quiet splash --"

Dawning (dawning) wrote :

Err, I thought I had a 4,1 macbook, evidently, it's a 3,1.

Dawning (dawning) wrote :

Update: As it now stands, I'm not observing any start up boot splash on my Macbook. However I am seeing it during shutdown. And the machine seems to be booting up/down just fine.

My machine is fully updated 10.04 x64 as of the date of posting this message.

Steve Langasek (vorlon) wrote :

Ok, then it sounds like your current problem reduces to bug #540801; marking as a duplicate. Thanks for following up.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers