splash fails to show during boot (intel)

Bug #555214 reported by Christian Göbel on 2010-04-04
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by yannis

Bug Description

Binary package hint: plymouth

Testing Lucid on my four-year old Laptop with Intel-Centrino platform, currently the splash screen is not displayed during boot.
The splash (still) displays fine during shut-down, though.

- In the past this worked just fine. When I first installed Lucid alpha-3 I had the following behaviour:
After after a long time (15 seconds) the new splash screen showed up for a couple of seconds before a smooth transition to the gdm-login-screen.

- Since a couple of weeks the splash does not show up every time during boot.
Actually it showed up only twice during this time:
a) Only once during boot, I had a animated splash (showing snow).
b) Some days ago I had (only once, again) a oversized splash with ugly colour transitions (16 colour mode? 256 colour mode?).

Additional information:
I was looking for existing bug-reports on launchpad and suspected to suffer from bug #540801 - however the suggested workaround didn't solve my issue. This suggests that the problem is not that the splash is started to late during boot. Therefore I guess that this is a different issue.
---
Architecture: i386
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100213)
Lsusb:
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Samsung Electronics SX20S
Package: plymouth 0.8.1-4
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=96c2365d-66ca-48e2-8dbb-7560a3da2a64 ro quiet splash
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Tags: lucid
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Uname: Linux 2.6.32-19-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/14/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 12ZE
dmi.board.name: SX20S
dmi.board.vendor: Samsung Electronics
dmi.board.version: Revision PR
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Samsung Electronics
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr12ZE:bd07/14/2006:svnSamsungElectronics:pnSX20S:pvrRevisionPR:rvnSamsungElectronics:rnSX20S:rvrRevisionPR:cvnSamsungElectronics:ct1:cvrN/A:
dmi.product.name: SX20S
dmi.product.version: Revision PR
dmi.sys.vendor: Samsung Electronics

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Chaostya (chaostya) wrote :

Lucid 10.04 upgraded from Karmic
Plymouth Version: 0.8.1-2
Dell D610 + Intel with KMS

On boot I see GRUB menu, then "Starting up..." and then GDM login screen appears. No bootsplash.
When I shutdown new plymouth Ubuntu shutdown splash appears fine.

When I boot LiveCD startup splash appears fine too.

innervision (dguaraglia) wrote :

Same problem here. I'm on a Sony VAIO notebook. Dist-upgraded from Karmic yesterday.

cat /proc/fb reports: 0 inteldrmfb

What happens is:

1) I see grub in graphical mode (I configured it to be 1280x800)
2) Screen goes blank in text mode (big underline cursor at top of screen)
3) Screen blinks
4) Screen goes blank in graphics mode (small underline cursor at top of screen)
5) Screen blinks
6) I get GDM

Sometimes there's a flash of text displaying a few kernel messages betweens steps 4 and 5.

I've checked "Show boot splash" and unchecked "Show text during boot" in the StartupManager to no avail. I guess that's as far as a "normal" user would go, so he'd be stuck with a problem.

I just tested with the latest updates (April 18th) and this is still an issue.
A look at the bootchart reveals that plymouthd is actually started very early during the boot process (as it should). However the splash does not appear. Instead I only see a black screen with a blinking cursor. Then some boot messages, then a dark black screen and then finally the gdm-login screen.

I attach the bootchart.

Please let me know if I can provide information that could help to solve this issue.

Changed in plymouth (Ubuntu):
status: New → Confirmed
tags: added: regression-potential

Since Caostia and innervision have the same issue I mark this bug as confirmed.
Since splash worked without problems on earlier versions of Ubuntu (e.g. Ubuntu 9.10, Karmic) and it worked fine in earlier versions (alpha) of Lucid, I also tag this bug as regression-potential.

Steve Langasek (vorlon) wrote :

Which workaround from bug #540801 did you try?

Chaostya and innervision almost certainly have that bug. I would think that you also had the same bug, except that you say that adding plymouth to the initramfs doesn't fix the problem for you.

innervision (dguaraglia) wrote :

When I upgraded to Karmic RC1 a few months ago, however the problem was solved when Release came out.

I'll try to generate a bootchart too and see what comes up.

innervision (dguaraglia) wrote :

OK, done, here goes the bootchart. Apparently plymouthd is loading when expected, but not showing. I attach the bootchart.

@ Steve Langasek:
From bug #540801 I tried the following 'workaround': (see comment 2 of the bug):

> One "solution" is to use the initramfs and start plymouth as a critical step:
>
> echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
> update-initramfs -u

If I understand correctly this is workaround if plymouth is not started early enough during
the boot-process and consequently has not enough time to be displayed.
However on my laptop this did not make any difference.

Anything else that I could provide?

Steve Langasek (vorlon) wrote :

Well, just to double-check that plymouth really got into your initramfs, you can do:

zcat /boot/initrd.img-$(uname -r) | cpio -t | grep plymouth

You can also boot with the option 'plymouth:debug=file:/var/log/plymouth.log' and post the resulting file.

Here we go:
Step 1: zcat /boot/initrd.img-$(uname -r) | cpio -t | grep plymouth
36924 blocks

Step 2: I reinstalled all Plymouth packages that I could find via Synaptics.

Step 3: Then I booted with the plymouth:debug=file:/var/log/plymouth.log option, the log-file is attached to the comment.
Actually during this boot I got a disc-check and the splash screen showed up during disc-check!

Step 4: I booted again with the plymouth:debug option in order to make sure that the splash was not triggered by the disk-check.
Result: The splash did actually show up for a couple of seconds just before the gdm-login screen appeared!

Step 5: I wondered if the problem is fixed (perhaps due to step 2?) and reboot again. This time without the plymouth:debug option.
Result: No splash shows up.

This really makes me wonder what triggers that behaviour?
Could it be that there is a 20 seconds delay required before plymouth shows a splash on my computer - and I just added the required extra seconds by the plymouth:debug option or the disc-check?

Anyway this laptop requires roughly 20 seconds before showing the gdm-screen. Which makes my computer look like the exact use case for a splash screen.

Any suggestions?

This is the plymouth log file from the second boot (with plymouth:debug option).

Steve Langasek (vorlon) wrote :

> Step 1: zcat /boot/initrd.img-$(uname -r) | cpio -t | grep plymouth
> 36924 blocks

Ok, this shows definitively that you don't have plymouth in your initramfs, so for whatever reason you are *not* using the workaround from bug #540801. So this *is* the same as bug #540801, the only outstanding question is why the workaround didn't take effect for you.

What is the output of 'uname -r' by itself?

What is the output of 'ls /etc/initramfs-tools/conf.d'? And of 'cat /etc/initramfs-tools/conf.d/splash'?

Chaostya (chaostya) wrote :

not using workaround

$ zcat /boot/initrd.img-$(uname -r) | cpio -t | grep plymouth
36877 blocks
$ uname -r
2.6.32-21-generic
$ ls /etc/initramfs-tools/conf.d/
resume
$ cat /etc/initramfs-tools/conf.d/splash
cat: /etc/initramfs-tools/conf.d/splash: No such file or directory

Chaostya (chaostya) wrote :

using LiveCD I see Plymouth splash when booting

Marco (makro) wrote :

I don't have any encryption on my disks...
Anyway by installing cryptsetup package you can have plymouth on boot...
why?!??

@Stefe Langasek:
Here is the output of the commands:
$ uname -r
2.6.32-21-generic
$ ls /etc/initramfs-tools/conf.d
resume
$ cat /etc/initramfs-tools/donf.d/splash
cat: /etc/initramfs-tools/donf.d/splash: No such file or directory

Sorry for the confusion, I tried the workaround some weeks ago when the splash disappeared from my boot experience.
But when I tried the workaround from bug #540801 - the splash did not show up neither - so I removed plymouth from the initramfs again. (Would this break plymouth altogether?)
So the bug description seemed correct at that time.

Since the splash showed up in different settings of comment 19 - I will try again. Maybe the workaround didn't work since plymouth has been broken temporarily for my system? I will report my experience here.

@Steve Langasek:
Now the workaround actually worked! This confirms that my problem was a duplicate of bug #540801.
I have no clue why it didn't work some weeks ago, but now it did the trick.
I suspect that the splash has been broken at that time on my machine.
Sorry for the noise. Thank you very much for your time and effort!

Just in case somebody wants to try, just open a terminal and type the following.
# to become superuser (root) (for whatever reason I could not use just sudo echo ... ):
sudo su
# type your password here
echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
update-initramfs -u
# exit root-mode:
exit

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers