plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Bug #554955 reported by ajacx on 2010-04-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

Lucid Lynx - 2.6.32-19-generic - i686 - Intel Pentium 4
On booting I see the error: Could not read bytes: Pipe broken... but still loads to gdm and able to login. Then while using Chrome or another program which requires mem/cpu I get the crash, monitor first flashes and the message "Could not read bytes: Pipe broken" which might be a remnant can be seen again, monitor switches off, keyboard inactive but cpu running. Happened a few times now, 3 times in the middle of using Chrome.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.1-4
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
CurrentDmesg:
 [ 32.256037] eth0: no IPv6 routers present
 [ 43.312061] end_request: I/O error, dev fd0, sector 0
 [ 43.364044] end_request: I/O error, dev fd0, sector 0
Date: Sun Apr 4 08:58:45 2010
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
MachineType: KOBIAN PI845GLM
ProcCmdLine: root=UUID=7753e6c9-382b-434d-9247-9be6bef9af76 ro quiet splash
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron: PATH=(custom, no user)
ProcFB: 0 inteldrmfb
SegvAnalysis:
 Segfault happened at: 0xeb2fe1 <ply_event_loop_process_pending_events+513>: test %eax,0x4(%esi)
 PC (0x00eb2fe1) ok
 source "%eax" ok
 destination "0x4(%esi)" (0x00000004) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_event_loop_process_pending_events ()
 ply_event_loop_run () from /lib/libply.so.2
 ?? ()
 __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
 ?? ()
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()
UserGroups:

dmi.bios.date: 04/02/01
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: Version 07.00T
dmi.board.name: PI845GLM
dmi.board.vendor: KOBIAN
dmi.board.version: 1.0
dmi.chassis.asset.tag: 0123ABC
dmi.chassis.type: 3
dmi.chassis.vendor: KOBIAN
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrVersion07.00T:bd04/02/01:svnKOBIAN:pnPI845GLM:pvr1.0:rvnKOBIAN:rnPI845GLM:rvr1.0:cvnKOBIAN:ct3:cvr1.0:
dmi.product.name: PI845GLM
dmi.product.version: 1.0
dmi.sys.vendor: KOBIAN

ajacx (anjo-antony) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #553745, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-i386-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers