plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()

Bug #554914 reported by Ned Hedrick on 2010-04-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

Just performed an upgrade. This problem occurred shortly after. There do not seem to be any ill effects.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.1-4
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Apr 3 19:08:22 2010
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
Lsusb:
 Bus 004 Device 002: ID 045e:00e1 Microsoft Corp. Wireless Laser Mouse 6000 Reciever
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Hewlett-Packard Compaq Presario CQ50 Notebook PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=c245dc79-cf52-486e-8dec-7ec37b1ec9d7 ro quiet splash
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron: PATH=(custom, no user)
ProcFB: 0 VGA16 VGA
SegvAnalysis:
 Segfault happened at: 0x7faf36a0309c <ply_event_loop_process_pending_events+508>: test %r12d,0x8(%r13)
 PC (0x7faf36a0309c) ok
 source "%r12d" ok
 destination "0x8(%r13)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_event_loop_process_pending_events ()
 ply_event_loop_run () from /lib/libply.so.2
 ?? ()
 __libc_start_main () from /lib/libc.so.6
 ?? ()
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_event_loop_process_pending_events()
UserGroups:

dmi.bios.date: 08/18/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.54
dmi.board.name: 360A
dmi.board.vendor: Wistron
dmi.board.version: 08.60
dmi.chassis.type: 10
dmi.chassis.vendor: Wistron
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.54:bd08/18/2009:svnHewlett-Packard:pnCompaqPresarioCQ50NotebookPC:pvrF.54:rvnWistron:rn360A:rvr08.60:cvnWistron:ct10:cvrN/A:
dmi.product.name: Compaq Presario CQ50 Notebook PC
dmi.product.version: F.54
dmi.sys.vendor: Hewlett-Packard

Ned Hedrick (nedhedrick) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #553745, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers