No plymouth graphical boot on Intel graphics

Bug #551709 reported by mikbini on 2010-03-30
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

I cannot see plymouth graphical boot at startup, although I have a graphical shutdown screen.

As far as I can tell alternatives are set to the default graphical ubuntu-logo theme:

$ update-alternatives --display default.plymouth
default.plymouth - auto mode
 link currently points to /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth

and GRUB_CMDLINE_LINUX_DEFAULT is set to "quiet splash" in /etc/defaults/grub.

As per lspci my graphic chipset is an "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)". and in my /proc/fb I find:

0 inteldrmfb

This happens on a macbook, booting through refit and then grub, with grub installed in the ubuntu partition (I know this is "a BAD idea" but it's the way suggested by the Macbook installation FAQ at http://ubuntuforums.org/showthread.php?t=1192296).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.1-2
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
NonfreeKernelModules: wl
Architecture: i386
CurrentDmesg:
 [ 16.940305] ppdev: user-space parallel port driver
 [ 23.117088] eth1: no IPv6 routers present
 [ 25.929045] eth0: no IPv6 routers present
 [ 38.685450] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
 [ 61.138772] process `skype' is using obsolete setsockopt SO_BSDCOMPAT
Date: Tue Mar 30 14:56:14 2010
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
MachineType: Apple Inc. MacBook4,1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-18-generic root=UUID=3f7919f6-a881-4335-ab54-c8e485e3afb4 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
SourcePackage: plymouth
dmi.bios.date: 02/09/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB41.88Z.00C1.B00.0802091535
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F22788A9
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 2
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22788A9
dmi.modalias: dmi:bvnAppleInc.:bvrMB41.88Z.00C1.B00.0802091535:bd02/09/08:svnAppleInc.:pnMacBook4,1:pvr1.0:rvnAppleInc.:rnMac-F22788A9:rvrPVT:cvnAppleInc.:ct2:cvrMac-F22788A9:
dmi.product.name: MacBook4,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

mikbini (mikbini) wrote :
Steve Langasek (vorlon) wrote :

This looks like bug #540801. Marking as a duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers