package plymouth-theme-ubuntu-logo (not installed) failed to install/upgrade: trying to overwrite '/lib/plymouth/themes/ubuntu-logo/ubuntu-logo.script', which is also in package plymouth 0:0.8.0~-17

Bug #549701 reported by BobPendleton on 2010-03-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

Logged in. Started synaptic. Clicked on reload.

I scanned through the list of packages and saw that ubuntu-desktop, ubuntu-standard, and ubuntu-minimal were to be upgraded. So I marked those three for upgrade and clicked on apply. I should note that two other packages were dragged in to meet dependencies of the three I clicked. They were related to the plymouth-theme. I had expected all, or at least many, of the upgradeable packages to be pulled in as dependencies. But, that's why we do experiments, to test our expectations against reality.

This is not a critical bug. I decided to file it because I've seen a lot of updates go slightly wrong because packages were updated that while the packages they depend on were not yet in the repository. I've seen a lot more of that type of problem since upgrading to Alpha 3 and Beta 1 than I have seen with alpha and beta releases in the past. On previous versions of Ubuntu, at least 3 or 4 version back, I have always kept one machine running the current alpha starting at alpha 1. This time I've had a lot more problems with the early alphas. In fact, the old laptop I use for that would not install until Beta 1. I wound up running Alpha 3 on my desktop cause I really wanted to see what it was like!

As an old developer and some times software manager I associate an up tick in configuration bugs with either to much pressure on the developers or to much confidence. :-) Both need to be looked at carefully.

ProblemType: Package
Architecture: amd64
Date: Sat Mar 27 11:47:43 2010
DistroRelease: Ubuntu 10.04
ErrorMessage: trying to overwrite '/lib/plymouth/themes/ubuntu-logo/ubuntu-logo.script', which is also in package plymouth 0:0.8.0~-17
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: plymouth-theme-ubuntu-logo (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic root=UUID=125fe5b0-ef8b-408b-bcce-235ce3608341 ro quiet splash
ProcFB: 0 VGA16 VGA
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
SourcePackage: plymouth
Title: package plymouth-theme-ubuntu-logo (not installed) failed to install/upgrade: trying to overwrite '/lib/plymouth/themes/ubuntu-logo/ubuntu-logo.script', which is also in package plymouth 0:0.8.0~-17
Uname: Linux 2.6.32-17-generic x86_64
dmi.bios.date: 08/07/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2NPV-VM ACPI BIOS Revision 1401
dmi.board.name: M2NPV-VM
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 1.xx
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2NPV-VMACPIBIOSRevision1401:bd08/07/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTekComputerINC.:rnM2NPV-VM:rvr1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Related branches

BobPendleton (bob-pendleton) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.1-1ubuntu2

---------------
plymouth (0.8.1-1ubuntu2) lucid; urgency=low

  * Make sure all the plymouth themes declare Replaces: plymouth (<< 0.8.1-1~)
    to give a smooth upgrade. LP: #549701.
  * Add Breaks: against the old versions of the out-of-tree plymouth theme
    packages.
  * Recommend plymouth-theme-ubuntu-text | plymouth-theme, to avoid pulling
    in a theme at random. LP: #550237.
 -- Steve Langasek <email address hidden> Sun, 28 Mar 2010 15:36:41 -0700

Changed in plymouth (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers