ubuntu-logo theme puts password prompt below dialogue, pushing it offscreen for 800x600 modes (default uvesa mode?)

Bug #539723 reported by Kees Cook on 2010-03-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: plymouth

When mounting my encrypted swap, there is no text displayed, just the passphrase entry box. This was working for a few weeks in the middle of Lucid, but has vanished again.

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 16 10:23:45 2010
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.0~-14
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-16-generic root=/dev/mapper/systemvg-root2lv ro quiet splash
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 inteldrmfb
 1 VGA16 VGA
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: plymouth
Uname: Linux 2.6.32-16-generic x86_64
dmi.bios.date: 09/22/2008
dmi.bios.vendor: Intel Corp.
dmi.bios.version: JOQ3510J.86A.0954.2008.0922.2331
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DQ35JO
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD82085-800
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrJOQ3510J.86A.0954.2008.0922.2331:bd09/22/2008:svn:pn:pvr:rvnIntelCorporation:rnDQ35JO:rvrAAD82085-800:cvn:ct3:cvr:

Related branches

Kees Cook (kees) wrote :

Please provide output of

  ls -l /lib/plymouth/themes

Changed in plymouth (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Kees Cook (kees) wrote :

$ ls -l /lib/plymouth/themes/
total 32
lrwxrwxrwx 1 root root 32 2010-02-05 10:36 default.plymouth -> ubuntu-logo/ubuntu-logo.plymouth
drwxr-xr-x 2 root root 4096 2010-03-16 09:53 details/
drwxr-xr-x 2 root root 4096 2010-03-16 09:53 fade-in/
drwxr-xr-x 2 root root 4096 2010-03-16 09:53 glow/
drwxr-xr-x 2 root root 4096 2010-03-16 09:53 script/
drwxr-xr-x 2 root root 4096 2010-03-16 09:53 solar/
drwxr-xr-x 2 root root 4096 2010-03-16 09:53 spinfinity/
drwxr-xr-x 2 root root 4096 2010-03-16 09:53 text/
drwxr-xr-x 2 root root 4096 2010-03-16 09:53 ubuntu-logo/

I suspect the problem is that text is being displayed _under_ the passphrase prompt, since when the entry box goes away, it says "successfully whatever the crypted swap device blah".

My screen resolution is very low, since I'm using UVESA fb (non-KMS ATI).

Changed in plymouth (Ubuntu):
status: Incomplete → New
Kees Cook (kees) wrote :

Here's a video of early boot with the input box, and final text.

summary: - no text prompt for encrypted drive password prompt
+ ubuntu-logo theme has no text prompt for encrypted drive password prompt
Changed in plymouth (Ubuntu):
status: New → Triaged

So based on my own success using the password prompts in plymouth, I think there are actually two unrelated bugs here.

First, the password prompt is displayed by the ubuntu-logo theme below the entry box. This doesn't make sense; the prompt should be above the entry box.

And second, in the video, it's clear that the entry box is at the bottom of the display... which would put the prompt off the bottom of the screen! So there seems to be a bug in how the driver is driving the display hardware.

I'm seeing a variation of the two bugs: first the text is below the entry field, then, following the input of on invalid password, both the text and the entry field 'jump up' and now the text is displayed in the same vertical position than the entry field. See attached screenshots.

Steve Langasek (vorlon) on 2010-03-21
summary: - ubuntu-logo theme has no text prompt for encrypted drive password prompt
+ ubuntu-logo theme puts password prompt below dialogue, pushing it
+ offscreen for Kees strange uvesafb config
summary: ubuntu-logo theme puts password prompt below dialogue, pushing it
- offscreen for Kees strange uvesafb config
+ offscreen for Kees's strange uvesafb config
Kees Cook (kees) on 2010-03-21
summary: ubuntu-logo theme puts password prompt below dialogue, pushing it
- offscreen for Kees's strange uvesafb config
+ offscreen for 800x600 modes (default uvesa mode?)
Launchpad Janitor (janitor) wrote :
Download full text (4.6 KiB)

This bug was fixed in the package plymouth - 0.8.1-1

---------------
plymouth (0.8.1-1) lucid; urgency=low

  [ Scott James Remnant ]
  * Update to the upstream 0.8.1 release:
    - Our patches have been merged upstream, some changes due to cleaning
      them up for submission and noticing a few bugs along the way.
      Remaining changes are:
      + ubuntu-logo theme
      + ubuntu version of the text theme
      + call update-initramfs rather than plymouth-update-initrd in
        plymouth-set-default-theme
      + filter fsck progress updates from the progress bar tracker
      + watch for enter key press
      + support lbm-nouveau as an alternate driver name for nouveau to
        permit backports once Lucid has released
      + use /dev/fb0 as default framebuffer device name
      + stop animation of script plugin in idle function
    - Will become process group leader of its VT if possible (opens without
      O_NOCTTY when redirecting stdio to it), this is almost certainly
      correct keyboard-wise.
    - Deallocates VT on "plymouth quit" after switching VT back to VT1
    - Open terminal in text and details plugin, don't assume it's already
      open.
    - Calling "plymouth quit" or "plymouth deactivate" while the same
      command is already running will now block the new command until the
      old one complete, rather than returning immediately.
    - Various window fixes for script plugin
    - Script plugin updated to use the window X and Y offsets every time
    - Plymouth client tool has been updated to have commands for many cases
      in preference to the --command style.

  * Restored code to disable Plymouth's graphical plugins when an alternate
    init= is given on the kernel command-line, otherwise init=/bin/bash
    doesn't work so well when Plymouth is in the initramfs.
  * Restored crash handler that dumps boot messages to /dev/tty1.

  * Split themes out into different packages, reducing the size of the
    Plymouth package. This also means that you can remove the themes
    packages to remove the "graphical splash" part of Plymouth while keeping
    the ability to prompt for questions on the console.
  * Use the alternatives system to select the default themes. The existing
    symlink will be replaced on upgrade if you have not changed it.
  * Also use alternatives to select the text theme.
  * Restore the upstream text theme, renaming ours to "ubuntu-text".
  * Fallback to the built-in details theme (boot messages on console, but
    with the ability to prompt for questions) if no theme package is
    installed.
  (LP: #507238)

    Unfortunately these changes mean that if you've selected a custom
    theme, you will need to install that package and select it again.
    Sorry about that.

  * Include the 16-color VGA frame-buffer renderer. LP: #526892.

  * Fix text, ubuntu-text and details themes to restore the console to text
    mode when adding text displays.

  * debian/rules:
    - Set default tty for boot and shutdown with configure arguments
    - Set default background color to the Ubuntu Aubergine, this provides
      some consistency with other default themes.
  * debian/plymouth.upstart, d...

Read more...

Changed in plymouth (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers