Ubuntu

Key presses (such as Enter) can kill the X server after a boot with the text plugin

Reported by Scott James Remnant (Canonical) on 2010-03-12
88
This bug affects 13 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: plymouth

This bug only refers to issues with the text.so plugin; this plugin is used when there is no DRM or Framebuffer device available. You can recognise it because it says "Ubuntu 10.04" across the middle of the screen, rather than displaying an Ubuntu logo. If you see an issue with similar-sounding symptoms, but see the Ubuntu logo, please file a new bug.

So far occurances of bug has been due to the VT (shared by Plymouth and the X server) being reset by Plymouth back into Raw Mode after X has started and set the VT into Canonical Mode. I had believed I had eliminated the code paths that could do this, but there must still be one out there somewhere.

I've been able to replicate this on a slow-booting laptop only so far

Changed in plymouth (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Scott James Remnant (scott)
milestone: none → ubuntu-10.04-beta-2
Draycen DeCator (ddecator) wrote :

I'm affected, as I marked at the top of the report. Please let me know if there are any files you want attached to this report.

Omer Akram (om26er) wrote :

For me this has been fixed with the latest version of plymouth. (0.8.0~-14)

Steve Langasek (vorlon) wrote :

Then you don't have this bug. This bug report was opened specifically to track a known outstanding issue in -14; it's not necessary to comment if you *don't* have this problem.

I always see this bug when booting todays 64bit iso via loopback from hd with karmics grub2 without the splash parameter.
On todays fully updated installed system I do not see the bug anymore even without the splash parameter.

cesconoa (cesconoa) wrote :

same problem... but not only in text mode. Also in graphical prompt for passwd.
It does not present if I use "ok" button.

It's combined with "plymouthd teminated with kill" in all shut-down!

On Sun, 2010-03-14 at 20:59 +0000, cesconoa wrote:

> same problem... but not only in text mode. Also in graphical prompt for passwd.
> It does not present if I use "ok" button.
>
Could you file a new bug for the fact you can kill X if you don't finish
entering a password in graphical mode

Scott
--
Scott James Remnant
<email address hidden>

Martin Erik Werner (arand) wrote :

Reproducible crash when pressing enter in todays liveCD, booted in virtualbox.

text splash is seen on bootup.

Steve Langasek (vorlon) wrote :

> Reproducible crash when pressing enter in todays liveCD, booted in virtualbox.

> text splash is seen on bootup.

That's a pending bug in ubiquity, not a bug in plymouth.

Martin Erik Werner (arand) wrote :

@Steve
Ubiquity is not running as a process when this happens... Sure this is the case?
Which is the bug no. for the ubiquity bug?
Notable though is that the crash only appears on liveCD.

Changed in plymouth (Ubuntu):
status: Confirmed → Fix Committed

The -16 plymouth package I've uploaded to my PPA should fix this, I would appreciate testing:

https://launchpad.net/~scott/+archive/ppa/

Draycen DeCator (ddecator) wrote :

@Scott
I installed Plymouth from your PPA, and unfortunately I'm experiencing the exact same behavior as before:

- "Ubuntu 10.04" is shown by Plymouth instead of the logo
- A lot of text fills up the Plymouth screen during boot up (I keep noticing fsck, but I'm not sure if it's being conducted or not)
- Hitting <Enter> after GDM loads causes it to "reload"

Please let me know if there are any files you would like from my system. If you come out with any other possible fixes, I will make sure to test them.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.0~-16

---------------
plymouth (0.8.0~-16) lucid; urgency=low

  * src/libply-splash-core/ply-text-display.c:
    - It turns out that resetting the VT back into KD_TEXT mode every
      second, while the X server is starting, is not perhaps the best
      idea. LP: #538213.
 -- Scott James Remnant <email address hidden> Wed, 17 Mar 2010 03:28:03 +0000

Changed in plymouth (Ubuntu):
status: Fix Committed → Fix Released
Jeff Lane (bladernr) wrote :

the updated plymouth package does not fix this issue for me...

Running a VirtualBox VM (1 proc, 1GB ram)

Had it with todays Lucid builds, and updated plymouth to 0.8.0~-16 using apt-get.

After installing that updated plymouth package, I restarted the VM and the X restart on hitting Enter still occurs.

plymouth:
   Installed: 0.8.0~-16
   Candidate: 0.8.0~-16
   Version table:
 *** 0.8.0~-16
           500 http://us.archive.ubuntu.com/ubuntu lucid/main Packages
           100 /var/lib/dpkg/status

On Wed, 2010-03-17 at 05:27 +0000, Draycen DeCator wrote:

> I installed Plymouth from your PPA, and unfortunately I'm experiencing the exact same behavior as before:
>
> - "Ubuntu 10.04" is shown by Plymouth instead of the logo
> - A lot of text fills up the Plymouth screen during boot up (I keep noticing fsck, but I'm not sure if it's being conducted or not)
> - Hitting <Enter> after GDM loads causes it to "reload"
>
Do you have cryptsetup installed?

Scott
--
Scott James Remnant
<email address hidden>

tags: added: iso-testing
Draycen DeCator (ddecator) wrote :

Yes I do.

cryptsetup: 2:1.1.0~rc2-1ubuntu12

On Wed, 2010-03-17 at 19:40 +0000, Draycen DeCator wrote:

> Yes I do.
>
> cryptsetup: 2:1.1.0~rc2-1ubuntu12
>
This means you have bug #540256 (they're all kinda related, but then so
is most of the population of Norfolk)

Scott
--
Scott James Remnant
<email address hidden>

Mark Lord (launchpad-rtr) wrote :

Still broken in fully released Lucid -- this is now August 2010.

Is there a known workaround that actually stops my system from crashing,
other than re-installing Hardy in place of Lucid ???????

Mark Lord (launchpad-rtr) wrote :

Speaking of which.

How the fsck can we get RID of this blasted plymouth bugfest entirely?

It appears to have a about a zillion packages that are dependent on it, so synaptic won't ditch it without tossing most of Lucid. What a screw-up.

I'm thinking something along the lines of this:

  updatedb
  locate plymouth | xargs rm

Got a better suggestion? This is just too painful. I *live* in text editors, and having them randomly crash the entire X session every 2-3 minutes is just stupid.

-ml

Changed in plymouth (Ubuntu):
status: Fix Released → Confirmed

To maintain a respectful atmosphere, please follow the code of conduct - http://www.ubuntu.com/community/conduct/ . Bug reports are handled by humans, the majority of whom are volunteers, so please bear this in mind.

Since this report was already fixed for the original reporter and his equipment, you should file a new report. You can do that using "ubuntu-bug plymouth", which will include the needed logs for your hardware.

Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
Mark Lord (launchpad-rtr) wrote :

There are already a zillion entries in launchpad for this bug.
Adding yet another one, fragmenting the reports even further, won't help.

Oh well. No wonder Ubuntu gets such bad press.
I don't agree with the bad press, but really.. this is a critical bug,
and shouldn't be swept away like that.

Cheers

Mark Lord (launchpad-rtr) wrote :

Ahh.. found the answer to my question.

Here's how to get rid of most of plymouth, and thereby get rid of most of the problems it causes, including this launchpad entried and numerous others:

dpkg --get-selections| awk '/^plymouth-theme/{print $1}' | xargs sudo apt-get purge

Cheers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers