gdm crashes once on keyboard input

Bug #534861 reported by Guy Van Sanden on 2010-03-09
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gdm

GDM always crashes once after boot up before logging in.
It rendenders fine and responds to mouse events, but when pressing any keyboard key it will crash and restart.

The second time, it works as expected.
I can reproduce this on 2 machines, one with an Intel video card and the other with an Nvidia card.

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 9 07:13:17 2010
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: gdm 2.29.6-0ubuntu7
ProcEnviron:
 LANGUAGE=en_DK:en_GB:en
 LC_CTYPE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/zsh
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: gdm
Uname: Linux 2.6.32-15-generic x86_64

Guy Van Sanden (gvs) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, does it crash on any key or enter? do you get the issue if you uninstall plymouth too?

summary: - gdm crashes once on keyboard input [lucid]
+ gdm crashes once on keyboard input
Changed in gdm (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Guy Van Sanden (gvs) wrote :

I don't think I can remove plymouth as it says:

# aptitude remove plymouth
...
Remove the following packages:
cryptsetup
plymouth-x11

Without cryptsetup I can't boot from my encrypted LVM

It crashes on all keys, sometimes I can get a couple of keystrokes in though.

Sebastien Bacher (seb128) wrote :

could you try to see if Xorg.0.log.* or dmesg or syslog list a crash?

Guy Van Sanden (gvs) wrote :

Attaching the log

Guy Van Sanden (gvs) wrote :

dmesg

Guy Van Sanden (gvs) wrote :

dmesg seems clean

Sebastien Bacher (seb128) wrote :

what about messages and syslog?

Guy Van Sanden (gvs) wrote :
Guy Van Sanden (gvs) wrote :
Guy Van Sanden (gvs) wrote :

I think plymouth is the cause, it boots in ASCII mode for some reason...

affects: gdm (Ubuntu) → plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package plymouth - 0.8.0~-13

---------------
plymouth (0.8.0~-13) lucid; urgency=low

  [ Steve Langasek ]
  * Don't attach /proc/cmdline to apport reports, this is already in the
    standard info that gets collected...

  [ Alberto Milone ]
  * ubuntu_logo theme:
    - New logo from Otto Greenslade.
    - Switch off dots starting from the ones on the left instead of
      switching them off all at once.

  [ Scott James Remnant ]
  * Move the Ubuntu logo up as discussed with Otto, this makes the mouse
    cursor appear between the logo and dots and solves the optical illusion
    of the logo being too low. LP: #535014.
  * Don't include message about disk checks, which can come from mountall.
  * Drop the rc script splash functions, we don't want the SysV-rc compat
    stuff messing around with the splash screen - this can be entirely
    managed by Upstart now. LP: #528787, #537262.

  * Plymouth Fix Mega Patch:
    - This hasn't yet been broken up into enough bits to send upstream, and
      doesn't *quite* address all the issues yet, but it's a major step.

    - Rewrite the VT handling, rather than abusing /dev/tty0 keep all VT
      operations on the actual VT (tty7), this avoids issues where we set
      the graphics mode of the wrong VT or put the wrong VT into VT_PROCESS
      mode. LP: #520460, #522598, #526321, #533135
    - Don't attempt VT switch when using non-VT consoles.
    - Make VT mandatory for renderer plugins, so we fallback gracefully to
      text when the console is not a VT. LP: #516825, #527083.
    - Restore VT when finished displaying the splash unless plymouth quit
      is called with --retain-splash. LP: #506297.
    - Activate VT from text and details plugins, rather than haphardly in
      the main code, this means the textual boot is also on VT7.
      LP: #518352, #520122.
    - Add a --has-active-vt command that can let gdm inquire whether it
      should reuse Plymouth's VT; fixes the issue where Plymouth has no
      visible splash screen and X ends up on VT1. LP: #519641, #533572.

    - Don't open terminal device in X11, fixes the issue where X will crash
      when debugging plugins using the X11 renderer.
    - Add --tty option to plymouthd for debugging when X is running and
      thus using an alternate VT.

    - Improve deactivate command so that the terminal is no longer watched
      for keyboard input, session is closed, etc. LP: #528787, #531650.
    - Ignore mode changes while deactivated, otherwise we can end up
      resetting the VT back into text mode while X is starting up.
      LP: #523788, #502509.

    - Fix races with simultaneous quit and deactivate commands, or multiples
      of those commands.
    - Ignore --show-splash, --hide-splash, etc. commands while deactivated.
    - Add reactivate command for testing purposes.

    - Don't scan out drm buffer contents to fbcon when not called with
      quit --retain-splash. LP: #527180.

    - Avoid resetting the terminal to unbuffered mode on every write, this
      results in setting X's VT into raw mode and results in the X server
      crashing on key presses. LP: #532047, #534861, #519460, #520...

Read more...

Changed in plymouth (Ubuntu):
status: New → Fix Released
Guy Van Sanden (gvs) wrote :

Fully updated 15 minutes ago and the bug is still there.

Guy Van Sanden (gvs) wrote :

I applied the workarround for the ASCII splash in plymouth here: http://www.webupd8.org/2010/03/how-to-get-plymouth-working-with-nvidia.html

And it also fixed this bug.

The fix Ubuntu released did not work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers