System fails to boot with plymouth installed (nouveau driver with >1 display)

Bug #533135 reported by bbordwell on 2010-03-06
358
This bug affects 58 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: plymouth

I have had plymouth removed for some time now due to the many problems it had been causing. All the old bugs i was experiencing have been fixed, but when i tried to reinstall plymouth my system becomes unbootable. The boot process is normal until after the splash screen dissapears. A blinking underscore comes up in the top left corner of the screen, which is what it used to do when i had plymouth installed. then it just hangs there with the blinking underscore and never does anything else. If i press the power button a bunch of messages come up about various proccesses being killed, the last of which is gdm, next should be plymouth and the shut down, but plymouth does not get killed causing me to have to kill the power. The only way to boot is to boot into recovery mode and remove plymouth, then everything works great.

ProblemType: Bug
Architecture: amd64
Date: Sat Mar 6 01:13:08 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100301)
MachineType: ECS G41T-M2
Package: plymouth (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-15-generic root=UUID=71761949-fd82-4179-87ff-386f767b13df ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: plymouth
Uname: Linux 2.6.32-15-generic x86_64
dmi.bios.date: 06/23/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080015
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: G41T-M2
dmi.board.vendor: ECS
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: ECS
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080015:bd06/23/2009:svnECS:pnG41T-M2:pvr1.0:rvnECS:rnG41T-M2:rvr1.0:cvnECS:ct3:cvr1.0:
dmi.product.name: G41T-M2
dmi.product.version: 1.0
dmi.sys.vendor: ECS

Related branches

bbordwell (benbordwell) wrote :
bbordwell (benbordwell) on 2010-03-06
Changed in plymouth (Ubuntu):
status: New → Invalid
bbordwell (benbordwell) wrote :

marking as invalid because a fresh install seems to have fixed the problem. Hopefully it was just a strange quirk with my setup.

bbordwell (benbordwell) wrote :

Okay fresh install the problem came back after a few restarts, unfortunately I am unsure what caused the problem to reappear. Once again removing plymouth let the system boot normally.

Changed in plymouth (Ubuntu):
status: Invalid → New
bbordwell (benbordwell) wrote :

I tried another fresh install. The only significant change i made from the default install was to install the updates. Where it stands right now is that pressing restart causes the system to fail to boot, but if i do a full shut down and then press the power button to start it up again it boots.

bbordwell (benbordwell) wrote :

haha sorry for all the comments but I am trying to get as much info about this bug as i can. I installed a few packages and ran sensors-detect. I then shut it down, waited ten seconds and then powered it back up. It failed to boot due to Plymouth hanging again, so i did a hard shut down and tried again, once again did not work. Just for the heck of it i tried once more and it worked this time. I am not a developer so I am not sure about these kind of things but random changes in behavior like this usually means some kind of a race condition is present correct?

successful and unsuccessful boots are the same until the splash screen goes away. On unsuccessful boots the blinking underscore appears in the top left (after a long while a message comes up and says something about Plymouth not responding for 120 seconds or something along those lines), but on the successful boots after the splash screen goes away the screen becomes corrupt and the a couple of seconds later my background image appears and the bars on the top and the bottom appear.

I am going to install the nvidia-proprietary drivers and see what affect that has on it.

bbordwell (benbordwell) wrote :

okay installed the nvidia proprietary drivers and did two soft restarts, both worked great, then did a complete shutdown and power on and it also worked great.

nouveau plus an nv50 card has got to be a pretty common setup for lucid testers is no one else getting this bug?

bbordwell (benbordwell) wrote :

I did a little more work to try and isolate this bug, i removed the nvidia proprietary driver and then unplugged the hdmi cable going to my tv. I then restarted twice and both went amazingly, the plymouth splash screen stayed up until my background image came up, first time i have seen the boot work the way it was designed. i then plugged the hdmi cable back in to the tv and restarted, wouldn't boot exactly as described in the bug report. I then unplugged the hdmi cable and tried again, this time the plymouth boot splash did not show up and i had the blinking underscore in the top left corner,but there are two differenced. It is responsive, if i press a button a symbol is typed, and the cursor is there and it moves. If i press enter it goes to the log in screen just as before (see bug 515412), i can then log in and everything works as expected.

So i think i finaly nailed down the conditions nessasary for this bug. nouveau driver with two screens plugged in.

When i get time i will try a fresh install and never plug in the tv and make sure things go well, once i have my system completely set up i will plug in the second display and I expect it will return me to a non booting/problematic computer.

bbordwell (benbordwell) wrote :

sorry I don't see a way to edit my comments. the bug referenced in post 7 should be bug 516412.

bbordwell (benbordwell) wrote :

yep after a fresh install i can confirm that plmouth only hangs with two displays plugged in.

I have this bug pinned down as specifically as i can so this should be the end of my comments :), if you need anymore info just ask i check my email frequently and i am running lucid for the sole purpose of bug hunting.

drs305 (drs305) wrote :

plymouth 0.8.0~-12

The boot problems with ureadahead/plymouth have been documented, but with today's updates 3-10-10 my system became unbootable. The system boots to an empty Desktop on which two blinking cursors intermittently jump as if proceeding along a text line, leaving a thin, garbled black streak behind them. The only way I can recover is a poweroff.

Removing plymouth/plymouth-X11 resolves the issue and the system boots normally. The failure is repeated any time I try to reinstall plymouth and reboot.

I have been effected by the bug before, but the system merely halted on the black screen with "ureadahead" failure messages. Pressing ENTER continued the boot to the logon screen (even though I had autologon enabled) and after entering the information the system booted normally.

Now the system doesn't boot.

I used "ubuntu-bug" to report this. It says the data was collected and sent, but in case not this is an amd_64 Lucid A3 install with an Nvidia 7600GS card, 2.6.32-16-generic

Steve Langasek (vorlon) wrote :

When the system is in this broken state after boot, please see whether Alt+SysRq+K succeeds in resetting it.

Changed in plymouth (Ubuntu):
status: New → Incomplete
bbordwell (benbordwell) wrote :

Alt+SysRq+k did not do anything for me.

bbordwell (benbordwell) wrote :

okay after testing that i unplugged the tv again and as usual with one display hooked up it booted beautifully, but just to make sure i pressed Alt+SysRq+K after it was completely booted and it did nothing, is this normal or should it kill X or something similar?

bbordwell (benbordwell) wrote :

haha okay i figured something was up since it did not do anything when it was working, so i went and found an old standard keyboard and it worked. I experimented with my main wireless keyboard and it turns out the F lock was on causing my SysRq not to send a signal.

So yes, Alt+SysRq+K does reset it, it goes to the login screen.

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package plymouth - 0.8.0~-13

---------------
plymouth (0.8.0~-13) lucid; urgency=low

  [ Steve Langasek ]
  * Don't attach /proc/cmdline to apport reports, this is already in the
    standard info that gets collected...

  [ Alberto Milone ]
  * ubuntu_logo theme:
    - New logo from Otto Greenslade.
    - Switch off dots starting from the ones on the left instead of
      switching them off all at once.

  [ Scott James Remnant ]
  * Move the Ubuntu logo up as discussed with Otto, this makes the mouse
    cursor appear between the logo and dots and solves the optical illusion
    of the logo being too low. LP: #535014.
  * Don't include message about disk checks, which can come from mountall.
  * Drop the rc script splash functions, we don't want the SysV-rc compat
    stuff messing around with the splash screen - this can be entirely
    managed by Upstart now. LP: #528787, #537262.

  * Plymouth Fix Mega Patch:
    - This hasn't yet been broken up into enough bits to send upstream, and
      doesn't *quite* address all the issues yet, but it's a major step.

    - Rewrite the VT handling, rather than abusing /dev/tty0 keep all VT
      operations on the actual VT (tty7), this avoids issues where we set
      the graphics mode of the wrong VT or put the wrong VT into VT_PROCESS
      mode. LP: #520460, #522598, #526321, #533135
    - Don't attempt VT switch when using non-VT consoles.
    - Make VT mandatory for renderer plugins, so we fallback gracefully to
      text when the console is not a VT. LP: #516825, #527083.
    - Restore VT when finished displaying the splash unless plymouth quit
      is called with --retain-splash. LP: #506297.
    - Activate VT from text and details plugins, rather than haphardly in
      the main code, this means the textual boot is also on VT7.
      LP: #518352, #520122.
    - Add a --has-active-vt command that can let gdm inquire whether it
      should reuse Plymouth's VT; fixes the issue where Plymouth has no
      visible splash screen and X ends up on VT1. LP: #519641, #533572.

    - Don't open terminal device in X11, fixes the issue where X will crash
      when debugging plugins using the X11 renderer.
    - Add --tty option to plymouthd for debugging when X is running and
      thus using an alternate VT.

    - Improve deactivate command so that the terminal is no longer watched
      for keyboard input, session is closed, etc. LP: #528787, #531650.
    - Ignore mode changes while deactivated, otherwise we can end up
      resetting the VT back into text mode while X is starting up.
      LP: #523788, #502509.

    - Fix races with simultaneous quit and deactivate commands, or multiples
      of those commands.
    - Ignore --show-splash, --hide-splash, etc. commands while deactivated.
    - Add reactivate command for testing purposes.

    - Don't scan out drm buffer contents to fbcon when not called with
      quit --retain-splash. LP: #527180.

    - Avoid resetting the terminal to unbuffered mode on every write, this
      results in setting X's VT into raw mode and results in the X server
      crashing on key presses. LP: #532047, #534861, #519460, #520...

Read more...

Changed in plymouth (Ubuntu):
status: Incomplete → Fix Released
bbordwell (benbordwell) wrote :

will confirm that the new version of plymouth fixed the problem.

bbordwell (benbordwell) on 2010-03-17
Changed in plymouth (Ubuntu):
status: Fix Released → New
bbordwell (benbordwell) wrote :

I am afraid I am going to have to reopen this bug. Plymouth is still hanging when i have two displays attached, i just got lucky after the first reboot after the update to ~14.

 Are there any log files I could provide that might be helpful? Now that I know the alt+sysreq+k workaround I can provide them.

Roman Yepishev (rye) wrote :

I am confirming that booting with DVI-D cable attached fails as well with nouveau.
Plymouth splash stays on the screen and X does not seem to be able to take over the screens.

02:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400M G] (rev a1)

If splash is removed from commandline then X is able to start with two outputs (LVDS/DVI-D)

I am attaching my Xorg log files in case it might be helpful to diagnose that.

Roman Yepishev (rye) wrote :
Roman Yepishev (rye) wrote :
Roman Yepishev (rye) wrote :
psierra (pscbarros) wrote :

Hi, I've the same issue with plymouth, my system doesn't at all. Tried to use 'S' 'I' 'F' or 'M' which appears on the screen nothing special besides a message saying 'init: plymouth main process (341) killed by SEGV signal'
I'm using a presario CQ61, intel, no additional monitor

Steve Langasek (vorlon) wrote :

psierra, please file a separate bug report for your issue.

summary: - System fails to boot with plymouth installed
+ System fails to boot with plymouth installed (nouveau driver with >1
+ display)
Steve Langasek (vorlon) wrote :

I've been able to reproduce this here on a test machine.

Changed in plymouth (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Dimitryyy (mr-dsh) wrote :

I have the same problem. Can t booting live cd Ubuntu 10.04 beta1 when >1 display. But problem was began earlier( alpha3 10.04), when i update kernel from 2.6.32-15 to 2.6.32-16, after reboot i had picture 1024 768 in the left high corner my display(22 inch 1680 1050) (i had nvidia driver at that moment), then i install kernel 2.6.34-rc1 and all works well. Now (find this post) i unplug second cabel, install beta1 daily-live 22-Mar-2010(excellent work) attached second cabe, not boot. Then again unplug cabel, install nvidia driver (attached second cabe) and have little picture in the high left corner 1024 768. Ok. Install kernel 2.6.34-rc1 all work well.And now if i boot 2.6.16 have little picture,boot 2.6.34-rc1 both display work well (1680-1050 and 800-600)
Nvidia 250GTS leadtek

TJ (tj) wrote :

Experiencing this bug with a Sony Vaio VGN-FE41Z which has an LVDS internal monitor and an external DVI-D connected via the docking station. During start-up output is mirrored to the external monitor.

The display 'stops' with the plymouth splash screen and the message "Press C to cancel checking disks". The Xorg log shows it started and got 'stuck' just after the nouveau driver probed the displays.

Using Alt+SysReq+K will kill all the processes on tty7 and restart Xorg which then presents the GDM greeter correctly.

Changing the kernel's command-line via the GRUB menu (edit entry, delete "splash", press Ctrl+X to start) also works around the issue.

Marc de Vries (madevr-orange) wrote :

Just wanted to say: This bug is fixed for me now (not sure why). Although the resolution of Plymouth changes while booting and it doesn't quite look right I get successfully to the login.

Ian Corne (icorne) wrote :

Still broken for me.

Ruben Verweij (ruben-verweij) wrote :

For me it works with the Ubuntu text theme, but the system hangs with the Ubuntu logo theme...

Ian Corne (icorne) wrote :

Same as Ruben, only the logo theme hangs the system.

The ubuntu-logo and ubuntu-text themes are very different; if ubuntu-text works, and ubuntu-logo does not, that implies a fault with the renderer.

Could you try one of the other graphical themes (e.g. plymouth-theme-spinfinity) and see whether it works or fails with that

Changed in plymouth (Ubuntu):
status: Triaged → Incomplete
Ian Corne (icorne) wrote :

The theme plymouth-theme-spinfinity also breaks booting.

Changed in plymouth (Ubuntu):
status: Incomplete → Triaged
Roman Yepishev (rye) wrote :

I am experiencing this issue and I found plymouthd process running when it should not be (at least it shuts down on my Aspire One netbook when GDM starts up).
The plymouthd process is so stuck that it is not possible for gdb to attach to it. It is not possible to kill plymouthd process with KILL signal as well.

Will try to do some stracing during the boot to find out what blocks it from exiting.

Roman Yepishev (rye) wrote :

After digging further I see that sometimes plymouthd does not receive quit command, but when it does, it hangs with the following:

(me sends quit command):

read(6, "Q\2", 2) = 2
read(6, "\1", 1) = 1
read(6, "\0", 1) = 1
getsockopt(6, SOL_SOCKET, SO_PEERCRED, "A\v\0\0\0\0\0\0\0\0\0\0", [12]) = 0
close(13) = 0
open("/lib/plymouth/themes/details/details.plymouth", O_RDONLY) = 7
fstat64(7, {st_mode=S_IFREG|0644, st_size=84, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb5fba000
read(7, "[Plymouth Theme]\nName=Details\nDe"..., 4096) = 84
_llseek(7, 0, [84], SEEK_CUR) = 0
read(7, "", 4096) = 0
read(7, "", 4096) = 0
read(7, "", 4096) = 0
read(7, "", 4096) = 0
read(7, "", 4096) = 0
close(7) = 0
munmap(0xb5fba000, 4096) = 0
open("/lib/plymouth/details.so", O_RDONLY) = 7
read(7, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\340\v\0\0004\0\0\0"..., 512) = 512
fstat64(7, {st_mode=S_IFREG|0644, st_size=9692, ...}) = 0
mmap2(NULL, 12532, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 7, 0) = 0xe8b000
mmap2(0xe8d000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 7, 0x1) = 0xe8d000
close(7) = 0
mprotect(0xe8d000, 4096, PROT_READ) = 0
mmap2(NULL, 196608, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb5f8b000
brk(0x8868000) = 0x8868000
mmap2(NULL, 204800, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb5f59000
brk(0x884f000) = 0x884f000
munmap(0xb5f8b000, 196608) = 0
mremap(0xb5f59000, 204800, 196608, MREMAP_MAYMOVE) = 0xb5f59000
write(12, "init: job_process_handler: Ignor"..., 195460) = 195460
munmap(0xb5f59000, 196608) = 0
ioctl(11, 0x641f, 0) = -1 EINVAL (Invalid argument)
ioctl(11, 0x40046486 <unfinished> ...
And hang happens.

Roman Yepishev (rye) wrote :

fd 11 is /dev/dri/card0.

So, plymouth sends some ioctl to the gfx card and then decides to hang completely.
Alt+SysRq+K on the plymouth terminal kills plymouthd and it allows gdm startup.

Vaibhav (vnagarnaik) wrote :

I am also facing this issue. Thinkpad W700 with NVidia FX3700M. The boot on the laptop with LVDS LCD screen is fine. Boot with laptop attached to a dock with 2 monitors (VGA and DVI-D) hangs with plymouth running. I can work around the issue by booting in recovery mode or without "splash" parameter in boot arguments. Running NOUVEAU driver for the card. It looks like from the Xorg.log, the hang is in NVEnterVT call rom NOUVEAU after it initializes XvMC extension.

Vaibhav (vnagarnaik) wrote :

I am also facing this issue. Thinkpad W700 with NVidia FX3700M. The boot on the laptop with LVDS LCD screen is fine. Boot with laptop attached to a dock with 2 monitors (VGA and DVI-D) hangs with no key presses acknowledged.
I can work around the issue by booting in recovery mode or without "splash" parameter in boot arguments. Running NOUVEAU driver for the card. It looks like from the Xorg.log, the hang is in NVEnterVT call from NOUVEAU after it initializes XvMC extension.

Paul Natsuo Kishimoto (khaeru) wrote :

I believe I may also be experiencing this bug, with a brand-new install of Lucid beta-2. The title certainly matches my problem.

lspci shows:
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

...this card has one DVI and one VGA output. When both outputs are connected, the system is *totally* unresponsive once it reaches the xsplash logo with "Ubuntu" and five orange dots (on a normal boot, this displays as the GDM login fades in).

If I disconnect either output, the system boots without issue; I can later reconnect the output, turn on the corresponding monitor, and use System > Preferences > Monitors to configure it, also without issue.

bedhead75 (bedhead999) wrote :

I can confirm this bug too when trying to boot Lucid beta 2 from the Live CD. Having two monitors connected to a Nvidia card hangs the boot process exactly as described. There is no hang when only one monitor is plugged in.

Nagappan Alagappan (nagappan) wrote :

With dual VGA card I'm able to successfully install Ubuntu 10.04 beta2 with the following procedure:

* Install Ubuntu 9.10 32/64-bit
* Update /etc/apt/source.list, Find Karmic, Replace with Lucid
* sudo apt-get update
* sudo apt-get install

Other changes I did:
* In Ubuntu 9.10 have installed Grub 1, as Clonezilla SE [1] doesn't support Grub2 the time I created Ubuntu 9.10 host image
* After installing 10.04, modified /boot/grub/menu.lst and removed quiet splash keywords, just to be safe :)

Note: With Ubuntu 10.04 beta2 ISO image I get the same issue as reported in this bug.

Thanks

[1] - www.clonezilla.org

Pat Callahan (pat-callahan1) wrote :

I just nominated this for Lucid because it prevents the beta 1 or beta2 install disks from proceeding beyond the initial screen with the dots. Kind of ironic, since the purpose of plymouth was to provide a smooth boot experience.

Anyway, if this is not fixed for the release, Ubuntu is going to have a whole bunch of unhappy campers.

This bug occurs on boot from

   beta1 i386
   beta2 i386

   installed beta2 from alternate cd

Pat Callahan (pat-callahan1) wrote :

Alt+SysReq+K is a workaround though.

Pat Callahan (pat-callahan1) wrote :
Steve Langasek (vorlon) wrote :

This may be a kernel bug; tracked in bug #539655.

Beta2 LiveCD (and fresh install)

I also get this ; the system becomes unresponsive at "4 red dots".

Booting to a recovery console and replacing nouveau with nvidia-current fixed the problem for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.2-1

---------------
plymouth (0.8.2-1) lucid; urgency=low

  [ Steve Langasek ]
  * New upstream release.
  * debian/plymouth.plymouth-stop.upstart: trust the new kdm to stop plymouth
    for us, too. LP: #540177.
  * plymouth needs to depend on initramfs-tools to avoid calling
    update-initramfs when the stack isn't configured yet and rendering the
    system unbootable with a broken initramfs. LP: #358654.
  * src/client/ply-boot-client.c: ply_boot_client_flush() needs to process
    the incoming queue before the outgoing, otherwise we get a deadlock.
    LP: #554737.
  * src/plugins/splash/script/script-lib-image.c: call script_obj_is_null()
    to check for the presence of the alpha argument, otherwise all our labels
    are rendered invisibly...
  * src/plugins/renderers/drm/plugin.c: temporarily disable the drm backend
    for nouveau, until we can get to the bottom of the DRM lockup in bug
    #539655. This is not as pretty, but it boots to the desktop without
    hanging regardless of how many displays are used, and that takes
    precedence. LP: #533135.

  [ Scott James Remnant ]
  * Implement a Window.GetBitsPerPixel() function in the script library,
    and the necessary support in ply_pixel_display, ply_renderer and in
    the vga16fb and frame-buffer renderers to make that information
    available. This will return "0" on drm and x11 where the answer is
    "lots". LP: #558352.
  * Modify vga16fb to only fallback to reducing colors if it's overflowed
    the 16-color palette already, so if you stick to the same 16 colors,
    you can get exact matches.
  * Use alternate 16-color images when we have only 4bpp. LP: #551013.

  [ Alberto Milone ]
  * ubuntu-logo: accept a format string from mountall for the disk check
    progress, so that localization is possible. LP: #553954.
 -- Steve Langasek <email address hidden> Thu, 15 Apr 2010 00:55:46 +0000

Changed in plymouth (Ubuntu Lucid):
status: Triaged → Fix Released
Nagappan Alagappan (nagappan) wrote :

I'm still noticing this issue with current-build live CD / Install Ubuntu option from grub menu - http://cdimage.ubuntu.com/daily-live/current/ 16-Apr-2010 08:30 695M Desktop CD for PC (Intel x86) computers (standard download)

Will it take time to reach the current-build ?

Thanks

Steve Langasek (vorlon) wrote :

plymouth 0.8.2-1 is included on the daily CDs for April 16. If you are still having problems, it's not the same bug as this one.

Dimitryyy (mr-dsh) wrote :

live CD 16-Apr-2010 I check. With my hardware (LCD (DVI) 'n' TV (DVI-VGA) have booting good.

f3a97 (f3a97) wrote :

I confirm the issue is fixed after an upgrade!

Many thanks guys!

Keep up the good work :)

I still have this around, with Lucid release. This bitter bug has also bitten me with Fedora 12 and Fedora 13 Alpha, under AMD64. With Lucid, I'm using the official CDs.

On Mon, May 03, 2010 at 02:58:15AM -0000, Ernesto Manriquez wrote:
> I still have this around, with Lucid release.

That's not possible. This bug is specific to the interaction between
nouveau DRM and plymouth, and in the final Lucid release, plymouth does not
use the DRM backend on nouveau. You have an unrelated issue and should file
a separate bug report, describing your problem in your own words.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

To post a comment you must log in.