Ubuntu

[Lucid] plymouth does not display when using nvidia drivers

Reported by Charlie Kravetz on 2010-01-13
306
This bug affects 66 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

RELEASE: Lucid Lynx
CD/DVD VARIANT: 32bit Xubuntu Alternate cd
ISO BUILD: Xubuntu lucid-alternate-i386.iso dated 2010-01-12.2
SYMPTOMS: After installing, using the "Guided partitioning using full disk with LVM Encryption", the installation completes normally. Remove the cd, as the system restarts. When the grub menu appears, the entry is blinking. As the timer counts down, the system appears to continue to start, but the screen goes black and remains black in all TTY's. The monitor has not shutdown, but the screens are black with no prompts.

STEPS TO REPRODUCE:
1. install from daily image
2. Partition using Guided, full disk, using LVM with encryption for the partition menu.
3. Allow the installation to complete.
4. Restart when it tells you to.
5. Observe the Grub menu and watch the monitor go blank.

The installation never asked for the PassPhrase, and perhaps it is hung waiting for input. It is not possible to tell with no prompts. Since it is an encrypted installation with no prompts, I can not get the log files.

Steve Langasek (vorlon) wrote :

Reassigning this to plymouth as a first pass.

What video chipset do you have in this system?

If you boot without 'splash', do you get a text prompt?

affects: ubuntu → plymouth (Ubuntu)

Sorry for taking so long. This was on a hardware test of Lucid, specs are:
Hardware test; 1.5GHz P4; 1GB RAM; NVidia 6200 w/256MB memory

Running without 'quiet splash', I don't get any prompt on the TTY it starts on. I am, however, able to switch to Alt+F1 and see it ask for the passphrase. Thanks. I never thought of that.

Thierry Carrez (ttx) wrote :

Also affects Ubuntu Server. The workaround works here as well.

summary: - [Lucid Xubuntu] fails to restart after installing full disk with
- encryption
+ [Lucid] fails to restart after installing full disk with encryption
Steve Langasek (vorlon) wrote :

No; bug #496765 is about the fact that the *text* passed as the --prompt argument to plymouth is not displayed. This bug (which I've just reproduced by passing i915.modeset=0 on the kernel commandline) is about getting a completely black screen with plymouth.

Should plymouth work on non-KMS video currently?

Alberto Milone (albertomilone) wrote :

Ok, I misread the description then.

As regards non-KMS drivers, plymouth should still work thanks to the vgafb16 module.

@Scott (Keybuk)
Any ideas as to why this doesn't work?

Steve Langasek (vorlon) on 2010-01-19
summary: - [Lucid] fails to restart after installing full disk with encryption
+ [Lucid] plymouth does not display when using nvidia drivers
Steve Langasek (vorlon) wrote :

Can someone with an affected system check what framebuffer (fb*) modules are loaded after boot when booting without 'splash'? What does /proc/fb show?

Claudio Moretti (flyingstar16) wrote :

claudio@Jarvis:~$ sudo /proc/fb
[sudo] password for claudio:
sudo: /proc/fb: command not found

On Tue, Jan 19, 2010 at 12:36:39PM -0000, Claudio Moretti wrote:
> claudio@Jarvis:~$ sudo /proc/fb
> [sudo] password for claudio:
> sudo: /proc/fb: command not found

This should be 'cat /proc/fb', not 'sudo /proc/fb'.

Thanks,
--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

$ cat /proc/fb
0 VGA16 VGA

I did a complete install on the same system that I used for ISO testing. I am including the install logs and lspci results for your consideration.

This is the syslog from the restart

This is the dmesg log from the restart

Let me know if you need any other logs. The installation will sit until after the bug is resolved.

Whoops, sounded strange:

root@Jarvis:~# cat /proc/fb
0 VGA16 VGA

On Tue, Jan 19, 2010 at 22:44, Steve Langasek
<email address hidden>wrote:

> On Tue, Jan 19, 2010 at 12:36:39PM -0000, Claudio Moretti wrote:
> > claudio@Jarvis:~$ sudo /proc/fb
> > [sudo] password for claudio:
> > sudo: /proc/fb: command not found
>
> This should be 'cat /proc/fb', not 'sudo /proc/fb'.
>
> Thanks,
> --
> Steve Langasek Give me a lever long enough and a Free OS
> Debian Developer to set it on, and I can move the world.
> Ubuntu Developer http://www.debian.org/
> <email address hidden> <email address hidden>
>
> --
> [Lucid] plymouth does not display when using nvidia drivers
> https://bugs.launchpad.net/bugs/506717
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: New
>
> Bug description:
> RELEASE: Lucid Lynx
> CD/DVD VARIANT: 32bit Xubuntu Alternate cd
> ISO BUILD: Xubuntu lucid-alternate-i386.iso dated 2010-01-12.2
> SYMPTOMS: After installing, using the "Guided partitioning using full disk
> with LVM Encryption", the installation completes normally. Remove the cd, as
> the system restarts. When the grub menu appears, the entry is blinking. As
> the timer counts down, the system appears to continue to start, but the
> screen goes black and remains black in all TTY's. The monitor has not
> shutdown, but the screens are black with no prompts.
>
> STEPS TO REPRODUCE:
> 1. install from daily image
> 2. Partition using Guided, full disk, using LVM with encryption for the
> partition menu.
> 3. Allow the installation to complete.
> 4. Restart when it tells you to.
> 5. Observe the Grub menu and watch the monitor go blank.
>
> The installation never asked for the PassPhrase, and perhaps it is hung
> waiting for input. It is not possible to tell with no prompts. Since it is
> an encrypted installation with no prompts, I can not get the log files.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/506717/+subscribe
>

Markus Korn (thekorn) on 2010-01-21
Changed in plymouth (Ubuntu):
status: New → Triaged
Sense Egbert Hofstede (sense) wrote :

I can confirm that Plymouth shows nothing but black on my system, which is using the nvidia-current drivers for its Nvidia Geforce 9600GT graphics card. However, when the moment arrives that ureadahead is killed, or when error messages are shown the black screen goes away and you see the lines of white text we wanted not to ruin our wonderful boot experience.

However, GDM is loaded after a while, so my issues may be unrelated.
If I should attach more information, please ask and I'll post it. The output of 'cat /proc/fb' here is "0 VGA16 VGA", just as the original reporter's.

Steve Langasek (vorlon) wrote :

certainly not 'triaged', we still have no idea what's going on here.

Changed in plymouth (Ubuntu):
status: Triaged → Confirmed
Steve Langasek (vorlon) on 2010-01-22
Changed in plymouth (Ubuntu Lucid):
milestone: none → lucid-alpha-3
Steve Langasek (vorlon) wrote :

I was able to reproduce this on a machine with intel video only by doing the following:

 - edit /usr/share/initramfs-tools/hooks/plymouth to comment out /lib/plymouth/renderers/drm.so and regenerate my initramfs
 - boot with i915.modeset=0 set

This is noteworthy because it appears the frame-buffer renderer does work when the framebuffer is intel, it just doesn't work when it's vga16fb. Will continue working on debugging this, and will reboot again with the drm renderer enabled to reconfirm that plymouth does work with i915.modeset=0.

Steve Langasek (vorlon) wrote :

Sorry, it seems I misremembered. With the drm renderer enabled, i915.modeset=0 also causes plymouth to fail to show up. With the drm renderer excluded from the initramfs, but without passing i915.modeset=0, splash screen appears correctly.

The net conclusion seems to be the same: the frambuffer renderer works with inteldrmfb, but not with vga16fb.

Steve Langasek (vorlon) wrote :

Oh, well, here's the problem when trying to use vga16fb. In src/plugins/renderers/frame-buffer/plugin.c:

  if (fixed_screen_info.visual != FB_VISUAL_TRUECOLOR ||
      variable_screen_info.bits_per_pixel < 16)
    {
      ply_trace ("Visual is %s; not using graphics\n",
                 get_visual_name (fixed_screen_info.visual));
      return false;
    }

Since vga16fb is, by definition, less than 16 bpp (vga16fb = 16 colors = 4 bit indexed), if this is the only framebuffer available, the plymouth framebuffer renderer won't work.

So we either need some working fallback to text output, or we need someone to port this code to the VGA colormap...

Changed in plymouth (Ubuntu Lucid):
status: Confirmed → Triaged
Steve Langasek (vorlon) wrote :

As already noticed in the duplicate bug report, booting with 'vga=<mode>' also works around this issue by forcing the use of the VESA fb instead of the VGA16 fb. That's not suitable as a solution for this by default on users systems, however.

Steve Langasek (vorlon) wrote :

The text fallback wasn't working because the script plugin, despite having no support for non-framebuffer output, wasn't telling plymouth this. I've applied a patch to bzr that fixes this. I'm not sure if we should consider this bug closed, or if we should be targeting getting plymouth running in GUI mode on vga16fb systems.

(Also, it looks like plymouth is crashing for me when using the text plugin, so I'll be debugging that before I'll upload this, regardless.)

Sense Egbert Hofstede (sense) wrote :

I'd go for keeping this bug as getting something usable -- text mode in this case -- for vga16fb systems and file a separate bug for getting something visual working on that fb, especially since it seems a lot of work to me to port the code to a new colourmap.

By the way, I'm pasing the 'vga=' argument, but all that changed is that now Grub2 warns me that the argument is deprecated in favour of gfxpayload, which cannot be set in /etc/default/grub -- that is a bug report somewhere, not sure if also on LP though. I still don't have a proper boot splash.

Steve Langasek (vorlon) wrote :

I agree; considering this fix complete.

> By the way, I'm pasing the 'vga=' argument, but all that changed is
> that now Grub2 warns me that the argument is deprecated in favour of
> gfxpayload, which cannot be set in /etc/default/grub -- that is a bug
> report somewhere, not sure if also on LP though. I still don't have a
> proper boot splash.

It's not obsolete at the kernel level. Where are you adding this vga setting? It should be added to the "GRUB_CMDLINE_LINUX_DEFAULT" setting; see https://help.ubuntu.com/community/Grub2 for information about configuring grub2.

Changed in plymouth (Ubuntu Lucid):
status: Triaged → Fix Committed
Sense Egbert Hofstede (sense) wrote :

I've added "vga=0x0369" to the argument list in GRUB_CMDLINE_LINUX_DEFAULT, nevertheless I do get the warning that it is deprecated. This is also what is said elsewhere on the internet, Grub2 has deprecated this boot option.
I'll try the GRUB_GFXMODE option to see what it does.

exploder91 (d-cosner) wrote :

This problem is still present with nvidea graphics. This is marked as "Fix Committed", has the fix just not made it into the repos yet? The report also says that 3 people are effected, there are more than 3 people effected by this bug. I am guessing that most people just did not want to add a "me too" to this bug report.

I am only posting to confirm that this bug is still present with nvidea graphics.

Sense Egbert Hofstede (sense) wrote :

exploder91: Fix Committed means indeed that the fix hasn't landed in the repositories yet. The status will be Fix Released when that's happened.
The number of affected people is as low or high as the number of people who visited this bug report and told Launchpad they were affected as well.

I've tried everything that has been posted and still no plymouth, nvidia 6200

Changed in plymouth (Ubuntu Lucid):
status: Fix Committed → Incomplete
status: Incomplete → In Progress
status: In Progress → Fix Released
status: Fix Released → Incomplete
exploder91 (d-cosner) wrote :

Sense Hofstede, I misunderstood the status of this before I posted, sorry about that. I am enjoying the LTS so much and I was just trying to do my part with the bug reporting. I will try to be more careful when it comes to reading the status in the future. Again, sorry for my mistake and thank you.

Sense Egbert Hofstede (sense) wrote :

cecilpierce: Please don't change the status without knowing what you're doing. It was set to Fix Committed because a fix is committed but still pending or not in the repositories due to a different cause. When it will be set to Fix Released the fix should be in the Lucid repositories and then you could properly say if the fix works or if it doesn't. However, even then the status doesn't have to be Incomplete since we've already confirmed the existence of this bug.

exploder91: Don't apologise for not knowing something! You did nothing wrong and we can't expect someone to know right from his/her birth how we use the different statuses.

Changed in plymouth (Ubuntu Lucid):
status: Incomplete → Fix Committed
exploder91 (d-cosner) wrote :

Thanks Sense Hofstede! I have a better understanding of the status now. I see some outstanding work in this release and just wanted to be sure what was happening with this issue. The system boots up so fast that Plymouth is not going to displaying very long anyway. This release is pretty easy to get exited about, it is really nice and there is still a lot of development time remaining. I honestly have that thought in the back of my mind that this is that Windows killer system we have all thought about for years. Yes, I think it is that good!

Joel Ebel (jbebel) on 2010-01-27
tags: added: glucid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.0~-8

---------------
plymouth (0.8.0~-8) lucid; urgency=low

  [ Steve Langasek ]
  * Include label.so in the initramfs, as well as the font support files it
    depends on, needed for any text prompts or messages. This will bloat the
    initramfs substantially (about 3MB) and impact boot performance as a
    result, but the solution to that is to not include plymouth in the
    initramfs unless we know it's needed for prompting (e.g., cryptsetup).
    LP: #496765.
  * Move x11 renderer into a separate package, to avoid pulling GTK into the
    server install by default. LP: #509579.
  * debian/rules: fix up the dh_makeshlibs exclude path to match where we're
    currently installing.
  * src/plugins/splash/script/plugin.c: the script plugin has no support at
    all for text consoles, so if there are no pixel displays available,
    return an error so that plymouth can fall back to the text plugin.
    LP: #506717.
  * Always include the 'details' and 'text' themes in the initramfs, since
    plymouth uses these as built-in fallbacks and they're tiny.
  * src/main.c: when a splash plugin fails to load, make sure to unregister
    any related keyboard handlers.
  * don't let the password walk off the end of the dialog box. LP: #496782.
  * split the plymouth upstart job into plymouth and plymouth-splash, so that
    plymouth starts up early and doesn't have to race gdm; and stop
    unconditionally adding plymouth to the initramfs now that we can start it
    this way.
  * debian/plymouth.postinst: also set the theme on first install, or on
    upgrade from versions prior to 0.8.0~-7, because update-initramfs called
    before plymouth has been configured for the first time will accidentally
    cause a call to --reset to use the text theme instead of the intended
    default.
  * debian/plymouth.plymouth-splash.upstart: don't wait on tty-device-added,
    these are now guaranteed to be available; copied from gdm upstart job.
  * Depend on mountall (>= 2.0) to ensure we have the above guarantee.
  * Mark /usr/share/initramfs-tools/scripts/init-bottom/plymouth executable,
    otherwise initramfs-tools skips it. LP: #509487.
  * Drop the Debian revision (-1) from the version in the symbols file, to
    fix a lintian warning.
 -- Steve Langasek <email address hidden> Tue, 02 Feb 2010 08:11:47 +0000

Changed in plymouth (Ubuntu Lucid):
status: Fix Committed → Fix Released
philinux (philcb) wrote :

Not working here with nVidia-current driver

Black screen at startup the fsck messages etc then GDM.

Steve Langasek (vorlon) wrote :

philinux,

do you have the 0.8.0~-8 version of plymouth installed?

philinux (philcb) wrote :

Hi Steve,

I'm fully up to date but....

apt-cache policy plymouth
plymouth:
  Installed: 0.8.0~-7
  Candidate: 0.8.0~-7
  Version table:
 *** 0.8.0~-7 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Sense Egbert Hofstede (sense) wrote :

philinux: actually you're not. You're running Plymouth '0.8.0~-7', whereas the version that should work is Plymouth '0.8.0~-8'. It's in the last number.

philinux (philcb) wrote :

@Sense, I could see that I'm running an older version but lucid is fully up to date. Where does the 0.8.0~8 version come from.

Sense Egbert Hofstede (sense) wrote :

The '0.8.0~8' version comes from Steve's reply and the changelog that was posted in this bug report. The fact that you couldn't update to the latest version was probably caused by the latest version not being synced with your repository yet. It takes a while before packages reach the archives after they were built on Launchpad.

As the original reporter on this bug, I can report that I now get a prompt for the passphrase. After installing, using the "Guided partitioning using full disk with LVM Encryption", the installation completes normally. Remove the cd, as the system restarts. When the grub menu appears, the entry is blinking. After entering the passphrase on a black screen with no prompts, the system did boot to the gdm screen. I logged in to the desktop and applied all the updates. I then restarted. Unfortunately, the screen begins to scramble after entering it, and the gdm prompt no longer comes up. Instead, I get a screen with about divisions on it, that I can see. I logged in to a tty, and plymouth is now '0.8.0~-8'.

Am I now seeing a new bug, and if so, is it because of this change or another one?

Just to verify, I also did this installation in a VirtualBox, and it worked. I could also log in through gdm after the updates and restart. I also installed without encryption and failed to get the gdm screen after updating.

Steve Langasek (vorlon) wrote :

Let me see if I've understood right - after upgrade to plymouth 0.8.0~-8, you do correctly get prompted for the passphrase on boot, which didn't work before; and then the screen is messed up afterwards? I guess that will be a new bug.

When you do see the prompt for the passphrase, what does the prompt look like? Is it text-only?

Just upgraded to 0.8.0~-8 and can confirm I now get the password prompt, however I have a new problem where the "Unlocking disk" message appears everytime a letter in the passphrase is entered - attached a photo to illustrate

Sorry, just realised I didn't have splash on my grub command - running with splash enabled it works as expected - the above behaviour is not plymouth related.

philinux (philcb) wrote :

Righto got 0.8.0~-8

No plymouth at startup. Fsck messages then corrupted sort of blue/white progress bar at bottom of screen. Locked up solid at gdm had to reisub and reboot twice to get in to desktop. Using the terminal causes a hard freeze too.

This is after purging and reinstalling plymouth too.

philinux (philcb) wrote :

Terminal has decided not to lock up solid this reboot.

apt-cache policy plymouth
plymouth:
  Installed: 0.8.0~-8
  Candidate: 0.8.0~-8
  Version table:
 *** 0.8.0~-8 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

philinux (philcb) wrote :

Update.

Had to chroot in to lucid and purge plymouth. It was causing a hard lockup on logging in at gdm.

Recovery mode hangs at resume normal boot.

I can now boot into lucid with no problems.

I see the grub menu (multiple drives and installs), then a black screens for a couple of seconds, then a text-only prompt for the password:

     Unlocking the disk /dev/disk/by-uuid/UUID_OF_THE_DISK (sda1_crypt)
                 Enter passphrase: :

Yes, it is two lines, and there are two colons after passphrase, with a space in between them. This is more or less centered on my screen, from top to bottom(displays in the middle of the black screen). The rest of the screen is blank.

Fred (ian-bews) wrote :

plymouth:
  Installed: 0.8.0~-9
  Candidate: 0.8.0~-9
  Version table:
 *** 0.8.0~-9 0
        500 http://gb.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

No plymouth at startup. Fsck messages then corrupted sort of blue/white progress bar at bottom of screen.

Also still getting this freezing bug:
https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/516412
...if it's relevant.

Steve Langasek (vorlon) wrote :

The blue/white progress bar isn't corrupted, it /is/ plymouth. You do have plymouth at startup; you don't have a graphical splash screen at startup, because the nvidia driver doesn't expose a framebuffer that plymouth can use to display graphics. The latter is an issue that should be addressed, but is separate from not getting *any* feedback on nvidia chips.

philinux (philcb) wrote :

Hi Steve,

Re my post #51. Any idea whats causing the hard lockup?

Also is the bug status wrong now.

Claudio Moretti (flyingstar16) wrote :

Not really; plymouth shows up; it does not work, but it is shown, so this bug is fixed.
We need to file another bug for this.
I don't have time now, can one of you do it and link it here, please?

philinux (philcb) wrote :

https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/506717

My problem namely the gdm lockup on pressing the enter key to login can be got around by alt+SysRq+k then login again.

Claudio Moretti (flyingstar16) wrote :

The GDM lookup problem is discussed, if I'm not misunderstanding, in bug #516412.
Try subscribing there :)

philinux (philcb) wrote :

Thats the copy and paste bug again at work.

Seems to paste a previous copy. Bug 516412 was linked in post #53 which is what I was supposed to be pasting.

Claudio Moretti (flyingstar16) wrote :

err.. What?

On Mon, Feb 8, 2010 at 19:50, philinux <email address hidden> wrote:

> Thats the copy and paste bug again at work.
>
> Seems to paste a previous copy. Bug 516412 was linked in post #53 which
> is what I was supposed to be pasting.
>
> --
> [Lucid] plymouth does not display when using nvidia drivers
> https://bugs.launchpad.net/bugs/506717
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: Fix Released
> Status in “plymouth” source package in Lucid: Fix Released
>
> Bug description:
> RELEASE: Lucid Lynx
> CD/DVD VARIANT: 32bit Xubuntu Alternate cd
> ISO BUILD: Xubuntu lucid-alternate-i386.iso dated 2010-01-12.2
> SYMPTOMS: After installing, using the "Guided partitioning using full disk
> with LVM Encryption", the installation completes normally. Remove the cd, as
> the system restarts. When the grub menu appears, the entry is blinking. As
> the timer counts down, the system appears to continue to start, but the
> screen goes black and remains black in all TTY's. The monitor has not
> shutdown, but the screens are black with no prompts.
>
> STEPS TO REPRODUCE:
> 1. install from daily image
> 2. Partition using Guided, full disk, using LVM with encryption for the
> partition menu.
> 3. Allow the installation to complete.
> 4. Restart when it tells you to.
> 5. Observe the Grub menu and watch the monitor go blank.
>
> The installation never asked for the PassPhrase, and perhaps it is hung
> waiting for input. It is not possible to tell with no prompts. Since it is
> an encrypted installation with no prompts, I can not get the log files.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/506717/+subscribe
>

Timo Reimerdes (timorei) wrote :

apt-cache policy plymouth
plymouth:
  Installiert: 0.8.0~-10ubuntu1
  Kandidat: 0.8.0~-10ubuntu1

sudo plymouth-set-default-theme ubuntu-logo --rebuild-initrd
update-initramfs: Generating /boot/initrd.img-2.6.32-14-generic-pae

cat /proc/fb
0 VGA16 VGA

No properly working plymouth on my ASUS laptop running proprietary nvidia drivers.

dei (cephos) wrote :

Have the same problem like Fred and probably chillshock with the blue/green/white bars on the bottom.

plymouth 0.8.0~-10ubuntu1

Should be this bug: https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/526892
You can subscribe, to get informed when it gets changed.

Rajeev Nair (rajeev) wrote :

What about ATI cards? I have an ATI Radeon 4850 with the open source driver.I dont see nothing.

Rajeev Nair: Have you filed a new bug for that? This was determined to be NVIdia and Plymouth, and has been fixed.

Gabriel Mazetto (brodock) wrote :

I have plymouth 0.8.0~-12 and I still having problems...

still seeing the problem here

karl (karl-sebastian-liebich) wrote :

0.8.0~-17 and black screens too.

Chaostya (chaostya) wrote :

Latest Lucid
Plymouth Version: 0.8.1-2
Intel with KMS

On boot I see GRUB menu, then "Starting up..." and then GDM login screen appears. No bootsplash. When I shutdown new shutdown splash appears.

hikaricore (hikaricore) wrote :

I have a couple systems that I work on which this is still an issue on.
Fix plymouth...

Sense Egbert Hofstede (sense) wrote :

I can confirm that this issue is fixed in Lucid for Nvidia when you're using the closed driver.

Chaostya: this bug report is for Nvidia, you're using Intel. Rajeev: same for you, but you're using ATi. Those errors belong in different bug reports.

By the way, hikaricore, comments like "Fix plymouth..." are not really helpful. I hope you can see why.

I tried this steps, and it isn't working for me:

"Step 1: we must edit the /etc/default/grub file.
Open a terminal and paste this:
         sudo gedit /etc/default/grub
On line #18, uncomment (uncomment = remove the "#" in front of the line( "#GRUB_GFXMODE=640x480" and change the resolution to whatever you want. Here is how it should look:
         GRUB_GFXMODE=1024x768
Step 2: edit the /etc/grub.d/00_header file.
         sudo gedit /etc/grub.d/00_header
And find the following line: "gfxmode=${GRUB_GFXMODE}" (it's line 103 on my computer) and under it, paste this:
         set gfxpayload=keep
Step 3: update Grub 2:
To update the GRUB, simply run the following command:
        sudo update-grub
Once you complete the above steps, restart the computer and you should see the nice Plymouth screen like in the screenshot in the beginning of the post."

I'm still seeing blue progress bars instead of a nice plymouth splash... If I revert the changes, do you guys think plymouth should work? Or what can I do to fix that?

Oh, sorry for the last post... i should have put that on bug 526892 and not this one.

Jan Henkins (jhenkins) wrote :

Hello,

I've got the latest Lucid update (Beta2, updated approx Mon Apr 19 22:41:00) with Plymouth 0.8.2-2. My GFX is a GeForce 6200, and the above problem still persists with this setup. The status of this bug is "Fix Released"

Is there any logs/data that I could add that would be helpful?

Botond Szász (boteeka) wrote :

I can confirm that the bug is still not fixed.

Lucid 64 bit.
GeForce 8500 GT
NVIDIA Driver Version: 195.36.15

Cedric (cedric-brandenbourger) wrote :

Bug still not fixed, got the same problem.
Try the 3 steps, but then, my computer freeze before kdm login

jd65pl (jamie-dumbill) wrote :

I have this problem with the NVidia proprietary driver

uname -srm
Linux 2.6.32-21-generic x86_64

lsb_release -r
Release: 10.04

Nvidia driver: 195.36.15

plymouth:
  Installed: 0.8.2-2ubuntu2
  Candidate: 0.8.2-2ubuntu2
  Version table:
 *** 0.8.2-2ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

grep -iE 'gfx' /etc/default/grub
#GRUB_GFXMODE=640x480
GRUB_GFXMODE=1920x1200

grep 'gfxpayload' /etc/grub.d/00_header
  set gfxpayload=keep

Grub has been updated

philinux (philcb) wrote :

This fix worked for me. From a vanilla install. Instead of 12 seconds of blinking black cursor before plymouth I now have a smooth boot experience.

gksu gedit /etc/initramfs-tools/conf.d/splash
and add this option FRAMEBUFFER=y, save the file, then
sudo update-initramfs -u

philinux (philcb) wrote :

Forgot to add nVidia 8600GT

Same problem for me, I got the splash screen but in bad resolution with nvidia proprietary driver

philinux (philcb) wrote :

The fix for the resolution was this for me.

gksu /etc/default/grub

and add the line after GRUB_GFXMODE
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
GRUB_GFXPAYLOAD_LINUX=1680x1050 Save the file and run

sudo update-grub

The resolution chosen should be your monitors native resolution.

jd65pl (jamie-dumbill) wrote :

#77 does not work for me, I am using the driver directly from Nvidia rather than the one in the repos if that makes any difference.

Nvidia GeForce GT240
(See #76 for more details)

Tuxerito (tuxerito) wrote :

Fix it with the solution of philinux, message #77

nVidia 7150M
plymout 0.8.2-2ubuntu2

Tanks philinux

#77 doesn't work either for me, on two pc with nvidia drivers (nvidia Geforce 8400GS, nvidia ION)

jd65pl (jamie-dumbill) wrote :

#77 Doesn't work with the latest nvidia drivers either.
NVidia 195.36.24

Nicolas which driver are you using?

J.A. Sully (justin-sully) wrote :

on Ubuntu Lucid (all updates applied) with NVIDIA Quadro NVS 140m
Booting seems to take longer in 10.04 than it did in 9.10...but it may just be more flickery and in worse resolution. I've tried and undone every work around I can find. Would be great if a proper fix was released for this soon.

nothing works for me too. 8400GS, booting I get "Input not supported". drivers from repos.

I'm using 195.36.15.

Leonardo Torok (leotorok) wrote :

I'm using NVidia driver (195.36.15). Plymouth is displayed correctly, but I only got a black screen after it disapears. GDM only appear if I press ctrl + alt + f8 and go back to X with ctrl + alt + f7. All the virtual terminals (ctrl + alt + 1,2..) are with the fonts messed up.

Leonardo Torok (leotorok) wrote :

I've found an workaround: adding "vga=792" at the end of the entry in /boot/grub/menu.lst (i'm using the old Grub, i've dist-upgraded since hardy, passing by all releases).
With that change, GDM appears correctly, the virtual terminals are ok and plymouth doesn't stays ugly (now it's displaying correctly, with Ubuntu logo. Before that, it was a purple screen with "ubuntu 10.04" written on it and a progress bar).
I'm seeing some people (with Nvidia cards) suffering with that problem too.

Jack Dale (jack-dale) wrote :

Something similar to #71 worked well for me until recent kernel update
then removed all changes from #71

Tried #80 but did not work for me

#77 WORKS PERFECTLY for me:
NVIDIA GeForce 9600
Driver 195.36.15

Thanks philinux

Ron S (ronshere-people) wrote :

Never saw plymouth at all on boot or shutdown just a few colored pixels at the top of the screen and when a disc check was being done there was no message at all just a minute longer of black screen.
Using fix #77 fixed these problems.
Nvidia GeForce 8600 GT
Driver 195.36.15

jd65pl (jamie-dumbill) wrote :

After:
apt-get install kubuntu-destop

Missing packages were installed, I now have plymouth.

juanlucer (jlcv19) wrote :

Fix #77 has worked for my GeForce 7300 SE/7200 GS and 195.36.15 driver version
Before this I had several seconds of a black screen with a blinking cursor in the top left corner followed by less than a second of plymouth (0.8.2-2)

eris23 (jdkatz23) wrote :

With fix #77 plymouth was visible, but the grub menu wasn't.

philinux (philcb) wrote :

Error in #80. Should have been.

gksu gedit /etc/default/grub

eris23 (jdkatz23) wrote :

On my lucid system with nVidia 8800GT
Adding:
GRUB_GFXMODE=1920x1200
GRUB_GFXPAYLOAD_LINUX=1920x1200
to /etc/default/grub
and
FRAMEBUFFER=y
to /etc/initramfs-tools/conf.d/splash
seems to work.
Grub is visible, plymouth is visible during boot (I haven't checked shutdown, yet), and text consoles are visible.

Ivan Diaz (saisyukusanagi) wrote :

The same on mi desktop:

/etc/default/grub :

GRUB_GFXMODE=1440x900
GRUB_GFXPAYLOAD_LINUX=1440x900

/etc/initramfs-tools/conf.d/splash :

FRAMEBUFFER=y

As root or sudo:

update-initramfs -u
update-grub

TTy's are OK

Thank you community :)

yurik81 (yurik81) wrote :

Solution #77 was helpful for me. Thanks.

Why this solution still not in Ubuntu?

ippsatsi (laz133) wrote :

Solution # 97 works for me.
/etc/default/grub :

GRUB_GFXMODE=1280x1024
GRUB_GFXPAYLOAD_LINUX=1280x1024x32

/etc/initramfs-tools/conf.d/splash :

FRAMEBUFFER=y

As root or sudo:

update-initramfs -u
update-grub
Using GRUB_GFXPAYLOAD_LINUX=1280x1024x24, colors incomplete.
Nvidia 8600gt nvidia 195.36

doesn't work for me on Ubuntu 10-04 32bits on HP mini 311c (Nvidia ION) and Ubuntu 10.04 64bits on pc with Geforce 8400GS, with nvidia 195.36.24 for both :s

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers