mountall: could not connect to Plymouth

Bug #499772 reported by Per Ångström on 2009-12-23
74
This bug affects 16 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

After the latest round of updates, Plymouth apparently does not start, given the message that is displayed on startup:
mountall: could not connect to Plymouth

After that, there is trouble determining my graphics driver (intel 945 something), and I am given the usual recovery options, after which the graphics look fine.

ProblemType: Bug
Architecture: amd64
Date: Wed Dec 23 10:57:16 2009
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.0~-6
ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
SourcePackage: plymouth
Tags: lucid
Uname: Linux 2.6.32-9-generic x86_64

Per Ångström (autark) wrote :

Please read http://www.chiark.greenend.org.uk/~sgtatham/bugs.html.

Your report is completely unclear to what has happened on your computer; I'm left with the distinct impression that your system booted just fine.

In particular I have no idea what the "usual recovery options" are - since we completely rewrote those in 10.04 and if you're seeing something you'd normally expect, then you can't be running 10.04 ;-)

Changed in plymouth (Ubuntu):
status: New → Invalid
Per Ångström (autark) wrote :

Sorry for being unclear but I don't know what happened either. Something must be wrong, or that message should not have been displayed. If it is normal not to be able to connect to Plymouth, please remove the message so it doesn't confuse anyone. As this behavior is new, I thought it was interesting and should be reported.

About the "usual recovery options", I mean the options you get when there is something wrong with the graphics, such as "continue with a low resolution for the rest of session", "investigate the error", and such like. I guess I've seen that dialog too often, so I've become used to it, but it's not what I normally expect to see.

nicobrainless (nicoseb) wrote :

This is not a plymouth bug!
Plymouth is not needed by mountall and with or without plymouth I get the same error message:
mountall can not connect to plymouth.

This is a libplymouth2 or a mountall issue
In my case it broke the system... I can not start the computer anymore!

Christopher (soft-kristal) wrote :

I can confirm the message 'mountall: could not connect to Plymouth' is the first thing displayed on boot in Lucid. Most of the time it boots but I had trouble moments ago when the boot just stopped. Ctrl+Alt+F2 brought me to a login screen, but nothing appeared when I typed my username and I had to power off the laptop.

I also often have the low graphics message, although everything displayed (I have Cosmos as my desktop) other than Visual Effects - which are reset to None instead of Extra - appears to be normal.

Christopher (soft-kristal) wrote :

Attaching log file.

Per Ångström (autark) wrote :

@Christopher:
Please note that this bug has been deemed Invalid, so all your efforts are probably never going to get noticed by the right people. I suggest you take a look at bug #502492, which looks similar but more to the point.

Per Ångström (autark) wrote :

Sorry, wrong reference, should be bug #502494.

vinceee (ubuntu-genot) wrote :

hello,
i have the same problem on my asus eeepc 901 - fr, ubuntu lucid -fr since the last update. i am a newby on ubuntu, tell how i can help you, and how can give you the log file.

tags: added: iso-testing
Rajinder Sandhu (sandy744) wrote :

Same is the problem with me too... I am using Lucid 2.6.32-7-generic on x86 machine
The screen output is as follows:
mounting none on /dev no such device fail
mountall could not connect to plymouth

it has happened since last update although 2.6.32.10 is installed but that is also not being displayed in the boot menu options menu so that I can select and boot from it.
Then other thing I could not open any partition other than Lucid, checked and found privileges of root and user were lying blank then manually updated priviges of root and user, now I can see the other partitions and open them.
Thanks
Rajinder

Kreuger Burns (car-crazy33) wrote :

I get this message about mountall not connecting to plymouth as well but it doesnt affect my usage at all. I can still login and run the computer no problems.

holstein (mikeholstein) wrote :

same for me... no noticeable effect, i just get the 'mountall: could not connect to plymouth' message, and then the computer boots normally...

Areia (musicareia) wrote :

Same here!!! Normal boot, but no splash.

pedroh (higuchip) wrote :

Same problem here. I can not start the computer anymore. How could I fix this problem if I cant boot my computer even in text mode?

DrPaulaner (dr-paulaner) wrote :

same in here, stops booting with the note Mount all: cant connect to playmouth

so i do have a login line; if i put in my loginname, password, i can do a "startx"

gnome ist starting fine for 2 mins, after this time it resets me to the gdm login window.

BUT only if i use 2.6.32-25 kernel, all is fine if i use 2.6.32-22 the bug came with the latest updates from tonight

ubuntu 10.04 amd 64

DrPaulaner (dr-paulaner) wrote :

still no solution ;-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers