plymouth ask-for-password doesn't display --prompt argument

Bug #496765 reported by Steve Langasek on 2009-12-14
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Steve Langasek
Lucid
High
Steve Langasek

Bug Description

Binary package hint: plymouth

Updating cryptsetup to integrate with plymouth, I find that I'm presented at boot with a padlock and an entry field, but no text explaining what I'm unlocking. This information has been passed as 'plymouth ask-for-password --prompt="my prompt string"', but plymouth doesn't appear to be using it.

Since a system may have multiple encrypted disks, each requiring a distinct passphrase for decryption, it is vital that the prompt be presented to the user.

ProblemType: Bug
Architecture: amd64
Date: Mon Dec 14 15:34:04 2009
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.0~-5
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-8.12-generic
SourcePackage: plymouth
Tags: lucid
Uname: Linux 2.6.32-8-generic x86_64

Related branches

Steve Langasek (vorlon) wrote :
Changed in plymouth (Ubuntu):
importance: Undecided → High
status: New → Triaged
Steve Langasek (vorlon) wrote :

There is also no change in the boot splash when calling 'plymouth message --text=string', so e.g., there is no feedback on a failed passphrase. I'm speculating that these two issues have the same root cause.

Changed in plymouth (Ubuntu Lucid):
assignee: nobody → Alberto Milone (albertomilone)
Luke (lukekuhn) wrote :

Passphrase cursor is at top left of screen, not in passphrase box when
using cryptsetup in the initramfs. Pretty passphrase box with lock logo shows but is empty.

Cryptsetup worked fine on entering password anyway. No feedback of any kind, but Cryptsetup accepted it and ran. This was with just ONE device, of course. When the correct password is entered, the "solar" theme I use with a replaced logo becomes animated, it is static until then. I will try a deliberate bad passphrase and see if i get a second try.

System:

AMD Phenom X4 with Nvidia 6600LE video card

Here's how I made it work with the Nvidia card:

Remove "--attach-to-session" and "printf '\033[?25l' > /dev/tty7" from /usr/share/initramfs/scripts/init-top/plymouth

use Jaunty version of /usr/share/initramfs/scripts/init-top/framebuffer

vga=791 on boot command line

Steve Langasek (vorlon) wrote :

Luke, the behavior you're describing is not consistent with what I've seen here; please file a separate bug report.

Luke (lukekuhn) wrote :

 You are right-that's a symptom of a separate bug, but can be mistaken for the password cursor. There is no cursor in the dialog box nor a prompt below it, so that fools the eye.

As for the no-prompt bug, I have found that the prompt works just fine if you test a splash in X, but won't display the text running from the initramfs to actually unlock a disk. You can test it, but you cannot actually use the prompt="string" option. It doesn't work in the framebuffer/forced vga graphics I am using for the splash. Does anyone know it it works through the dri graphics?

Steve Langasek (vorlon) wrote :

Tracked this down to the label.so module not being included by the initramfs hook. I've fixed this in bzr now, but the fix makes the initramfs 3MB larger due to all the support files it needs (libraries, a font, fontconfig). Scott, is the problem that led you to force-enable the framebuffer in debian/initramfs-tools/conf-hooks.d/plymouth still outstanding, and if so, can you give more info about what that problem was so we can reproduce it and get it resolved - and get meaningful boot chart data again for the kernel?

Changed in plymouth (Ubuntu Lucid):
assignee: Alberto Milone (albertomilone) → Steve Langasek (vorlon)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.0~-8

---------------
plymouth (0.8.0~-8) lucid; urgency=low

  [ Steve Langasek ]
  * Include label.so in the initramfs, as well as the font support files it
    depends on, needed for any text prompts or messages. This will bloat the
    initramfs substantially (about 3MB) and impact boot performance as a
    result, but the solution to that is to not include plymouth in the
    initramfs unless we know it's needed for prompting (e.g., cryptsetup).
    LP: #496765.
  * Move x11 renderer into a separate package, to avoid pulling GTK into the
    server install by default. LP: #509579.
  * debian/rules: fix up the dh_makeshlibs exclude path to match where we're
    currently installing.
  * src/plugins/splash/script/plugin.c: the script plugin has no support at
    all for text consoles, so if there are no pixel displays available,
    return an error so that plymouth can fall back to the text plugin.
    LP: #506717.
  * Always include the 'details' and 'text' themes in the initramfs, since
    plymouth uses these as built-in fallbacks and they're tiny.
  * src/main.c: when a splash plugin fails to load, make sure to unregister
    any related keyboard handlers.
  * don't let the password walk off the end of the dialog box. LP: #496782.
  * split the plymouth upstart job into plymouth and plymouth-splash, so that
    plymouth starts up early and doesn't have to race gdm; and stop
    unconditionally adding plymouth to the initramfs now that we can start it
    this way.
  * debian/plymouth.postinst: also set the theme on first install, or on
    upgrade from versions prior to 0.8.0~-7, because update-initramfs called
    before plymouth has been configured for the first time will accidentally
    cause a call to --reset to use the text theme instead of the intended
    default.
  * debian/plymouth.plymouth-splash.upstart: don't wait on tty-device-added,
    these are now guaranteed to be available; copied from gdm upstart job.
  * Depend on mountall (>= 2.0) to ensure we have the above guarantee.
  * Mark /usr/share/initramfs-tools/scripts/init-bottom/plymouth executable,
    otherwise initramfs-tools skips it. LP: #509487.
  * Drop the Debian revision (-1) from the version in the symbols file, to
    fix a lintian warning.
 -- Steve Langasek <email address hidden> Tue, 02 Feb 2010 08:11:47 +0000

Changed in plymouth (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers