BIOS logo reappears after the Lubuntu dots

Bug #1872669 reported by Chris Guiver on 2020-04-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lubuntu-artwork (Ubuntu)
Undecided
Unassigned
plymouth (Ubuntu)
Low
Unassigned

Bug Description

This bug was briefly mentioned in lp 1861470, Daniel van Vugt suggested raising a new bug so this is it. (sony ultrabook; vaio)

Today's daily (2020-04-13) was installed as a QA-test, on
sony vaio ultrabook (i5-9400u, 4gb, intel haswell-ULT)
and on boot I see

- encryption-key entry (text) screen (full disk encryption)
- (brief) black screen
- vaio
- plymouth (lubuntu dots)
- vaio
- sddm/greeter

On shutdown I also see the vaoi logo again before the plymouth (lubuntu dots) appears too.

To me the importance of this is extremely low; it doesn't impact operation, just a less than ideal boot sequence.

Expected behavior:

I'd like to not see the vaio (bios type) of screen during boot & shutdown as often..

(this has occurred on prior ISOs, and I booted it a few times confirming results are as I describe, at least on this crappy vaio)

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: plymouth 0.9.4git20200323-0ubuntu6
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
ApportVersion: 2.20.11-0ubuntu26
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CurrentDesktop: LXQt
Date: Tue Apr 14 18:59:06 2020
DefaultPlymouth: /usr/share/plymouth/themes/lubuntu-logo/lubuntu-logo.plymouth
InstallationDate: Installed on 2020-04-14 (0 days ago)
InstallationMedia: Lubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200413)
MachineType: Sony Corporation SVP11216CGB
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-21-generic root=UUID=7664d80f-0c4f-4823-88f8-9be223086ab8 ro quiet cryptdevice=UUID=93d36644-c42f-422a-a029-afb7c2896796:luks-93d36644-c42f-422a-a029-afb7c2896796 root=/dev/mapper/luks-93d36644-c42f-422a-a029-afb7c2896796 resume=/dev/mapper/luks-93d36644-c42f-422a-a029-afb7c2896796 splash vt.handoff=7
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-21-generic root=UUID=7664d80f-0c4f-4823-88f8-9be223086ab8 ro quiet cryptdevice=UUID=93d36644-c42f-422a-a029-afb7c2896796:luks-93d36644-c42f-422a-a029-afb7c2896796 root=/dev/mapper/luks-93d36644-c42f-422a-a029-afb7c2896796 resume=/dev/mapper/luks-93d36644-c42f-422a-a029-afb7c2896796 splash vt.handoff=7
SourcePackage: plymouth
TextPlymouth: /usr/share/plymouth/themes/lubuntu-text/lubuntu-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/17/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0270V7
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0270V7:bd05/17/2013:svnSonyCorporation:pnSVP11216CGB:pvrC60BZAQW:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.family: VAIO
dmi.product.name: SVP11216CGB
dmi.product.sku: 54585979
dmi.product.version: C60BZAQW
dmi.sys.vendor: Sony Corporation

Chris Guiver (guiverc) wrote :
Chris Guiver (guiverc) on 2020-04-14
description: updated
Changed in plymouth (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Chris Guiver (guiverc) on 2020-04-14
description: updated
Daniel van Vugt (vanvugt) wrote :

We could probably agree to half of this - to not show the BIOS logo on shutdown. But the other half of not wanting to see it on boot-up is not something we are willing to change right now.

So "Won't Fix". Unless you want to change this bug to only cover the shutdown case...

Changed in plymouth (Ubuntu):
status: Triaged → Won't Fix
Chris Guiver (guiverc) on 2020-04-14
description: updated
Daniel van Vugt (vanvugt) wrote :

Oops. Too many issues are being discussed in one bug report :(

I do however see a real bug here:

- vaio
- plymouth (lubuntu dots)
- vaio

so let's focus on that. It sounds like a regression of bug 1861470 specific to Lubuntu.

summary: - lubuntu 20.04 brand appears after key & between plymouth & greeter
+ Don't use the bgrt splash screen
summary: - Don't use the bgrt splash screen
+ lubuntu 20.04 brand appears after key & between plymouth & greeter
summary: - lubuntu 20.04 brand appears after key & between plymouth & greeter
+ BIOS logo reappears after the Lubuntu dots
Changed in plymouth (Ubuntu):
status: Won't Fix → New
importance: Wishlist → Undecided
Daniel van Vugt (vanvugt) wrote :

This is probably also not a Plymouth bug, but a bug in whatever Lubuntu uses to customize plymouth.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1872669

tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

Could you maybe do a video showing the issue? Also could you boot using 'plymouth:debug' as a kernel parameter option and add the /var/log/plymouth to the report?

Changed in plymouth (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Chris Guiver (guiverc) wrote :

video uploading to gdrive..

Chris Guiver (guiverc) wrote :

https://photos.app.goo.gl/HCSAGksjpPchecVf9

It's very shaky sorry; it was started after entry of my key so screen had gone back.. boot process is shown from that point until sddm/greeter.

I paused video (didn't show login.. etc), and ~24secs in I'm starting to shutdown crapbook. The point to this bit was the VAIO appearing before the lubuntu dots..

Changed in plymouth (Ubuntu):
status: Incomplete → New
Daniel van Vugt (vanvugt) wrote :

Yeah looks like the same issue as bug 1861470. As I understand it, the kernel and grub (?) were modified to support the Ubuntu default spinner theme. So that will now break other flavours like Lubuntu still using the old theme. Those flavours should probably just be changed to use the same plymouth theme as regular Ubuntu.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
apt-ghetto (apt-ghetto) on 2020-04-19
Changed in lubuntu-artwork (Ubuntu):
status: New → Confirmed
Chris Guiver (guiverc) wrote :

Lubuntu 20.04 QA-test install using 2020-04-23 ISO
sony vaio ultrabook (i5-9400u, 4gb, intel haswell-ULT)

On initial boot I logged out where I normally reboot/shutdown, and I'm getting the VAIO logo after logout and before `sddm` re-appears.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers