Cannot complete installation in Ubuntu 17.10

Bug #1725525 reported by Larika on 2017-10-20
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
openvpn (Ubuntu)
Undecided
Unassigned
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Fresh Ubuntu 17.10 install .

Installation stuck in :

Configurazione di openvpn (2.4.3-4ubuntu1)...

Avanzamento: [ 81%] [#############################################..........]

and it never end.

Larika (matteo-tanca) wrote :

Today I installed it in a few seconds.

I didn't had connection problems, I installed a lot of packages but openvpn.

However I'm happy that is working fine now.

Changed in openvpn (Ubuntu):
status: New → Invalid
David Eaves (n-dave-e) on 2017-10-25
Changed in openvpn (Ubuntu):
status: Invalid → Confirmed
David Eaves (n-dave-e) wrote :

I am also encountering a stuck openvpn install on a fairly fresh Ubuntu 17.10 install. I have not been able to install.

Installation shows:

$ sudo apt install openvpn
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  resolvconf easy-rsa
The following NEW packages will be installed:
  openvpn
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
Need to get 469 kB of archives.
After this operation, 1,126 kB of additional disk space will be used.
Get:1 http://nz.archive.ubuntu.com/ubuntu artful/main amd64 openvpn amd64 2.4.3-4ubuntu1 [469 kB]
Fetched 469 kB in 1s (421 kB/s)
Preconfiguring packages ...
Selecting previously unselected package openvpn.
(Reading database ... 127063 files and directories currently installed.)
Preparing to unpack .../openvpn_2.4.3-4ubuntu1_amd64.deb ...
Unpacking openvpn (2.4.3-4ubuntu1) ...
Processing triggers for ureadahead (0.100.0-20) ...
Setting up openvpn (2.4.3-4ubuntu1) ...

Progress: [ 66%]

The following openvpn related processes are present:

$ ps aux | grep openvpn
root 6183 0.0 0.0 68244 1520 pts/1 S+ 16:25 0:00 sudo apt install openvpn
root 6184 0.4 0.2 126168 23956 pts/1 S+ 16:25 0:01 apt install openvpn
root 6229 0.0 0.1 71204 14412 pts/2 S+ 16:25 0:00 /usr/bin/perl -w /usr/share/debconf/frontend /var/lib/dpkg/info/openvpn.postinst configure
root 6236 0.0 0.0 4608 128 pts/2 S+ 16:25 0:00 /bin/sh /var/lib/dpkg/info/openvpn.postinst configure
root 6242 0.0 0.0 4608 936 pts/2 S+ 16:25 0:00 /bin/sh /usr/sbin/invoke-rc.d openvpn cond-restart
root 6264 0.0 0.0 4608 980 pts/2 S+ 16:25 0:00 /bin/sh -e /etc/init.d/openvpn cond-restart
xxxx 6368 0.0 0.0 21452 892 pts/4 S+ 16:29 0:00 grep --color=auto openvpn

Mark McCoy (s3ction9) wrote :

I am also having this issue on a fresh 17.10 install.

These processes seem to be stalled

$ ps aux | grep openvpn
root 23463 0.0 0.0 71444 18748 pts/1 S+ 08:18 0:00 /usr/bin/perl -w /usr/share/debconf/frontend /var/lib/dpkg/info/openvpn.postinst configure
root 23470 0.0 0.0 4608 948 pts/1 S+ 08:18 0:00 /bin/sh /var/lib/dpkg/info/openvpn.postinst configure
root 23476 0.0 0.0 4608 1744 pts/1 S+ 08:18 0:00 /bin/sh /usr/sbin/invoke-rc.d openvpn cond-restart
root 23498 0.0 0.0 4608 1840 pts/1 S+ 08:18 0:00 /bin/sh -e /etc/init.d/openvpn cond-restart

René M. Castillo (renkastle) wrote :

Im also having the same issue,

$ ps aux | grep openvpn
root 3110 0.0 0.2 71256 18528 pts/1 S+ 10:32 0:00 /usr/bin/perl -w /usr/share/debconf/frontend /var/lib/dpkg/info/openvpn.postinst configure
root 3117 0.0 0.0 4608 752 pts/1 S+ 10:32 0:00 /bin/sh /var/lib/dpkg/info/openvpn.postinst configure
root 3123 0.0 0.0 4608 1788 pts/1 S+ 10:32 0:00 /bin/sh /usr/sbin/invoke-rc.d openvpn cond-restart
root 3145 0.0 0.0 4608 1892 pts/1 S+ 10:32 0:00 /bin/sh -e /etc/init.d/openvpn cond-restart
renkast+ 3213 0.0 0.0 21452 1136 pts/2 S+ 10:34 0:00 grep --color=auto openvpn

René M. Castillo (renkastle) wrote :

By the way, i had to run apt-get purge openvpn in order to install new software, because interrupting openvpn causes issues when you need to install another package.

Roeland Ottens (roelandottens) wrote :

I'm unable to purge openvpn and 'dpkg --reconfigure -a' hangs indefinitely on "setting up openvpn" as well, so my package manager seems stuck for now.

Joshua Powers (powersj) wrote :

Thank you for taking the time to file a bug report.

Are these only on fresh installs or did anyone do an upgrade from zesty?
I was unable to reproduce in a container so I am wondering if some other
package is conflicting or some networking configuration is required. Can
someone try to reproduce and gather an strace as well?

Since there is not enough information in your report to begin triage or to
differentiate between a local configuration problem and a bug in Ubuntu, I
am marking this bug as "Incomplete". We would be grateful if you would:
provide a more complete description of the problem, explain why you
believe this is a bug in Ubuntu rather than a problem specific to your
system, and then change the bug status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in openvpn (Ubuntu):
status: Confirmed → Incomplete
Wesley (tuzzmaniandevil) wrote :

I upgraded from 17.04 and installed OpenVPN just fine. But then I did a clean install and now I'm getting the same bug.

francesc (francesc-guillen) wrote :

The same happens to me after an almost "fresh" 17.10 (I have installed a few packages before installing openvpn).

After cancelling the apt-get install (killing the terminal) and cancelling a
sudo dpkg --configure -a
Processing triggers for ureadahead (0.100.0-20) ...
Setting up openvpn (2.4.3-4ubuntu1) ...
^Cdpkg: error processing package openvpn (--configure):
 subprocess installed post-installation script was interrupted
Processing triggers for systemd (234-2ubuntu12.1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:

openvpn seems to work fine (at least for what I need it).

Andreas Hasenack (ahasenack) wrote :

I'm also unable to reproduce this on a fresh artful lxd container. We need to find out what's different in that environment from yours.

The next person who reproduces this problem, could you please attach a full "ps fauxw" output to this bug? Not filtering by the "openvpn" string via grep, please.

Andreas Hasenack (ahasenack) wrote :

I also tried an artful VM, with and without network (installed from the cached download deb in the latter case).

CSE (cservieres) wrote :

Hi, same problem here with the command : sudo apt install openvpn
Stuck at 66% on with /etc/init.d/openvpn cond-restart in process list like the other comments.

But if i first install network-manager-openvpn-gnome and let apt install the dependencies (libnm-glib-vpn1 network-manager-openvpn openvpn) all is fine.

so you can just do : sudo apt install network-manager-openvpn-gnome
to work arround the problem on fresh install.

Joshua Powers (powersj) wrote :

As Andreas requested above, could you please attach the result of the following command if you come across this:

$ ps fauxw

It would help us to understand what is stuck.

Changed in openvpn (Ubuntu):
status: Incomplete → Confirmed
Samuel Iglesias (samuelig) wrote :

It is 'plymouth --sync' the command that is stuck. Once I killed it, the installation finished.

Samuel Iglesias (samuelig) wrote :

Sorry, 'plymouth --ping'.

Joshua Powers (powersj) wrote :

Thanks for catching that! Looking at bug 1705345 it looks like others have hit this similar condition in other cases.

If you run 'plymouth --ping' by itself does it also hang? if so can you grab a strace of that command's output?

Reassigning to plymouth

Other similar bugs: LP: #1606472, LP: #1707197, LP: #1722745, LP: #1723451

Changed in plymouth (Ubuntu):
status: New → Confirmed
Louis Dartez (louis-dartez) wrote :

Has there been any activity on this bug? For a heavy openvpn user this really sucks.

Louis Dartez (louis-dartez) wrote :

Adding on to comment #12, #14, and #15:

I installed network-manager-openvpn-gnome and the installation got stuck again on `plymouth --ping`. I had to kill this with -9 (twice!, it restarts itself once it seems) to get the installation to move on. Apt cried that dpkg did not finished all the tasks it was supposed to but I am able to use openvpn anyway.

Mate LABADI (labadimate-d) wrote :

I had the same issue with installing OpenVPN and it hangs at openvpn.postinst.
My 17.10 was a fresh install in October, not upgraded from 17.04.

'plymouth --ping' seems to be the root of the problem. I had to 'kill -9' three (!) times.

Since it was asked above, I attach the result of 'ps fauxw'.

Jörg Frings-Fürst (jff-de) wrote :

Please remove Debian PTS from bug subscribers

RajW (rajaw) wrote :

Fresh install of Ubuntu 17.10. Same issue.

After this operation, 1,269 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu artful/main amd64 snapd amd64 2.28.5+17.10 [9,707 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu artful/main amd64 libpkcs11-helper1 amd64 1.22-2 [44.2 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu artful/main amd64 openvpn amd64 2.4.3-4ubuntu1 [469 kB]
Fetched 10.2 MB in 0s (17.5 MB/s)
Preconfiguring packages ...
Selecting previously unselected package libpkcs11-helper1:amd64.
(Reading database ... 162072 files and directories currently installed.)
Preparing to unpack .../libpkcs11-helper1_1.22-2_amd64.deb ...
Unpacking libpkcs11-helper1:amd64 (1.22-2) ...
Selecting previously unselected package openvpn.
Preparing to unpack .../openvpn_2.4.3-4ubuntu1_amd64.deb ...
Unpacking openvpn (2.4.3-4ubuntu1) ...
Processing triggers for ureadahead (0.100.0-20) ...
Setting up libpkcs11-helper1:amd64 (1.22-2) ...
Setting up openvpn (2.4.3-4ubuntu1) ...

Progress: [ 81%] [################################################################################..................]

Sketch (sorcher) wrote :

can someone please explain noobies how did you fix it?
I tried to kill plymouth but there is no such process running.
I'v encountered this bug on an upgrade from 17.04 as well as on a fresh 17.10.
now it's stuck and i know how to get out of it but i still need the openvpn package.

thanks to all in advance!

David Dattée (david-dattee) wrote :

Hi,

same here, same bug.
Any solution found or proposed ?

Thanks

Vladislav (vnikitov) wrote :

Hi,

I've also encountered this bug. It is happening on newly installed system.

Changed in openvpn (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
easydiez (easydiez) wrote :

This is hanging for me as well. I had to repetitively kill the "plymouth --ping" command to get it to successfully complete. Upon running the "plymouth --ping" independently, I also found that it hung. This was on 17.10 artful.

Andreas Hasenack (ahasenack) wrote :

Looks like this was addressed in #1705345. Could you guys please make sure you are running an updated system before installing openvpn? A reboot may be needed after the update perhaps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers