During d-i install of ubuntu-server from mini.iso I get no login prompt

Bug #1675453 reported by Dave Morley on 2017-03-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Łukasz Zemczak
Artful
Undecided
Łukasz Zemczak
grub2-signed (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned
plymouth (Ubuntu)
High
Łukasz Zemczak
Artful
High
Łukasz Zemczak

Bug Description

STEPS:
1. Grab the mini.iso from http://archive.ubuntu.com/ubuntu/dists/zesty/main/installer-amd64/current/images/netboot/mini.iso
2. Boot it
3. Run the installer and from the tasksel list select ubuntu basic server and openssh server in addition to the default selected base
4. Complete the install remove the media and reboot

EXPECTED:
I expect to see a login prompt

ACTUAL:
I get a blank screen with a cursor top left. SSH logins work as expected

WORKAROUND:
Flip to an alternate TTY and you get the login prompt.

Dave Morley (davmor2) wrote :

Look like mini.iso/netboot will use plymouth in text mode where the server.iso does not. So I think that plymouth is not being taken down and therefore utilising tty1 which is why we see no login adding plymouth to the bug.

affects: debian-installer (Ubuntu) → plymouth (Ubuntu)
Joshua Powers (powersj) on 2017-03-23
Changed in plymouth (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: rls-z-incoming
tags: added: zesty
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1675453

tags: added: iso-testing

In a fresh install, it hangs for five minutes, while it waits for the network interfaces to go up. After login prompt, if you try to restart networking, it complains about policykit-1 not found. Does this happen to you? If so, it is related to bug #1682201

tags: added: rls-aa-incoming
removed: rls-z-incoming
Changed in plymouth (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
tags: removed: rls-aa-incoming
tags: added: id-597a832cfc4199380b98faa4
Changed in plymouth (Ubuntu):
assignee: Adam Conrad (adconrad) → Łukasz Zemczak (sil2100)
Changed in plymouth (Ubuntu Artful):
assignee: Adam Conrad (adconrad) → Łukasz Zemczak (sil2100)
Changed in plymouth (Ubuntu):
status: Confirmed → In Progress
Changed in plymouth (Ubuntu Artful):
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :

The reason for this happening is that apparently this ubuntu-server image is booting with vt.handoff=7 while in systemd's logind we're only using the default number of configured tty's (i.e. 6). So plymouth is running, doing it's thing and then switches to tty7 which is not enabled. This can be confirmed by either increasing logind's number of tty's or by enforcing vt.handoff=1.

Need to look into how we had this configured in earlier versions. I'd opt for restoring vt.handoff=1 in this case.

Łukasz Zemczak (sil2100) wrote :

I see that by default our ubuntu-server images boot without "quiet splash", maybe this is what we'd prefer in case of the mini.iso ubuntu-server image as well?

On Fri, Nov 17, 2017 at 09:20:09AM -0000, Łukasz Zemczak wrote:
> The reason for this happening is that apparently this ubuntu-server
> image is booting with vt.handoff=7 while in systemd's logind we're only
> using the default number of configured tty's (i.e. 6). So plymouth is
> running, doing it's thing and then switches to tty7 which is not
> enabled. This can be confirmed by either increasing logind's number of
> tty's or by enforcing vt.handoff=1.

> Need to look into how we had this configured in earlier versions. I'd
> opt for restoring vt.handoff=1 in this case.

We should discontinue use of vt.handoff in 18.04; this has been agreed
elsewhere.

'vt.handoff=1' is pointless - VT1 is the default VT. The option should just
be dropped.

Łukasz Zemczak (sil2100) wrote :

What I'll do is remove the vt.handoff patch from grub2 and switch plymouth to use vt1 as well (if xnox doesn't beat me to the latter).

Changed in grub2 (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in grub2 (Ubuntu Artful):
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in grub2 (Ubuntu):
status: New → In Progress
Changed in grub2 (Ubuntu Artful):
status: New → In Progress
Łukasz Zemczak (sil2100) wrote :

So plymouth is by default using tty1 already, but there seem to be some other problems here. Looks like with the 'quiet splash' option, when plymouth is running there still seems to be some output printed out to the screen on top of the splash-screen (from the looks of it it's systemd output + a few single kernel messages on the kvm). This looks terrible. The old FRAMEBUFFER=y initramfs trick works partially, but the few single kernel messages are still being printed. By 'quiet' I would expect completely silent boot. When running with just 'quiet' without plymouth, I actually only see the kernel messages (which is still something I wouldn't expect seeing).

I suppose this would have to be fixed first.

Łukasz Zemczak (sil2100) wrote :

I'm learning all those bits slowly piece by piece here...

@Steve: it actually seems that "vt.handoff=1" is not equal to no-vt.handoff. I would have to look into the vt.handoff kernel patches, but without vt.handoff tty1 is indeed used by default for handoff and everything, but the difference is that vt.handoff also turns the terminal to a 'transparent' type until first switch in and out from that terminal. What this means practically is that when "quiet splash vt.handoff=1" is given, there is no output printed onto the screen and all plymouth transitions are fluid (and the aubergine BG is present from the start). Quoting Colin from askubuntu:

"vt.handoff=7 then causes the kernel to maintain the current contents of video memory on virtual terminal 7, which is a new "transparent" VT type. The first time that the kernel is told to switch away from VT 7, either from Plymouth or manually (Alt-F1, etc.), these contents are lost and VT 7 reverts to text mode."

Łukasz Zemczak (sil2100) wrote :

Ok, so it seems a few of my previous tests were a bit flawed. It looks like vt.handoff=1 does the trick completely for this particular bug. So once we switch grub2 to vt.handoff=1 this bug here will be fixed. Another thing that needs to be still considered is somehow tweaking netboot installs to have 'splash quiet' removed - but that's a separate story.

Changed in plymouth (Ubuntu):
status: In Progress → Invalid
Changed in plymouth (Ubuntu Artful):
status: In Progress → Invalid
Steve Langasek (vorlon) wrote :

On Thu, Jan 18, 2018 at 04:56:33PM -0000, Łukasz Zemczak wrote:
> Ok, so it seems a few of my previous tests were a bit flawed. It looks
> like vt.handoff=1 does the trick completely for this particular bug. So
> once we switch grub2 to vt.handoff=1 this bug here will be fixed.
> Another thing that needs to be still considered is somehow tweaking
> netboot installs to have 'splash quiet' removed - but that's a separate
> story.

My main concern with this is that AIUI the vt.handoff is a non-upstreamed
patchset in Ubuntu, which has seen some bit rot in the past. We should
probably be looking at how to do this without the vt.handoff patches.

Łukasz Zemczak (sil2100) wrote :

I agree that's something worth considering, but I'd say it's a separate story. The vt.handoff patches are not only needed for the d-i netboot install of server case, but in overall for the splash boot experience being smooth. Without vt.handoff all desktops will regress in how the splash screen looks like, with a black screen flashing before plymouth starts, text messages (even with quiet) appearing on screen.

So I'd opt for filling in a separate bug for the vt.handoff deprecation and move any discussion there. Or maybe there is a bug already where this has been discussed? Since I heard that vt.handoff removal already had some discussion, so I'd certainly like to see what was planned.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2-signed - 1.89

---------------
grub2-signed (1.89) bionic; urgency=medium

  * Rebuild against grub2 2.02-2ubuntu3. (LP: #1675453)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Mon, 22 Jan 2018 09:40:19 +0100

Changed in grub2-signed (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02-2ubuntu4

---------------
grub2 (2.02-2ubuntu4) bionic; urgency=medium

  * debian/patches/vt_handoff.patch: modify the existing patch to set
    vt.handoff=1 instead of vt.handoff=7 as we now start display managers on
    vt1 anyway. This also fixes issues with netboot installed server systems
    not displaying the login prompt on boot. (LP: #1675453)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 18 Jan 2018 18:32:31 +0100

Changed in grub2 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers