Failed 15.10 -> 16.04 upgrade

Bug #1548254 reported by Michael Vogt on 2016-02-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Plymouth
New
Undecided
Unassigned
plymouth (Ubuntu)
Undecided
Didier Roche

Bug Description

When doing a 15.10 -> 16.04 I ran into the following bug:
"""
[..]
Setting up linux-image-4.4.0-6-generic (4.4.0-6.21) ...^M
Running depmod.^M
update-initramfs: deferring update (hook will be called later)^M
Examining /etc/kernel/postinst.d.^M
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-6-generic /boot/vmlinuz-4.4.0-6-generic^M
N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension^M
N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension^M
N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension^M
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-6-generic /boot/vmlinuz-4.4.0-6-generic^M
update-initramfs: Generating /boot/initrd.img-4.4.0-6-generic^M
sed: can't read /usr/share/plymouth/themes/ubuntu-text/ubuntu-text.plymouth: No such file or directory^M
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 2.^M
update-initramfs: failed for /boot/initrd.img-4.4.0-6-generic with 2.^M
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2^M
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.4.0-6-generic.postinst line 1027.^M
dpkg: error processing package linux-image-4.4.0-6-generic (--configure):^M
 subprocess installed post-installation script returned error exit status 2^M
[..]
"""
and indeed, in plymouth-theme-ubuntu-text/xenial,now there is no /usr/share/plymouth/themes/ubuntu-text/ubuntu-text.plymouth on a /usr/share/plymouth/themes/ubuntu-text/ubuntu-text.plymouth*.in*

Steve Langasek (vorlon) on 2016-02-23
Changed in plymouth (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.9.2-3ubuntu11

---------------
plymouth (0.9.2-3ubuntu11) xenial; urgency=medium

  * debian/local/plymouth.hook:
    - Fix kernel updates on some weird configurations where there is
      a plymouth theme alternative setup pointing to a non existing theme.
      (LP: #1532355, #1548254)

 -- Didier Roche <email address hidden> Wed, 16 Mar 2016 15:25:50 +0100

Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
Peter Joseph (peterjoseph100) wrote :

I had a plethora of plymouth package status issues on 15.10 16.04 upgrade. Plymouth was not set to install so other things that depended on it failed. I had to mark plymouth for installation and dpkg-reconfigure -a a few times.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers