package linux-image-4.3.0-5-generic 4.3.0-5.16 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2

Bug #1532355 reported by Metlinx on 2016-01-08
284
This bug affects 70 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Didier Roche
Xenial
High
Didier Roche

Bug Description

hung during the boot time , after many retries.. it came back to the login prompt

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: linux-image-4.3.0-5-generic 4.3.0-5.16
ProcVersionSignature: Ubuntu 4.3.0-5.16-generic 4.3.3
Uname: Linux 4.3.0-5-generic i686
ApportVersion: 2.19.3-0ubuntu2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sysadmin 2731 F.... pulseaudio
 /dev/snd/controlC1: sysadmin 2731 F.... pulseaudio
Date: Thu Jan 7 23:24:23 2016
ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2
HibernationDevice: RESUME=UUID=0aaeb789-574f-4293-b953-3f84f02fe743
InstallationDate: Installed on 2015-08-22 (139 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release i386 (20150422)
Lsusb:
 Bus 003 Device 031: ID 04f3:0111 Elan Microelectronics Corp.
 Bus 003 Device 002: ID 8087:8000 Intel Corp.
 Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Latitude E7440
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.3.0-5-generic root=UUID=d3dfa265-52b0-4d9e-88c9-211a0272d159 ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 2.02~beta2-32ubuntu1
SourcePackage: initramfs-tools
Title: package linux-image-4.3.0-5-generic 4.3.0-5.16 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: Upgraded to xenial on 2016-01-08 (0 days ago)
dmi.bios.date: 05/01/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.asset.tag: 562268
dmi.board.name: 085VV3
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.asset.tag: 562268
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd05/01/2014:svnDellInc.:pnLatitudeE7440:pvr01:rvnDellInc.:rn085VV3:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E7440
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Metlinx (rajrueben) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

From the DuplicateSignature:

run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.3.0-5-generic /boot/vmlinuz-4.3.0-5-generic
update-initramfs: Generating /boot/initrd.img-4.3.0-5-generic
sed: can't read /usr/share/plymouth/themes/ubuntu-text/ubuntu-text.plymouth: No such file or directory
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 2.
update-initramfs: failed for /boot/initrd.img-4.3.0-5-generic with 2.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.3.0-5-generic.postinst line 1025.

Changed in initramfs-tools (Ubuntu):
importance: Undecided → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1532355

tags: added: iso-testing
Changed in initramfs-tools (Ubuntu Xenial):
status: Confirmed → Triaged
Phill Whiteside (phillw) wrote :

Regarding UpgradeStatus: Upgraded to xenial on 2016-01-08 (0 days ago)

The kernel team have decided that we have the linux LTS kernel 4.4 in our own 16.04 LTS. This makes perfect sense, my suggestion is to pull in the 'unstable' ppa from the kernel team and install the 4.4 kernel. (do not forget to un-install that ppa, else the kernel team will send you all sorts of "not tested" kernels :D )

Brian Murray (brian-murray) wrote :

I've recreated this by upgrading a fully up to date stock Wily system to Xenial.

Andy Whitcroft (apw) wrote :

This looks like a failure in the plymouth hook:

  run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.3.0-5-generic /boot/vmlinuz-4.3.0-5-generic
  update-initramfs: Generating /boot/initrd.img-4.3.0-5-generic
  sed: can't read /usr/share/plymouth/themes/ubuntu-text/ubuntu-text.plymouth: No such file or directory
  E: /usr/share/initramfs-tools/hooks/plymouth failed with return 2.
  update-initramfs: failed for /boot/initrd.img-4.3.0-5-generic with 2.
  run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2
  Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.3.0-5-generic.postinst line 1025.

affects: initramfs-tools (Ubuntu Xenial) → plymouth (Ubuntu Xenial)
Download full text (3.9 KiB)

I think the issue disappeared after a recent updating, with the latest
kernel is 4.4.x.

Jing Zhang
On 4/02/2016 8:16 AM, "Andy Whitcroft" <email address hidden> wrote:

> This looks like a failure in the plymouth hook:
>
> run-parts: executing /etc/kernel/postinst.d/initramfs-tools
> 4.3.0-5-generic /boot/vmlinuz-4.3.0-5-generic
> update-initramfs: Generating /boot/initrd.img-4.3.0-5-generic
> sed: can't read
> /usr/share/plymouth/themes/ubuntu-text/ubuntu-text.plymouth: No such file
> or directory
> E: /usr/share/initramfs-tools/hooks/plymouth failed with return 2.
> update-initramfs: failed for /boot/initrd.img-4.3.0-5-generic with 2.
> run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return
> code 2
> Failed to process /etc/kernel/postinst.d at
> /var/lib/dpkg/info/linux-image-4.3.0-5-generic.postinst line 1025.
>
> ** Package changed: initramfs-tools (Ubuntu Xenial) => plymouth (Ubuntu
> Xenial)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1531331).
> https://bugs.launchpad.net/bugs/1532355
>
> Title:
> package linux-image-4.3.0-5-generic 4.3.0-5.16 failed to
> install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools
> exited with return code 2
>
> Status in plymouth package in Ubuntu:
> Triaged
> Status in plymouth source package in Xenial:
> Triaged
>
> Bug description:
> hung during the boot time , after many retries.. it came back to the
> login prompt
>
> ProblemType: Package
> DistroRelease: Ubuntu 16.04
> Package: linux-image-4.3.0-5-generic 4.3.0-5.16
> ProcVersionSignature: Ubuntu 4.3.0-5.16-generic 4.3.3
> Uname: Linux 4.3.0-5-generic i686
> ApportVersion: 2.19.3-0ubuntu2
> Architecture: i386
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: sysadmin 2731 F.... pulseaudio
> /dev/snd/controlC1: sysadmin 2731 F.... pulseaudio
> Date: Thu Jan 7 23:24:23 2016
> ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited
> with return code 2
> HibernationDevice: RESUME=UUID=0aaeb789-574f-4293-b953-3f84f02fe743
> InstallationDate: Installed on 2015-08-22 (139 days ago)
> InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release i386 (20150422)
> Lsusb:
> Bus 003 Device 031: ID 04f3:0111 Elan Microelectronics Corp.
> Bus 003 Device 002: ID 8087:8000 Intel Corp.
> Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: Dell Inc. Latitude E7440
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.3.0-5-generic
> root=UUID=d3dfa265-52b0-4d9e-88c9-211a0272d159 ro quiet splash vt.handoff=7
> PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No
> PulseAudio daemon running, or not running as session daemon.
> RelatedPackageVersions: grub-pc 2.02~beta2-32ubuntu1
> SourcePackage: initramfs-tools
> Title: package linux-image-4.3.0-5-generic 4.3.0-5.16 failed to
> install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited
> with return c...

Read more...

Brian Murray (brian-murray) wrote :

No, this is still an issue and needs fixing.

Changed in plymouth (Ubuntu Xenial):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

I'm unfortunately not working in the distro anymore and can't get time to analyze this. Please check with the foundation team.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.9.2-3ubuntu11

---------------
plymouth (0.9.2-3ubuntu11) xenial; urgency=medium

  * debian/local/plymouth.hook:
    - Fix kernel updates on some weird configurations where there is
      a plymouth theme alternative setup pointing to a non existing theme.
      (LP: #1532355, #1548254)

 -- Didier Roche <email address hidden> Wed, 16 Mar 2016 15:25:50 +0100

Changed in plymouth (Ubuntu Xenial):
status: Triaged → Fix Released
To post a comment you must log in.