plymouthd crashed with SIGSEGV in ply_renderer_get_buffer_for_head()

Bug #1377378 reported by Alan on 2014-10-04
372
This bug affects 76 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Medium
abhilash

Bug Description

Crash when start.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: plymouth 0.9.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.16.0-20.27-generic 3.16.3
Uname: Linux 3.16.0-20-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.14.7-0ubuntu3
Architecture: i386
BootLog:
 Loading the saved-state of the serial devices...
  * Setting up X socket directories... 
[ OK ]
  * Starting automatic crash report generation: apport 
[ OK ]
Date: Sat Oct 4 05:02:47 2014
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationDate: Installed on 2014-05-03 (154 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
MachineType: Acer Aspire 5734Z
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-20-generic root=UUID=93da5e1e-271e-424a-9e7e-185097bd72e4 ro quiet splash vt.handoff=7
ProcCmdline: @sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-20-generic root=UUID=93da5e1e-271e-424a-9e7e-185097bd72e4 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0xb77837cb <ply_renderer_get_buffer_for_head+27>: mov 0x8(%eax),%ecx
 PC (0xb77837cb) ok
 source "0x8(%eax)" (0x00000010) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: plymouth
StacktraceTop:
 ply_renderer_get_buffer_for_head () from /lib/i386-linux-gnu/libply-splash-core.so.4
 ply_pixel_display_draw_area () from /lib/i386-linux-gnu/libply-splash-core.so.4
 script_lib_sprite_refresh () from /lib/i386-linux-gnu/plymouth/script.so
 ?? () from /lib/i386-linux-gnu/plymouth/script.so
 ply_event_loop_process_pending_events () from /lib/i386-linux-gnu/libply.so.4
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd crashed with SIGSEGV in ply_renderer_get_buffer_for_head()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 04/25/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 5734Z
dmi.board.vendor: Acer
dmi.board.version: V1.06
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.06
dmi.modalias: dmi:bvnAcer:bvrV1.06:bd04/25/2011:svnAcer:pnAspire5734Z:pvrV1.06:rvnAcer:rnAspire5734Z:rvrV1.06:cvnAcer:ct10:cvrV1.06:
dmi.product.name: Aspire 5734Z
dmi.product.version: V1.06
dmi.sys.vendor: Acer

Alan (alanjas) wrote :

StacktraceTop:
 ply_renderer_get_buffer_for_head (renderer=0x8, head=0x9c69370) at ply-renderer.c:328
 ply_pixel_display_draw_area (display=0x9c4e7c0, x=459, y=398, width=21, height=21) at ply-pixel-display.c:144
 draw_area (data=<optimized out>, height=<optimized out>, width=<optimized out>, y=<optimized out>, x=<optimized out>) at ./script-lib-sprite.c:537
 script_lib_sprite_refresh (data=0x9c4b918) at ./script-lib-sprite.c:837
 on_timeout (plugin=0x9c53578) at ./plugin.c:236

Changed in plymouth (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
information type: Private → Public
Andy Whitcroft (apw) wrote :

@Alan is this reproducible ie. does it happen often, or is it a one off?

Alan (alanjas) wrote :

No. Only happens sometimes after login.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
tags: added: vivid
Moahadeb (cwesbrooks) wrote :

lsb_release -rd;apt-cache policy nautilus plymouth
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04
nautilus:
  Installed: 1:3.14.2-0ubuntu4
  Candidate: 1:3.14.2-0ubuntu4
  Version table:
 *** 1:3.14.2-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
        100 /var/lib/dpkg/status
plymouth:
  Installed: 0.9.0-0ubuntu9
  Candidate: 0.9.0-0ubuntu9
  Version table:
 *** 0.9.0-0ubuntu9 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
        100 /var/lib/dpkg/status

Majord51 (majord51) wrote :

This error occured in 15.04 Ubuntu beta immediately after a reboot required by a software update.

Changed in plymouth (Ubuntu):
assignee: nobody → Remo Ritzmann (remo-ritzmann)
assignee: Remo Ritzmann (remo-ritzmann) → nobody
Changed in plymouth (Ubuntu):
assignee: nobody → abhilash (abhilashdesai123)
To post a comment you must log in.