cloud image boot produces unnecessary output

Bug #1303815 reported by Scott Moser on 2014-04-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Dimitri John Ledkov
Trusty
High
Dimitri John Ledkov

Bug Description

[Impact]

 * plymouth-upstart-bridge sends "upstart job name" as a status update to plymouthd. Previously details plugin didn't do anything with those, but to resolve bug #540645 it started to print them verbatim to the console. However "upstart job name" verbantim message is pointless, given that it was preceeded by a user friendly
"* Starting jobname [ OK ]"

[Test Case]

 * Boot without "splash" option set, or press ESC during boot. You should see a beautiful bootlog not littered with upstart job names on newlines without any other text on the line.

[Other Info]

 * Original bug report:

This is a regression in the most recent upload of plymouth (that fixed bug 1160079)
We're now seeing annoyingly verbose output like this:

Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... done.
[ 4.113876] random: init urandom read with 70 bits of entropy available
 * Starting Mount filesystems on boot^[[74G[ OK ]
mountall
 * Starting Populate /dev filesystem^[[74G[ OK ]
 * Starting Populate and link to /run filesystem^[[74G[ OK ]
 * Stopping Populate and link to /run filesystem^[[74G[ OK ]
mounted-dev
mounted-run
 * Stopping Populate /dev filesystem^[[74G[ OK ]
startpar-bridge
mounted-run
 * Stopping Track if upstart is running in a container^[[74G[ OK ]
startpar-bridge
mounted-dev
startpar-bridge
container-detect
startpar-bridge

It seems like there is even duplicate data going there, as you can see the multiple 'mounted-dev' output.
I'm attaching a full log also.

Related bugs:
 * bug 682831: lost console output early in boot
 * bug 1160079: plymouth aborts in cloud images

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: plymouth 0.8.8-0ubuntu16
ProcVersionSignature: User Name 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CurrentDmesg: [ 18.108817] init: plymouth-upstart-bridge main process (194) killed by TERM signal
Date: Mon Apr 7 13:36:16 2014
DefaultPlymouth: Error: command ['readlink', '/etc/alternatives/default.plymouth'] failed with exit code 1:
Ec2AMI: ami-61b3a108
Ec2AMIManifest: ubuntu-us-east-1/images-testing/ubuntu-trusty-daily-amd64-server-20140407.manifest.xml
Ec2AvailabilityZone: us-east-1e
Ec2InstanceType: m3.medium
Ec2Kernel: aki-919dcaf8
Ec2Ramdisk: unavailable
Lspci:

Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize libusb: -99
ProcCmdLine: root=LABEL=cloudimg-rootfs ro console=hvc0
ProcEnviron:
 TERM=screen-bce
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: root=LABEL=cloudimg-rootfs ro console=hvc0
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Scott Moser (smoser) wrote :
Scott Moser (smoser) on 2014-04-07
description: updated
Steve Langasek (vorlon) wrote :

Dimitri, Scott says this is a regression from the latest upload. Can you please have a look at this for 14.04?

Changed in plymouth (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
importance: Undecided → High
Steve Langasek (vorlon) wrote :

FWIW I've just reproduced this in a ppc64el VM too. Console output:

Ubuntu Trusty Tahr (development branch) ubuntu hvc0

ubuntu login: hvc0
tty1
startpar-bridge
startpar-bridge

This is definitely a behavior change from the previous version. (In fact, I upgraded plymouth in this VM specifically to check whether some other console issues were fixed, and have run into this instead.)

Dimitri John Ledkov (xnox) wrote :

Right, so before we had empty:
* Starting
messages which were coming from jobs that have no description.
The intention for those was to be hidden, yet i think i've modified to have empty descriptions replaced by jobnames.
Later i've fixed to properly hide jobs with no description.
Now naked job descriptions are printed by something.
I'll look into fixing this.

Changed in plymouth (Ubuntu Trusty):
status: Confirmed → In Progress
milestone: none → trusty-updates
Dimitri John Ledkov (xnox) wrote :

So i've reproduced this on a normal desktop, even with a previous plymouth (so behaviour is not a regression as far as i can tell so far)

over e.g. ssh connection
1) stop lightdm; start plymouth in shutdown mode
2) start plymouth-upstart-bridge
3) press esc to get messages/console instead of splash
4) restart a job, e.g. restart cups

Starting/stopping plymouth bridge messages are printed, followed by the upstart job name.

Next i've set "console log" on plymouth-upstart-bridge, and started/stopping messages went away to /var/log/upstart/plymouth-upstart-bridge.log, however the naked upstart job name was still printed to the console.

Stopping plymouth-upstart-bridge makes the messages go away. I'm still trying to trace if it's plymouthd or plymouth-upstart-bridge spewing things onto the console.

Dimitri John Ledkov (xnox) wrote :

Right, i've traced this now.

So to fix bug #540645 (no fsck updates shown in details mode)

I've implemented the "Update status" (U) plymouth protocol command to actually print the passed message on the console.

However, plymouth-upstart-bridge was also sending "Update status" (U) with just the job name, since forever. But until bug #540645 was fixed, those were not printed in details mode. I'll test/propose to remove the "Update status" (U) command from plymouth-upstart-bridge and thus get a good looking boot.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.8-0ubuntu17

---------------
plymouth (0.8.8-0ubuntu17) trusty; urgency=medium

  * Suppress job-name update notifications to plymouthd from
    plymouth-upstart-bridge. (LP: #1303815)
 -- Dimitri John Ledkov <email address hidden> Fri, 11 Apr 2014 17:01:51 +0100

Changed in plymouth (Ubuntu Trusty):
status: In Progress → Fix Released
Changed in plymouth (Ubuntu):
milestone: trusty-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers