plymouthd assert failure: plymouthd: ./plugin.c:1304: open_input_source: Assertion `backend != ((void *)0)' failed.

Bug #1216022 reported by Zsolt Fatér on 2013-08-23
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Unassigned

Bug Description

It was appear after start gnome 3

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: plymouth 0.8.8-0ubuntu8
ProcVersionSignature: Ubuntu 3.11.0-3.7-generic 3.11.0-rc6
Uname: Linux 3.11.0-3-generic i686
ApportVersion: 2.12.1-0ubuntu2
Architecture: i386
AssertionMessage: plymouthd: ./plugin.c:1304: open_input_source: Assertion `backend != ((void *)0)' failed.
Date: Thu Aug 22 19:51:28 2013
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
InstallationDate: Installed on 2012-02-29 (540 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: MICRO-STAR INT'L CO.,LTD MS-1013
MarkForUpload: True
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-3-generic root=UUID=d60b7a67-16c8-4235-8231-2abc3f401d5c ro quiet splash vt.handoff=7
ProcCmdline: @sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-3-generic root=UUID=d60b7a67-16c8-4235-8231-2abc3f401d5c ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: plymouth
StacktraceTop:
 __assert_fail_base (fmt=0xb7736654 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0xb77bedeb "backend != ((void *)0)", file=file@entry=0xb77bede0 "./plugin.c", line=line@entry=1304, function=function@entry=0xb77bfa39 "open_input_source") at assert.c:92
 __GI___assert_fail (assertion=0xb77bedeb "backend != ((void *)0)", file=0xb77bede0 "./plugin.c", line=1304, function=0xb77bfa39 "open_input_source") at assert.c:101
 ?? () from /lib/i386-linux-gnu/plymouth/renderers/drm.so
 ?? () from /lib/i386-linux-gnu/plymouth/renderers/drm.so
 ply_event_loop_process_pending_events () from /lib/i386-linux-gnu/libply.so.2
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd assert failure: plymouthd: ./plugin.c:1304: open_input_source: Assertion `backend != ((void *)0)' failed.
UpgradeStatus: Upgraded to saucy on 2013-06-15 (69 days ago)
UserGroups:

dmi.bios.date: 01/09/2006
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: A1013AMS V4.30
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: MICRO-STAR INT'L CO.,LTD
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrA1013AMSV4.30:bd01/09/2006:svnMICRO-STARINT'LCO.,LTD:pnMS-1013:pvr0131:cvnMICRO-STARINT'LCO.,LTD:ct10:cvrN/A:
dmi.product.name: MS-1013
dmi.product.version: 0131
dmi.sys.vendor: MICRO-STAR INT'L CO.,LTD

Zsolt Fatér (fzs) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0xb7736654 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0xb77bedeb "backend != ((void *)0)", file=file@entry=0xb77bede0 "./plugin.c", line=line@entry=1304, function=function@entry=0xb77bfa39 <__PRETTY_FUNCTION__.8280> "open_input_source") at assert.c:92
 __GI___assert_fail (assertion=assertion@entry=0xb77bedeb "backend != ((void *)0)", file=file@entry=0xb77bede0 "./plugin.c", line=line@entry=1304, function=function@entry=0xb77bfa39 <__PRETTY_FUNCTION__.8280> "open_input_source") at assert.c:101
 open_input_source (backend=0x0, input_source=0x817f818) at ./plugin.c:1304
 on_input_source_disconnected (input_source=0x817f818) at ./plugin.c:1295
 ply_event_loop_handle_disconnect_for_source (source=0x8180990, loop=0x81780b0) at ply-event-loop.c:1089

Changed in plymouth (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Sebastien Bacher (seb128) wrote :

That issue started in saucy according to e.u.c
https://errors.ubuntu.com/problem/2ff2edcc09c48900024a784cb7f539c9c15ef2de

The bug is ranked #10 on the current trusty report

The first reports are from https://launchpad.net/ubuntu/+source/plymouth/0.8.8-0ubuntu8

information type: Private → Public
Changed in plymouth (Ubuntu):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Marcin Kordyaczny (kordyaczny) wrote :

Just after starting OS.

Daryl Hughes (zorw2016) wrote :

This error problem seems to happen to 14.04 LTS too at start up

Hyid Choi (cjh58508) wrote :

After Update I have same issue, Using Ubuntu 14.04 LTS beta 2, Gnome Flashback (Compiz) on Start up.

tags: added: trusty
Luis Salazar (ljsalazar) wrote :

Happened to me at first login after startup on Trusty.

23dornot23d (keithaerospace92) wrote :

Happened to me over last couple of days (.23 and .24 kernel) 64 bit

Daryl Hughes (zorw2016) wrote :

This issue may seem at the time to be fixed on Ubuntu 14.10 Utopic

But still in the Build mode so will be continuing test making sure this wont happen again

yash (yashx1) wrote :

same issue. using 14.04

PawelZ (pzubrzak) wrote :

Also happening on Ubuntu 15.04 MATE during starting OS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers