Ubuntu

black/blue screen before installer, tty switch fixes it

Reported by Paolo Pisati on 2012-10-12
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Quantal
High
Unassigned
ubuntu-omap4-extras-graphics
Undecided
Unassigned
linux-ti-omap4 (Ubuntu)
Medium
Paolo Pisati
Raring
Undecided
Unassigned
Saucy
Medium
Paolo Pisati
plymouth (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned
pvr-omap4 (Ubuntu)
High
Ricardo Salveti
Raring
Undecided
Unassigned
Saucy
High
Ricardo Salveti

Bug Description

quantal-desktop-armhf+omap4.img from 12th October 2012 md5sum: b6e635a4ca045b241d58ed3a73ca6943

During a test installation, after the purple Ubuntu splash screen, the user is greeted with a black or blue screen instead of the installer.
Switching tty and back (ctrl+alt+f1 and alt+f7) fixes it.

Paolo Pisati (p-pisati) wrote :

During the boot the splash screen is visible so /dev/fb is ok up to that point, the problem arises when we hand it off to X/pvr/etcetc but i added linux-ti-omap4 just in case.

Paolo Pisati (p-pisati) wrote :

i couldn't complete an installation because at the end i got e message saying:

"an unrecoverable error has happened.. blablabla... a desktop session will start so you can fix it"

and again i got a black screen, tty switch (C+A+F1 and A+7) and i got back to a desktop session.

Changed in pvr-omap4 (Ubuntu):
assignee: nobody → Ricardo Salveti (rsalveti)
Changed in linux-ti-omap4 (Ubuntu):
assignee: nobody → Paolo Pisati (p-pisati)
Changed in linux-ti-omap4 (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key quantal
Paolo Pisati (p-pisati) on 2012-10-12
summary: - black/blue screen before installer, tty switches fixes it
+ black/blue screen before installer, tty switch fixes it
Ricardo Salveti (rsalveti) wrote :

Adding the ubuntu-omap4-extras-graphics project as I believe this is a known issue from TI side.

One thing I was discussing with ogra a few days ago is that we're using the pvr-omap4 driver already at the installer, and that's not a good thing to do as this might affect future hardware revisions (issues with the SGX driver specifically).

Ideally both the installer and the 'safe' X11 session should just be using fbdev, so the user gets to a valid session all the time (only issue if the desktop session requires unity 3d, then we should use fbdev at least during the installer).

Steve Langasek (vorlon) on 2012-10-12
Changed in plymouth (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-ti-omap4 (Ubuntu):
status: New → Confirmed
Changed in pvr-omap4 (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

I'm also seeing this issue with a quantal-desktop omap4 daily build from 10-11-12. The system boots fine, but I have to switch to another tty then back to tty7 to get graphics.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1065902

tags: added: iso-testing
Changed in ubuntu-release-notes:
status: New → Invalid
Paolo Pisati (p-pisati) wrote :

Some more infos on my setup:

-reproducible on a panda ES rev B1 and a panda rev A4
-using the hdmi output on the board (the one closest to the usb + nic tower) and an hdmi->dvi cable

this setup has worked well since Maverick but i get this bug constantly with Q.

Two ways to get around it:

1) using a native hdmi device (like my plasma tv), and using the hdmi output, i DON'T get this bug

or

2) using the other hdmi output on the board and the aforementioned hdmi->dvi cable (but i get a crappy resolution in this case).

C de-Avillez (hggdh2) wrote :

reproduced locally, HDMI->DVI connector

CursingRabbit (cursingrabbit) wrote :

Not only happening on ARM:

Same problem with ubuntu-12.10-desktop-i386 on an Acer Aspire One 722 with AMD C-60 APU.

After starting the PC you see the
- BIOS-Logo,
- blinking cursor,
- Screen goes on,
- Screen goes off.

The only workaround is to switch with CRTL+ALT+F2, then CTRL+ALT+F7.

After that everythings normal and i enter my password for the hdd encryption.

Changed in linux-ti-omap4 (Ubuntu):
status: Confirmed → Fix Released
Oliver Grawert (ogra) wrote :

please do not randomly clese bug tasks unless you can point to a changelog entry with the fix, this is definitely not fixed (only noted with a workaround in the release notes)

Changed in linux-ti-omap4 (Ubuntu):
status: Fix Released → Confirmed
Changed in pvr-omap4 (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) on 2013-06-24
Changed in plymouth (Ubuntu Raring):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-ti-omap4 (Ubuntu Raring):
status: New → Confirmed
Changed in pvr-omap4 (Ubuntu Raring):
status: New → Confirmed
brianM (brian-reachharbour) wrote :

I have similar symtoms on an Amd a6-5200 machine with Radeon HD8670M, however the tty switch has no effect. I am totally locked out from installing 13.10 !!! This is a critical bug

Niles Rogoff (nilesrogoff) wrote :

I have the same problem even on existing non-beta and LTS releases on a Dell D505 laptop.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers