System will not boot with default settings of "gfxmode $linux_gfx_mode"

Bug #1047685 reported by L
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

Ubuntu by default has the line "gfxmode $linux_gfx_mode" in the GRUB entry I use to boot.

If this line is in GRUB, the system hangs on a windowed purple screen. It will not boot.

To boot into Ubuntu, I must manually remove this line.

Hardware is a Thinkpad T520. Occurs in both 12.04 and 12.10 Beta 1.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: grub (not installed)
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Fri Sep 7 19:32:27 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: grub
UpgradeStatus: Upgraded to quantal on 2012-09-07 (0 days ago)
---
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
DistroRelease: Ubuntu 12.10
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: LENOVO 4239CTO
NonfreeKernelModules: nvidia
Package: plymouth 0.8.4-0ubuntu3
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=728e7962-8356-4582-b65b-30d43dba3a77 ro nomodeset
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=728e7962-8356-4582-b65b-30d43dba3a77 ro nomodeset
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Tags: quantal
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Uname: Linux 3.5.0-13-generic x86_64
UpgradeStatus: Upgraded to quantal on 2012-09-07 (3 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/06/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8AET56WW (1.36 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4239CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8AET56WW(1.36):bd12/06/2011:svnLENOVO:pn4239CTO:pvrThinkPadT520:rvnLENOVO:rn4239CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4239CTO
dmi.product.version: ThinkPad T520
dmi.sys.vendor: LENOVO

Revision history for this message
L (ajsoiasaaso) wrote :
Revision history for this message
Steve Langasek (vorlon) wrote :

Reassigning this bug to plymouth. Please run apport-collect 1047685 to gather necessary hardware information from the affected system.

Also, please check whether the system boots successfully with each of the following changes:

- re-enabling gfxmode and turning 'splash' off in the boot settings
- re-enabling gfxmode and removing the nvidia binary graphics driver

affects: grub (Ubuntu) → plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
status: New → Incomplete
Revision history for this message
L (ajsoiasaaso) wrote : BootDmesg.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
L (ajsoiasaaso) wrote : BootLog.gz

apport information

Revision history for this message
L (ajsoiasaaso) wrote : CurrentDmesg.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : Dependencies.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : EtcDefaultGrub.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : Lspci.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : Lsusb.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : ProcEnviron.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : ProcInterrupts.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : ProcModules.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : UdevDb.txt

apport information

Revision history for this message
L (ajsoiasaaso) wrote : UdevLog.txt

apport information

Revision history for this message
Martin Henderson (nymrat) wrote :

Same problem on an HP Pavilion dm1 with ATI Radeon using open source drivers.
Occured after upgrade to 12.10.

Screen is purple while booting, flickering a few times. Log-in sound plays, but screen remains purple.
Cannot Ctrl-Alt-F1 to terminal.

One interesting point - if AC adapter is connected while GRUB is running, system boots fine.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for plymouth (Ubuntu) because there has been no activity for 60 days.]

Changed in plymouth (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers