no display output from i7-620LE "Arrandale" built-in Intel Graphics Device

Bug #1004611 reported by s p e x on 2012-05-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

I have worked on A LOT of trial and error (even trying experimental 3.4.x drm kernels with 12.04) for this problem.

However, 10.10's LiveCD seems to be a sweet spot where I have some of the problem (no video for plymouth) but not all of the problem, X comes up.

Any of the newer releases both Plymouth and Xorg fail.

I do get this error on for 10.10, 11.04, 11.10, and 12.04:

[drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
[drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88021161a000
[drm:drm_fb_helper_restore] *ERROR* Failed to restore crtc configuration
[drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
[drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88021161a000
[drm:drm_fb_helper_restore] *ERROR* Failed to restore crtc configuration

But perhaps that's a red herring. Since that error is present here in 10.10, and yet X is running.

That error led me to this bug:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/814895
and I even tried the kernel mentioned there (with 12.04) but I still didn't get any video.

Perhaps this is the problem? (dual channel LVDS issue)
http://lists.freedesktop.org/archives/intel-gfx/2010-January/005643.html

Ultimately I'd like to be runing 12.04LTS. But it seems like I'm stuck at 10.10.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: plymouth 0.8.2-2ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
AssertionMessage: plymouthd: ./ply-renderer-i915-driver.c:328: begin_flush: Assertion `buffer != ((void *)0)' failed.
Date: Fri May 25 17:50:03 2012
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
ExecutablePath: /sbin/plymouthd
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcCmdline: /sbin/plymouthd --mode=boot --attach-to-session
ProcEnviron: PATH=(custom, no user)
ProcFB: 0 inteldrmfb
Signal: 6
SourcePackage: plymouth
StacktraceTop:
 raise () from /lib/libc.so.6
 abort () from /lib/libc.so.6
 __assert_fail () from /lib/libc.so.6
 ?? () from /lib/plymouth/renderers/drm.so
 ?? () from /lib/plymouth/renderers/drm.so
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Title: plymouthd assert failure: plymouthd: ./ply-renderer-i915-driver.c:328: begin_flush: Assertion `buffer != ((void *)0)' failed.
UserGroups:

dmi.bios.date: 02/10/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.3
dmi.board.name: BM57/BS57/BE57
dmi.board.vendor: congatec
dmi.chassis.type: 2
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.3:bd02/10/2011:svn:pn:pvr:rvncongatec:rnBM57/BS57/BE57:rvr:cvn:ct2:cvr:

s p e x (spex-k) wrote :
visibility: private → public
s p e x (spex-k) wrote :

I have since figured out a little bit more.

The motherboard I've been using is a development board. This board can support a flat panel display that would be suitable for a laptop.

Unfortunately, I'm unable to convince the board that it doesn't have a laptop LCD installed. On Ubuntu 10.04.1 LTS (which I switched to because I sorta prefer LTS) I was able to tell Xorg that I didn't want it to use the nonexistent "laptop" display.

I believe all the LVDS errors are from the software trying to query this nonexistent display and failing.

Further, I believe that the newer kernels/distributions are making little or no attempt to use the external display because of these problems.

Should I file a bug against 12.04?

Unsetting the need retracing tag, there is no retracer left running on that version of Ubuntu, the crash will need to be manually retraced

tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers