Enabling plugin 'Snippets' is followed by error 'GLib.Error: gtk-icon-theme-error-quark: Icon 'gtk-justify-left' not present in theme ubuntu-mono-dark"

Bug #1743137 reported by Norbert on 2018-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pluma (Ubuntu)
Undecided
Martin Wimpress

Bug Description

Steps to reproduce:
1. Install Ubuntu 18.04 LTS
2. Install Pluma with dependencies by `sudo apt-get install pluma gir1.2-pluma-1.0 libpeas-1.0-python2loader python-gi`
3. Launch Pluma text editor from terminal
4. Go to Edit->Preferences, Plugins tab, enable Snippets plugin

Expected results:
Snippets plugins is enabled without errors and/or warnings

Actual results:
Snippers plugin show errors in the terminal:

Traceback (most recent call last):
  File "/usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/WindowHelper.py", line 141, in on_tab_added
    view._snippet_controller = Document(self, view)
  File "/usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Document.py", line 53, in __init__
    self.provider = Completion.Provider(_('Snippets'), self.language_id, self.on_proposal_activated)
  File "/usr/lib/x86_64-linux-gnu/pluma/plugins/snippets/Completion.py", line 41, in __init__
    self.icon = theme.load_icon(Gtk.STOCK_JUSTIFY_LEFT, w, 0)
GLib.Error: gtk-icon-theme-error-quark: Icon 'gtk-justify-left' not present in theme ubuntu-mono-dark (0)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: pluma 1.18.3-2
ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
Uname: Linux 4.13.0-25-generic x86_64
ApportVersion: 2.20.8-0ubuntu6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Jan 13 20:40:49 2018
InstallationDate: Installed on 2017-12-22 (21 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171221)
SourcePackage: pluma
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Changed in pluma (Ubuntu):
status: New → In Progress
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in pluma (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pluma - 1.20.1-3ubuntu1

---------------
pluma (1.20.1-3ubuntu1) bionic; urgency=medium

  * debian/patches:
    + Add 0001_disable_python_plugins.patch. Disable Python plugins because
      libpeas only supports Python3 and the Python plugins in Pluma only
      support Python2. (LP: #1743133) (LP: #1743137)

 -- Martin Wimpress <email address hidden> Wed, 25 Apr 2018 11:51:50 +0100

Changed in pluma (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers