"Failed to load module 'pythonloader': /usr/lib/x86_64-linux-gnu/libpeas-1.0/loaders/libpythonloader.so: cannot open shared object file: No such file or directory" on enabling 'External Tools' or 'Python Console' plugins

Bug #1743132 reported by Norbert on 2018-01-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pluma (Ubuntu)
Medium
Martin Wimpress

Bug Description

Steps to reproduce:
1. Install Ubuntu 17.10 MATE
2. Launch Pluma text editor from terminal
3. Go to Edit->Preferences, Plugins tab, check "External Tools" and/or "Python Console" plugins

Expected results:
"External Tools" and/or "Python Console" plugins enabled successfully

Actual results:
"External Tools" and/or "Python Console" plugins does not enabled, it shows error message in terminal

(pluma:3128): libpeas-WARNING **: Failed to load module 'pythonloader': /usr/lib/x86_64-linux-gnu/libpeas-1.0/loaders/libpythonloader.so: cannot open shared object file: No such file or directory

(pluma:3128): libpeas-WARNING **: Could not load plugin loader 'python'

Note:
1. this bug is inspired by this AskUbuntu question (https://askubuntu.com/q/995466/66509)
2. the solution is to install dependencies manually (sudo apt-get install libpeas-1.0-python2loader gir1.2-pluma-1.0) and clean config directory (`rm -rf ~/.config/pluma`), so please add them to package.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: pluma 1.18.2-1
ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
Uname: Linux 4.13.0-25-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: MATE
Date: Sat Jan 13 19:37:13 2018
InstallationDate: Installed on 2017-12-23 (21 days ago)
InstallationMedia: Ubuntu-MATE 17.10 "Artful Aardvark" - Release amd64 (20171018)
SourcePackage: pluma
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) on 2018-01-13
description: updated
summary: "Failed to load module 'pythonloader': /usr/lib/x86_64-linux-
gnu/libpeas-1.0/loaders/libpythonloader.so: cannot open shared object
- file: No such file or directory" on enabling Python Console plugin
+ file: No such file or directory" on enabling 'External Tools' or 'Python
+ Console' plugins
description: updated
Norbert (nrbrtx) on 2018-01-13
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pluma (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2018-01-13
description: updated
Norbert (nrbrtx) on 2018-01-13
tags: added: bionic
Norbert (nrbrtx) wrote :

18.04 LTS with all updates, bug exists.

Norbert (nrbrtx) wrote :

18.04 LTS with all updates, bug exists.

Changed in pluma (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Martin Wimpress (flexiondotorg)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pluma - 1.20.1-2ubuntu1

---------------
pluma (1.20.1-2ubuntu1) bionic; urgency=medium

  * debian/control:
    + Add D: libpeas-1.0-python2loader (pluma). (LP: #1743132)
    + Move D: gir1.2-pluma-1.0 from (pluma-dev) to (pluma). (LP: #1723259)

 -- Martin Wimpress <email address hidden> Mon, 09 Apr 2018 09:23:20 +0100

Changed in pluma (Ubuntu):
status: Fix Committed → Fix Released
Norbert (nrbrtx) wrote :

Confirmed fixed in 1.20.1-2ubuntu1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers