Could not load Pluma repository: Typelib file for namespace 'Pluma', version '1.0' not found

Bug #1723259 reported by Norbert on 2017-10-12
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pluma (Ubuntu)
Medium
Martin Wimpress

Bug Description

Steps to reproduce:
1. Install Ubuntu 17.10 or 18.04 LTS and ubuntu-mate-desktop package
2. Launch Pluma from terminal with `pluma`

Expected results:
pluma starts silently

Actual results:
pluma writes the following message to terminal:

** (pluma:23057): WARNING **: Could not load Pluma repository: Typelib file for namespace 'Pluma', version '1.0' not found

Temporary workaround:
Install gir1.2-pluma-1.0 with `sudo apt-get install gir1.2-pluma-1.0`.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: pluma 1.18.2-1
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic i686
ApportVersion: 2.20.7-0ubuntu3
Architecture: i386
CurrentDesktop: MATE
Date: Fri Oct 13 00:13:29 2017
InstallationDate: Installed on 2017-08-26 (47 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha i386 (20170826)
SourcePackage: pluma
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Vlad Orlov (monsta) wrote :

Ah... missing runtime dependency on libpeas-1.0-python2loader.

Workaround: install libpeas-1.0-python2loader

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pluma (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) wrote :

Got this message again on fresh installation of Ubuntu 17.10 MATE.

Norbert (nrbrtx) wrote :

I installed dependency, rebooted, but it does not help:

mate1710@mate1710:~$ apt-cache policy libpeas-1.0-python2loader
libpeas-1.0-python2loader:
  Installed: 1.22.0-1
  Candidate: 1.22.0-1
  Version table:
 *** 1.22.0-1 500
        500 http://archive.ubuntu.com/ubuntu artful/universe i386 Packages
        500 http://ru.archive.ubuntu.com/ubuntu artful/universe i386 Packages
        100 /var/lib/dpkg/status
mate1710@mate1710:~$ pluma

** (pluma:1931): WARNING **: Could not load Pluma repository: Typelib file for namespace 'Pluma', version '1.0' not found
mate1710@mate1710:~$

Norbert (nrbrtx) wrote :

Real dependency was gir1.2-pluma-1.0 (see below):

mate1710@mate1710:~$ sudo apt-file search Pluma

gir1.2-pluma-1.0: /usr/lib/i386-linux-gnu/girepository-1.0/Pluma-1.0.typelib
pluma-dev: /usr/share/gir-1.0/Pluma-1.0.gir
pluma-doc: /usr/share/gtk-doc/html/pluma/PlumaMessage.html
pluma-doc: /usr/share/gtk-doc/html/pluma/PlumaMessageBus.html
pluma-doc: /usr/share/gtk-doc/html/pluma/PlumaMessageType.html
pluma-doc: /usr/share/gtk-doc/html/pluma/pluma-PlumaPrintJob.html

I installed gir1.2-pluma-1.0 and warning message gone.

description: updated
Norbert (nrbrtx) on 2017-10-30
description: updated
tags: added: bionic
Norbert (nrbrtx) wrote :

18.04 with all updates, bug is here.

Norbert (nrbrtx) wrote :

17.10 with all updates,
bug is here and related to other (bug 1743132, bug 1743133 and bug 1743134)

Norbert (nrbrtx) wrote :

18.04 LTS with all updates, bug exists.

Norbert (nrbrtx) wrote :

18.04 LTS with all updates, bug exists.

Changed in pluma (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Martin Wimpress (flexiondotorg)
status: Confirmed → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pluma - 1.20.1-2ubuntu1

---------------
pluma (1.20.1-2ubuntu1) bionic; urgency=medium

  * debian/control:
    + Add D: libpeas-1.0-python2loader (pluma). (LP: #1743132)
    + Move D: gir1.2-pluma-1.0 from (pluma-dev) to (pluma). (LP: #1723259)

 -- Martin Wimpress <email address hidden> Mon, 09 Apr 2018 09:23:20 +0100

Changed in pluma (Ubuntu):
status: Fix Committed → Fix Released
Norbert (nrbrtx) wrote :

Confirmed fixed in 1.20.1-2ubuntu1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers