postgresql-8.1-plr for Feisty missing plr.so and plr.sql

Bug #122183 reported by Lance Rushing on 2007-06-25
8
Affects Status Importance Assigned to Milestone
plr (Ubuntu)
Undecided
Unassigned
Feisty
Undecided
Lance Rushing

Bug Description

Binary package hint: postgresql-8.1-plr

For some reason postgresql-8.1-plr (http://packages.ubuntu.com/feisty/libs/postgresql-8.1-plr) is missing usr/lib/postgresql/8.1/lib/plr.so and usr/share/postgresql/8.1/plr.sql

These two files are the important ones. All other files in the package are just docs.

Previous releases contained these files:
http://packages.ubuntu.com/dapper/libs/postgresql-8.1-plr
http://packages.ubuntu.com/edgy/libs/postgresql-8.1-plr

And Gutsy already has it (postgresql 8.2):
http://packages.ubuntu.com/gutsy/libs/postgresql-8.2-plr

Did the build script get messed up?

Lance Rushing (lance-rushing) wrote :

I've been trying to figure out the problem.

I noticed that when the package builds, it creates directories for version 8.2 (!), but I only have 8.1 installed
<code>$ find install-8.1/
install-8.1/
install-8.1/usr
install-8.1/usr/lib
install-8.1/usr/lib/postgresql
install-8.1/usr/lib/postgresql/8.2
install-8.1/usr/lib/postgresql/8.2/lib
install-8.1/usr/lib/postgresql/8.2/lib/plr.so
install-8.1/usr/share
install-8.1/usr/share/doc
install-8.1/usr/share/doc/postgresql-doc-8.2
install-8.1/usr/share/doc/postgresql-doc-8.2/contrib
install-8.1/usr/share/doc/postgresql-doc-8.2/contrib/README.plr
install-8.1/usr/share/postgresql
install-8.1/usr/share/postgresql/8.2
install-8.1/usr/share/postgresql/8.2/contrib
install-8.1/usr/share/postgresql/8.2/contrib/plr.sql
</code>

I traced the "8.2" down to /usr/lib/postgresql/8.2/bin/pg_config which is part of the libpq-dev package. Seems like libpq-dev is only available in 8.2 for fiesty.
libpq-dev (>=8.1) is required by postgresql-server-dev-8.1, and postgresql-server-dev-8.1 is required when doing a "sudo apt-get build-dep postgresql-8.1-plr"

The permanent fix would be to make version 8.1 of libpg-dev available.

However, I have a patch which hard codes the paths. (See next comment for the fix)

Lance Rushing (lance-rushing) wrote :

Download the patch file to your home directory as rules.patch, then do:

<code>$ mkdir /tmp/plr
$ cd /tmp/plr
$ apt-get source postgresql-8.1-plr
$ sudo apt-get build-dep postgresql-8.1-plr
$ cd plr-0.6.2
$ patch -p0 -i ~/rules.patch
$ dpkg-buildpackage -rfakeroot -uc -b
$ cd ..
$ sudo dpkg --install postgresql-8.1-plr_0.6.2-4ubuntu1_amd64.deb
</code>

Enjoy!

Luca Falavigna (dktrkranz) wrote :

Thank you for your bug report.
Are these files required to run this package correctly?

Changed in plr:
status: New → Incomplete
Lance Rushing (lance-rushing) wrote :

Yes,

usr/lib/postgresql/8.1/lib/plr.so and
usr/share/postgresql/8.1/plr.sql

are required for this software to run correctly.

-Lance

P.S. I also have a writeup on how to build postgresql-8.2-plr for feisty using gutsy deb-src: http://lancerushing.blogspot.com/2007/06/building-plr-package-for-postgres-82-on.html

Luca Falavigna (dktrkranz) wrote :

I prepared this package for testing purposes. Could you please try it and report any troubles you'll find? Thank you.

William Grant (wgrant) on 2007-07-14
Changed in plr:
status: Incomplete → Invalid
Luca Falavigna (dktrkranz) wrote :

Attached debdiff for feisty-proposed should fix this behaviour.

Daniel Holbach (dholbach) wrote :

Martin: can you take a look into this?

Changed in plr:
assignee: nobody → pitti
Martin Pitt (pitti) wrote :

Reviewed, sponsored, and accepted into feisty-proposed. Please continue with testing and tagging as per https://wiki.ubuntu.com/MOTU/SRU.

Changed in plr:
status: Invalid → Fix Released
assignee: pitti → lance-rushing
status: New → Fix Committed
Luca Falavigna (dktrkranz) wrote :

plr (1:0.6.2-4ubuntu1.1) feisty-proposed; urgency=low

  * SRU: Provide missing files /usr/lib/postgresql/8.1/lib/plr.so and
    /usr/share/postgresql/8.1/plr.sql from postgresql-8.1-plr (LP: #122183)
  * Update Maintainer field in debian/control

 -- Luca Falavigna <email address hidden> Mon, 9 Jul 2007 23:23:28 +0200

Changed in plr:
status: Fix Committed → Fix Released
Changed in plr:
status: Fix Released → Fix Committed
Scott Kitterman (kitterman) wrote :

What steps does one have to do to confirm the fix works?

Lance Rushing (lance-rushing) wrote :

One way to see if everything works:

$ sudo dpkg --install postgresql-8.1-plr_0.6.2-4ubuntu1.1~demo1_i386.deb # install it
$ sudo su - postgres # become the postgres user
$ createdb plr_test; # create test db
$ psql plr_test < /usr/share/postgresql/8.1/plr.sql # load PLR functions
$ psql plr_test; # connect to DB
plr_test=# SELECT reload_plr_modules(); # test if the functions work.
  reload_plr_modules
 --------------------
  OK
 (1 row)

Works for me following given procedure

Works for me following given procedure

Luca Falavigna (dktrkranz) wrote :

Two persons confirmed this fix and aging period of 7 days is over. Tagging with verification-motu-done.

Martin Pitt (pitti) wrote :

Copied to feisty-updates.

Changed in plr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers