Lagging square around mouse pointer

Bug #1684240 reported by Jacob Greenstein on 2017-04-19
This bug affects 49 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-375 (Ubuntu)
nvidia-graphics-drivers-384 (Ubuntu)
plasma-workspace (Ubuntu)

Bug Description

(This can also be an nvidia related problem)

Mouse pointer behaves as if it has an invisible square attached to it. This square covers some area next to the pointer, but it is not always clear exactly where (a link to a screenshot is shown below, please note the white square with some text from the previous webpage displayed in that window).

This makes selecting text difficult, as one never knows where exactly the selection ends. Also, scrolling in some windows becomes problematic, as the pointer shadows a part of the scrollbar. When a text is being typed, one needs to make sure that the pointer is parked sufficiently far from the text (so, to make a long story short, this is very annoying).

This behavior does not depend on the choice of the cursor theme.

(A link to the screenshot:

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: plasma-workspace 4:5.9.4-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
CurrentDesktop: KDE
Date: Wed Apr 19 10:41:58 2017
InstallationDate: Installed on 2015-06-05 (684 days ago)
InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: plasma-workspace
UpgradeStatus: Upgraded to zesty on 2017-04-13 (5 days ago)

Jacob Greenstein (jgrnst) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-workspace (Ubuntu):
status: New → Confirmed
Loïc Gomez (opensource-loic) wrote :
Download full text (14.5 KiB)

I can confirm this issue, I have the same problem since zesty update.

I cannot use apport-collect to complete information as I'm also affected by

So here's too much information !
If you need more please just ask away.

-- Loïc

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty
$ uname -a
Linux valefor 4.8.0-45-generic #48-Ubuntu SMP Fri Mar 24 11:46:39 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
$ dpkg -l 'plasma*' |grep -v '^u'
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom Version Architecture Description
ii plasma-dataengines-addons 4:5.9.4-0ubuntu1 amd64 additional data engines for Plasma
ii plasma-desktop 4:5.9.4-0ubuntu1 amd64 Tools and widgets for the desktop
ii plasma-desktop-data 4:5.9.4-0ubuntu1 all Tools and widgets for the desktop data files
ii plasma-discover 5.9.4-0ubuntu1 amd64 Discover software management suite
ii plasma-discover-common 5.9.4-0ubuntu1 all Discover software manager suite (common data files)
rc plasma-discover-private 5.6.2-1ubuntu1.1 amd64 Private runtime libraries for the Discover suite
ii plasma-framework 5.31.0-0ubuntu1 amd64 Plasma Runtime components
ii plasma-integration 5.9.4-0ubuntu1 amd64 Qt Platform Theme integration plugins for KDE Plasma
ii plasma-look-and-feel-org-kde-breezedark-desktop 4:5.9.4-0ubuntu1 all Dark Breeze look-and-feel for Plasma
ii plasma-nm 4:5.9.4-0ubuntu1 amd64 Plasma5 networkmanager library.
ii plasma-pa 4:5.9.4-0ubuntu1 amd64 Plasma 5 Volume controller
ii plasma-runner-telepathy-contact 4:16.12.3-0ubuntu1 amd64 Telepathy Contact KRunner plugin
ii plasma-runners-addons 4:5.9.4-0ubuntu1 amd64 additional runners for Plasma 5 and Krunner
ii plasma-scriptengine-javascript 4:16.12.3-0ubuntu1 amd64 JavaScript script engine for Plasma
ii plasma-wallpapers-addons 4:5.9.4-0ubuntu1 amd64 additional wallpaper plugins for Plasma 5
ii plasma-widget-folderview 4:16.04.3-0ubuntu1 amd64 plasma widget showing the content of a folder
ii plasma-widgets-addons 4:5.9.4-0ubuntu1 amd64 additional widgets for Plasma 5
rc plasma-widgets-w...

Loïc Gomez (opensource-loic) wrote :

Some additionnal information: tried to change cursor theme from Brise to any other and problem is still there.
Also changing vsync tearing parameter (or any other in fact) in composer settings did not help either.

Jacob Greenstein (jgrnst) wrote :

Changed to nouveau; the problem disappeared.

iLugo (isra) wrote :

Finally found the bug report of this problem. It affects me, exactly the same. I could provide more details BUT it doesn't seem to be relevant, doesn't it? I explain:

A couple of notes, @jgrns:
What do you mean "the problem disappeared"? Does it mean: it "disappeared" from your system? Or: on everybody else's systems? It didn't "disappear" from mine. Mind to provide any useful context?

Posts like that are the ones that make so many people hate 'this' (you know, Linux, FOSS, and all the things that they should not hate for things like this). Not because you are inaccurate and confusing, but because you seem to have the power to change the status of the bug (without actually fixing it), whatever "nouveau" means in your launchpad jargon.

The bugs reports are not to satisfy those who have the power of changing status of bugs. They are for the users, because without users software is useless. Far too frequently I see these useless posts that seem to imply that magic does exist.

Problems don't "disappear" by magic in Engineering or in Science or in Life. And if you think they do, at least you should propose some theory that doesn't make you look that you just want to dismiss the problem or make us believe that "if you wait long enough, all your problems in life will disappear" --which is true, but some us don't want to wait until we die to see all troubles vanishing from our lives. I would be fired if I would ever suggest that to my customers, or worse, tell them that because all of a sudden I ceased to see the problem, they are wrong and it doesn't exist.

Sorry if it looks that I am irritated, but those six words did the job. I am sure others with this problem would also feel. Please if you can't help with this bug, or believe it's something magical that comes and go, or if open tickets are annoying, then please at least don't dismiss it with "it disappeared" without at least a slight context. It doesn't really add credibility to a --presumably-- software developer who tells users with a complaint that the problem was perhaps abducted by aliens and now "is gone". It's not. It's a bad bug, it disrupts tremendously the work in the KDE environment, to the point of almost preventing us to work with most of the programs that use the mouse at all. It is a show stopper.

You can change the status of the bug to whatever you please, it's not "my" bug report system. But then it's a bit useless for the rest of the people.

Anyhow, thanks for the bug report, because it is very well described. I might copy/paste part of the description and seek for help somewhere else.

Jacob Greenstein (jgrnst) wrote :

You should realize that this is not some sort of a help desk but a community where everyone is trying to help everyone by providing information about their issues. I "own" this bug because I reported it, but I am not a developer of the package involved.

In my first post I mentioned that this issue might be related with Nvidia proprietary driver; it often happens when KDE is upgraded that some issues arise because Nvidia maintainers do not keep up with the advancement of KDE/plasma. The open source driver (nouveau) has a lot of issues itself and I was reluctant to try it again; I did try it though after someone wrote that they got around this issue by switching to nouveau, and it worked for me. So, if you have an Nvidia card and are using the proprietary driver, you may try nouveau instead. If not, you will do everyone a service if you run ubuntu-bug on your system and submit the information it collects.

iLugo (isra) wrote :

...and I should have guessed all that information from your six words post because...?

So in your opinion: because I could not guess all of that, I should have opened my own bug report and fight it all by myself from zero, ignoring the fact that someone already had opened a bug report because "everyone is trying to help everyone by providing information about their issues".

Touching words, "everyone trying to help everyone". But it seems that this one was opened to get help for your own issue and not to "share" anything with anyone. So "someone wrote" is another way of telling the community (you say you are trying to help), that you are not sharing neither contents of said advice nor source of it; you just happen to "have found it". Nice.

So, should I have written my own report after wasting my time on this one: how would you feel if I would have concluded it with a six words post like: "I have fixed the problem now." with no more context. The internet is full of this kind of rubbish. Precisely: not a Help Desk, not a "sharing place", no nothing.

No, this is not Help Desk, and precisely because it's not, people should use it consciously and realizing that it's not because one opens a "ticket" that it makes them automatically a "community's hero" if you are not going to steer the bug report in the sense of making it an useful place of sharing information and not one where others will stumble upon and get frustrated by the "I have fixed my problem, goodbye" posts.

That community you talk about always expect that a bug report owner would have the minimum courtesy of providing any information that might be somehow relevant and potentially help. Not confusing/frustrating the community, which is what posts like those do.

So like you said: "community where everyone is trying to help everyone by providing information about their issues" is the opposite of what I found here, as your own last two posts unfortunately prove it. Either you share or you don't. You didn't. Just read your own words again, please, and try to actually apply those good ideas, next time. That would do everyone a service.

Loïc Gomez (opensource-loic) wrote :

Jacob message is pretty clear, I had no trouble understanding it, no need to write so many lines just for this, please get over it.

Anyways, back to topic, the problem persists and is probably related to nvidia driver.
Is there a way we can contribute and analyze/test this problem ?


Jacob Greenstein (jgrnst) wrote :

Merci beaucoup de votre soutien; comme vous pouvez le constater, je n'ai pas répondu à deuxième message, pour terminer cette discussion inutile.

What I cannot figure out is whether it is a problem of the driver or Nvidia OpenGL libraries. As far as I remember, installing the driver forces the libraries to be installed. It would be interesting to try installing just the driver (but not the libraries, if that is possible) and to check whether the problem persists.

Perhaps we should file a bug with nvidia: it is possible that developers/packagers of plasma did not notice this bug or weren't able to reproduce it since they do not use Nvidia driver.

Loïc Gomez (opensource-loic) wrote :

You're welcome Jacob :)
See also even if it seems less intrusive as what I'm experiencing.

I'm using dual screen, do you too ?

Jacob Greenstein (jgrnst) wrote :

I use dual screen quite often but not always. This behavior is the same for a single and a double screen. This is why I was reluctant to try nouveau, which used to have a lot of issues with that configuration. So far it works fine.

That other bug might be related; also, judging by the screenshot, they are using Gnome.

Loïc Gomez (opensource-loic) wrote :

Ok, I'm using an external screen but laptop screen is off when screen is connected.
I removed all nvidia drivers and tools and thus switched to nouveau, the problem is gone.

So this is most certainly related to nvidia drivers.

kelvie (kelvie) wrote :

Like Loïc, I also use an external screen, with the laptop screen turned off, and I see this problem.

I've also removed nvidia drivers temporarily, and primarily use the Intel integrated card now.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-375 (Ubuntu):
status: New → Confirmed
dskd (mark-p--sanders) wrote :

I am affected by this bug as well.

My workaroud for this Problem: Go to KDE System Settings -> Display and Monitor -> Compositor (left side) -> set "Rendering Backend" to XRender

But now my wobbly windows are gone ;(

I just upgraded to kubuntu 17.04 and this problem appeared (yeah, I knew an update would take some time, so I waited until I had some spare time).

Jacob Greenstein (jgrnst) wrote :

A new development: today I installed Kubuntu 17.04 from scratch on a new laptop. The pointer behaves normally.

Ricardo Sanz (tunic) wrote :

I'm also affected by this bug.

I have a GeForce GTX 1060 Mobile video card, using nvidia-375 (375.66-0ubuntu0.17.04.1) package on Kubuntu 17.04 with backports repository (Plasma 5.10.3).

It seems that the area around the mouse pointer is not redrawn properly.

Problem persists with compositor enabled and disabled.

The only workaround is what dskd (mark-p--sanders) said: use XRender as rendering backend (but I think performance is affected).

Ricardo Sanz (tunic) wrote :

I forgot to mention I'm also using double monitor (laptop + external screen with mini display port).

WORKAROUND: Use nvidia latest driver 381.22:

With this driver problem seems gone.

Ruben Javier (rubenjavier) wrote :

I have another big clue
This happened to me also, I'm on kubuntu 16.04.2 with nvidia drivers 384.47 and everything has been working fine while I was using xserver-xorg 1.18 (except for the know tearing).
So I updated to xserver-xorg-core-hwe 1.19.3 from the xenial proposed ppa and the cursor got corrupted.
So, it has to do with updating to xorg 1.19 and nvidia propietary driver
On the bright side, xorg 1.19 indeed fixes the screen tearing and vsync with the line "options nvidia_384_drm modeset=1" in /etc/modprobe.d/zz-nvidia-modeset.conf

Lienhart Woitok (liwo) wrote :

I updated from Kubuntu 16.04 to 17.04 a few days ago to fix some other issues with frequent crashes and on Kubuntu 17.04 am now also affected by this bug.

I tried updating nvidia driers to 381 and 384 but I could detect no difference between 375, 381 and 384 (from ppa:graphics-drivers/ppa). For now I switched to XRender as recommended in #16. OpenGL 3.1 and 2.0 both have the rectangle below the cursor.

I also use a dual screen setup but I could not detect a difference between leaving the external screen unplugged or not.

David Matějček (dmatej) wrote :

To me helped only unchecking the checkbox "Enable compositor on startup".

Jason Tiller (jason-sonos) wrote :

I am also experiencing the exact same issue on KDE Neon 5.10.4 and nvidia-384.59, and switching to Xrender also fixes it for me.

Note that for me turning off compositing while using OpenGL 3.1 had a salutory effect but did not completely resolve the problem. For example, chromium still showed the issue but Konsole, system settings, and nvidia-settings did not (I just had these up at the time).

I also noticed this issue crop up after updating to xorg 1.19.3. I initially thought it was due to me running the Ubuntu 4.11.4-lowlatency mainline kernel, but I also see the issue on 4.12.5.

dozer (matthew-pocock) wrote :

I can confirm this with the nvidia drivers. It happens when using opengl (2.x and 3.x) compositing but not xrender compositing.

dozer (matthew-pocock) wrote :

Oh it's back to being broken when playing factorio.

W (wernerm) wrote :

This bug is driving me nuts, but thankfully a workaround (that has been working for me) is to log out of the initial KDE session and simply log back in.

It's not ideal, but makes the bug more bearable.

W (wernerm) wrote :

PS1: That workaround works (for me) even when the rendering backend is OpenGL.
PS2: I'm also using multiple monitors.

Jason Tiller (jason-sonos) wrote :

I can confirm that logging out and then logging in also resolves the issue for me.

elahens88 (elahens88) wrote :

I have the same problem, when restarting the sddm, or after login and logout is resolved

hants (andreowitsch) wrote :

I can confirm this with
Nvidia Driver 375.66
Ubuntu 16.04 + Kubuntu Backports
KDE Plasma Version 5.8.7
Kde Frameworks Version 5.36.0
and sddm

Workaround: use lightdm instead of sddm:
> sudo dpkg-reconfigure lightdm

W (wernerm) wrote :

I can now also confirm that this bug might be related to sddm.

I replaced sddm with slim and the problem went away:

> sudo apt-get install slim

I have this error also. Anyone can fix it? I can't install Nvidia Drivers Property of this. I have that use nouveau.


Bashar (bashar-mc) wrote :

I have this bug too.
Logout and then Login temporary solves the problem.

Jacob D'Onofrio (jdonofrio728) wrote :

I also am affected by this issue. I am running KDE Neon with the hwe kernel. My nvidia driver is 384.90.

i have this bug too can be fixed by (near fix):

1. change to noveau
2. compositor settings: xrender as rendering backend (no opengl2 & opengl3.1 apparently causes it) tearing prevention full screen repaints.
it should show waay lesser symptoms (occasional flicker of the cursor) than it should

summary: - Mouse pointer behaves strangely
+ Lagging square around mouse pointer
Serhiy Zahoriya (xintx-ua) wrote :

I have this problem only if there are two user accounts running, only on the second one and only after

# prime-select nvidia

16.04, -hwe kernel and xserver, SDDM and KDE from the backports PPA. I don't want to disable OpenGL just for NVidia. Maybe later I'll write a script for switching rendering backend automatically with `prime-select query` and `kwriteconfig`

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-384 (Ubuntu):
status: New → Confirmed


I have a MSI CX61 with Intel card and Nvidia GT740M. I also have this problem with Nvidia Drivers Propietary. Any solution? Thanks.

Aleksandr (anyx) wrote :

You can remove sddm and use lightdm instead until this bug is not fixed

And, someone know when this bug will be fix? I have this bus from April 2017. Thanks!

Erlend Hamnaberg (ngarthl) wrote :

I had this problem with Cinnamon on ubuntu 17.04, and fixed it by adding:

Option "DRI3" "1"

to the nvidia X11 device configuration.

Add Option "DRI3" "1" to XORG not run in KDE Plasma.

When will it bi fix? Thanks.

Chris (cmavr8) wrote :

I also have this on a fresh installation of Ubuntu 16.04 when using nvidia-384.

Most workarounds do not work:
- Option "DRI3" "1" seems to have no effect.
- I'm already using lightdm (default) and not sddm, so the workaround of replacing sddm is N/A.
- I can't use the open-source driver because of other bugs. Booting is a pain and external monitors are not recognized.
- Even when one user is logged in, the problem manifests.

The only thing that works is to log out and back in, without reconnecting any displays. But this is highly inconvenient and not a viable solution.

Can we put more priority on this issue please? What is missing to get it in a queue?

David Guerrero (dguerrero33) wrote :

I'm also having this big on following configuration:
KDE neon User Edition 5.11
Nvidia GT 540m Driver 384.111
happening in both Opengl 2.0 and 3.1 and single/dual display

confirm workaround of logging out and logging in with sddm

David Cardozo (davidnet) wrote :

Same even with the new nvidia drivers. Any solution near ?

Chris (cmavr8) wrote :

For people that do not need the external GPU, they could disable it and only use the integrated Intel driver, after fixing a bug that causes non-booting.

In case anyone needs it, here's what I did, after installing the nvidia-384 driver:
    # Install bumblebee
    apt install bumblebee
    # Add my user to bumblebee group
    gpasswd -a user bumblebee
    # Switch to the intel card
    prime-select intel
    # Add to the grub kernel line: acpi_rev_override=1
    sudo vim /etc/default/grub && sudo update-grub

    # Followed steps 3, 4, 5 from these instructions:
    # If you need the ext card and it doesn't work, try various steps from to enable it

Tore A (toraus83) wrote :

Kubuntu 16.04 LTS. Very annoying bug but logout(after boot) and in again works.

Andrea (n4r3u) wrote :

Confirmed that this should solve the issue.
System settings -> Display and Monitor -> Compositor -> Rendering backend: set XRender instead of OpenGL.

Disabling Compositor solve it aswell but if you want to keep the effects just switch the backend.

Hello Andra.

But OpenGL will should offer more performance. I think that this bug
will should be fix for run with opengl.

El 03/02/18 a las 20:56, Andrea escribió:
> Confirmed that this should solve the issue.
> System settings -> Display and Monitor -> Compositor -> Rendering backend: set XRender instead of OpenGL.
> Disabling Compositor solve it aswell but if you want to keep the effects
> just switch the backend.

Scott Deagan (scott-deagan) wrote :

I experienced this bug on both my laptops (both with Nvidia 9xx series GPUs) with KDE Neon (developer stable), but not on my desktop PC. All are running the latest proprietary Nvidia 390 drivers.

I observed today that the problem only occurs when the Nvidia GPU is in use (sudo prime-select nvidia). The problem disappears if I switch to the Intel GPU (sudo prime-select intel).

Interestingly, the problem does not occur on my laptops when running Kubuntu 17.10, regardless of the GPU in use.

Scott Deagan (scott-deagan) wrote :

As mentioned in other comments here, one workaround is to restart sddm (or to log out and log back in again). Not very convenient.

dino99 (9d9) wrote :
Changed in plasma-workspace (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers-384 (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers-375 (Ubuntu):
status: Confirmed → Invalid

This happen in Ubuntu 16.04 LTS.

Changed in nvidia-graphics-drivers-375 (Ubuntu):
status: Invalid → Confirmed
Changed in nvidia-graphics-drivers-384 (Ubuntu):
status: Invalid → Confirmed
Changed in plasma-workspace (Ubuntu):
status: Invalid → Confirmed
tags: added: xenial
removed: zesty
Serhiy Zahoriya (xintx-ua) wrote :

I've found a more convenient workaround: the square does not appear at least on SDDM if the new session was started not from X but from a TTY.
The command I use in TTY is

$ qdbus --system org.freedesktop.DisplayManager /org/freedesktop/DisplayManager/Seat0 org.freedesktop.DisplayManager.Seat.SwitchToGreeter

Matthias (p-xel) wrote :

Hello everyone, I might have found some new clues about this problem (and a solution, for me at least ;)

I just installed the Nvidia driver 390.48 on my Alienware 17 R4 (Nvidia Geforce GTX 1080) running Ubuntu 18.04. After installing the driver this mouse problem started to occur. But I found out, that this problem only occurs when I have an external monitor connected via a Toshiba Dynadock using DisplayLink (but then it's _not_ limited to the external monitor only!).

If I disconnect the external monitor completely or plug it in directly into my laptops HDMI port the problem disappears. Probably it's a problem with DisplayLink and the Nvidia drivers?

Loïc Gomez (opensource-loic) wrote :

Hello Matthias,

I've read your comment, and I must add I was having this problem while simply using the HDMI port on my laptop. So maybe it's some lucky "fix" in your case ?

I'm not using nvidia drivers anymore since this problem was a real pain and was never fixed, plus another issue caused applications to suddenly stop refreshing at all except with alt+tab (which made quick complicated seeing what I do, "alt+tabbing" every second), so I can't tell if my input is still valid.

Kind regards.

GreyGeek (greygeek77) wrote :

I began having this problem last fall after an update to Nvida from 378 to 384, IIRC.
A couple of weeks ago I installed Kubuntu 18.04 with the Nvidia 390 driver and did NOT have this problem.
I switched back to Neon for personal preference reasons.
A workaround that I've been using is to open a console on the login screen (which shows the mouse pointer defect) using Ctl+Alt+F2 and in that console enter:

sudo systemctl restart sddm

The causes the login screen to reappear and the mouse defect is gone. I continue the log in and the Plasma 5.12.5 desktop appears and behaves normally. Of course logging into the desktop, logging out and logging back in also works but is too slow. The next time I boot up and the mouse artifact appears on the login screen I open the console and use the up arrow to locate the command and hit the Enter key on it.

Joseph Gehring (gehringj) wrote :

I will also confirm that I am using the most up to date version of the graphics drivers and that a logout will fix the issue. hopefully this is resolved in the upcoming update that i can not wait to try out. Keep up the good work. Just in case this is still being looked at by someone my hardware is as follows: Lenovo t530 with the Nvidia NVS 5400m graphics. Keep up the good work ladies and gents! I know that i greatly appreciate the hard work you all put in! It saves me from the disaster that is windows (in my opinion). :)


Tommy_CZ (t-kijas) wrote :

The bug still exists with latest nvidia drivers (!!!)

Bene (benedikt-bleimhofer) wrote :

Was fixed for me during the last updates on Lenovo W540 with Quadro K1100M.
I also updated to the latest displyLink drivers (4.2 08 Mar 2018).
NVIDIA driver version: 384.130

Kostanos (kostanos) wrote :

Have the same issue. My system:
Ubuntu 16.04.5, latest updates. Unity desktop.
Nvidia 384.130 driver.
DisplayLink 4.2, tried also with 4.1, the same issue.

I also uploaded 12 seconds video:

Can't confirm if this is Nvidia or DisplayLink or both drivers issue.

For sure, in my case, uninstalling DisplayLink driver everything works fine.

Kostanos (kostanos) wrote :

Update, logout and login again resolves the issue!!!

Markus Heß (hesmar) wrote :

I have the same issue with KDE neon and Nvidia 396.51 on a Dell XPS 15 9570 (GTX 1050 Ti). Restarting sddm fixes the issue but is really annoying.

Witold Burkiewicz (uunxx) wrote :

this is really annoying problem and apparently nobody cares except for the people that experience it.
But I have found a better workaround that works at least for me:
In /etc/init/sddm.conf after line:
    exec sddm
    killall sddm
    exec sddm

Just restarting sddm automatically right after it strated. No more logout/login manually.

Witold Burkiewicz (uunxx) wrote :

After several restarts the solution above sometimes didn't work, so I've modified it:
    exec sddm
    sleep 2
    killall sddm
    exec sddm
Possibly it will more persistent.

djem (kubuntuuser3231) wrote :

Okey guys i solved this i am on kubuntu i was having the exact same problem, now to the solution

Go in System Settings > Display and Monitor > Compositor and change Rendering backend to xRender
if you still have the same problem get back into driver and thats it.

Witold Burkiewicz (uunxx) wrote :

Crippling your system (switching to xrender and much slower nouveau driver) is not a solution.
What works for me flawlessly for more than a week on KDE Neon:
In file:
   ExecStartPre=/bin/sleep 10
After [Service]
The problem apparently is that something SDDM needs is not initialized before is starts, so delaying SDDM by 10 sec is adequate workaround. Perhaps it could be less, but it doesn't bother me as long as I don't have to log out/log in manually.

Vadym Stupakov (red-eyed) wrote :

Thank you, Witold Burkiewicz, it is really helpful workaround.

gasparka (gasparka) wrote :

I used Witold Burkiewicz fix with GDM on Arch - i had to edit '/etc/systemd/system/display-manager.service'. Thank you all!

Fabian Weise (f.nn) on 2019-01-23
information type: Public → Public Security
Fabian Weise (f.nn) wrote :


are there any updates on this bug so far? Still interested in whether this may be patched at some time. Just installed Kubuntu 16.04 using an NVIDIA Quadro P1000 and I am experiencing the same issues.

Fabian Weise (f.nn) on 2019-01-23
information type: Public Security → Public
information type: Public → Public Security
information type: Public Security → Public
Jamie Hutber (jamie-2) wrote :

For me editing the display-manager.service made no difference.

# temporary safety check until all DMs are converted to correct
# display-manager.service symlink handling
#ExecStartPre=/bin/sh -c '[ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "lightdm" ]'
ExecStartPre=/bin/sleep 10

So I will keep restarting lightdm 3 times per boot

zeitan (antonbas) wrote :

@jamie-2 the suggestion worked but of this way;
# temporary safety check until all DMs are converted to correct
# display-manager.service symlink handling
ExecStartPre=/bin/sleep 10
ExecStartPre=/bin/sh -c '[ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "lightdm" ]'

Happens also to me:
Manjaro 18.0.4
KDE 5.15.4

blastoise (blastoise) wrote :

I can confirm that this is happening only in combination with Display Link drivers.

Yesterday everything was working fine on Ubuntu 18.04 with Nvidia drivers, but today I've installed DisplayLink 5.1 so that I can use 2 external monitors at work and then square appeared.

Hi I might have some updates. I have been reading all the comments but my issue was totally different. I use an Asus Tuf fx504 laptop and recently dual booted to Ubuntu 20.04. However I did not install the nvidia drivers yet. Not this issue of lagging box around cursor happened randomly one day. I then finally installed the nvidia drivers hoping it would help. I have tried logging in and out, reconfigured lightdm as some answers suggested but still the issue persists.

Iam using a dual monitor and currently on nvidia-graphics-driver-440

podila aditya (podila.aditya) wrote :

I have also found this in Ubuntu 20.04 ,Amd ryxen 1700x , nvidia 1070X 8GB system
its bit difficult when coding

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers